Форум программистов «Весельчак У»
  *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

  • Рекомендуем проверить настройки временной зоны в вашем профиле (страница "Внешний вид форума", пункт "Часовой пояс:").
  • У нас больше нет рассылок. Если вам приходят письма от наших бывших рассылок mail.ru и subscribe.ru, то знайте, что это не мы рассылаем.
   Начало  
Наши сайты
Помощь Поиск Календарь Почта Войти Регистрация  
 
Страниц: [1]   Вниз
  Печать  
Автор Тема: Как в Бухгалтерии 1С удалить доки под номерами с определенной буквой?  (Прочитано 3241 раз)
0 Пользователей и 1 Гость смотрят эту тему.
evro
Гость
« : 28-12-2008 12:28 » 

У нас в Бухгалтерии велась нумерация с добавочной буквой, ну например У001 - услуга, Т001 - продажа. Сейчас возникла проблема удаления только документов с буквой У... за определенный период. Как можно их отсортировать и удалить быстро?
Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #1 : 28-12-2008 17:06 » 

Написать обработку, что-то вида:
Код:
Процедура Сформировать()
Док=СоздатьОбъект("Документ"); // Все документы, или же "Документ.ВидДокумента" - если конкретый вид
//Док.УстановитьФильтр(1,0); // Отберем только проведенные
Док.ВыбратьДокументы(НачДата,КонДата);
Пока Док.ПолучитьДокумент()=1 Цикл
Если Найти(Док.НомерДок,"У")<>1 Тогда Продолжить; КонецЕсли; // Если номер документа не начинается с "У" - перейти к следующему
// Если регистр буквы не важен - использова НРег() или ВРег()
Док.Удалить(0); // Пометка на удаление
КонецЦикла;
КонецПроцедуры
НачДата и КонДата - можешь задать прямо в модуле обработки как константы или (что правильней) как поля формы обработки
Записан
evro
Гость
« Ответ #2 : 29-12-2008 13:33 » 

спасибо
Записан
Страниц: [1]   Вверх
  Печать  
 

Powered by SMF 1.1.21 | SMF © 2015, Simple Machines