Форум программистов «Весельчак У»
  *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

  • Рекомендуем проверить настройки временной зоны в вашем профиле (страница "Внешний вид форума", пункт "Часовой пояс:").
  • У нас больше нет рассылок. Если вам приходят письма от наших бывших рассылок mail.ru и subscribe.ru, то знайте, что это не мы рассылаем.
   Начало  
Наши сайты
Помощь Поиск Календарь Почта Войти Регистрация  
 
Страниц: [1]   Вниз
  Печать  
Автор Тема: Отчет БУХ 8.1  (Прочитано 5676 раз)
0 Пользователей и 1 Гость смотрят эту тему.
ArtMari
Участник

ru
Offline Offline

« : 24-02-2009 19:04 » 

Подскажите пожалуйста, какой составить запрос в отчете, чтобы в результате было видно поступление в дебет сч 10.3.2, 10.3.6 и тд  с кредита 71.1.

Таблица отчета примерно на рисунке

* отчет.rar (9.96 Кб - загружено 198 раз.)
Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #1 : 24-02-2009 20:33 » 

Примерно так:
Код:
"ВЫБРАТЬ
| ХозрасчетныйОборотыДтКт.СчетДт КАК СчетДт,
| ХозрасчетныйОборотыДтКт.СчетКт,
| СУММА(ХозрасчетныйОборотыДтКт.СуммаОборот) КАК СуммаОборот
|ИЗ
| РегистрБухгалтерии.Хозрасчетный.ОборотыДтКт(&НачалоПериода, &КонецПериода, , , , , , ) КАК ХозрасчетныйОборотыДтКт
|ГДЕ
| ХозрасчетныйОборотыДтКт.СчетДт = &СчетДт
| И ХозрасчетныйОборотыДтКт.СчетКт = &СчетКт
|СГРУППИРОВАТЬ ПО
| ХозрасчетныйОборотыДтКт.СчетДт,
| ХозрасчетныйОборотыДтКт.СчетКт
|ИТОГИ
| СУММА(СуммаОборот)
|ПО
| СчетДт"// Вставить содержимое обработчика.
Где Хозрасчетный - регистр бухгалтерии (конфа для Украины), а НачалоПериода, КонецПериода, СчетДт, СчетКт нужно задать в параметрах запроса
Записан
ArtMari
Участник

ru
Offline Offline

« Ответ #2 : 24-02-2009 21:00 » 

KIVALS
А из какой таблицы выбирать
 Таб№, ФИО сотрудника, Документ, Наименование топлива и т.д?Пробовала из ХозрасчетныйОбороты, не получается.
Счет дт и кт известны, как их задать, чтобы не выбирать в параметрах?
Записан
ArtMari
Участник

ru
Offline Offline

« Ответ #3 : 25-02-2009 07:26 » 

Подскажите с чего начать?

Вывод строк в таком отчете должен быть в цикле?
Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #4 : 25-02-2009 21:01 » 

Попробуй указанный отчет построить с помощью визарда (конструктора) запросов - там увидишь аналитики по счетам - из них выберешь что нужно. Там же попробуй задать значения счетов...
Полученный текст запроса - в студию
Записан
ArtMari
Участник

ru
Offline Offline

« Ответ #5 : 02-03-2009 05:54 » 

Написала запрос, выдает правильно, но он выдает только счет 10.3, а мне надо далее уточнение 10.3.2 или 10.3.6 или 10.3.9 и тд и наименование не 10.3 - ТОПЛИВО, а наименование 10.3.2 - ТОПЛИВО В БАКАХ, 10.3.6 - ТОПЛИВО ФИЛИАЛ и т.д КАК это сделать?И как можно вообще посмотреть эти названия и коды?

меню Операции --> Планы счетов ---> План
счетов бухгалтерского учета - там только про 10.3 и все

Запрос = Новый Запрос("ВЫБРАТЬ
                      |   ХозрасчетныйДвиженияССубконто.СчетДт КАК СчетДт,
                      |   ХозрасчетныйДвиженияССубконто.СубконтоДт1 КАК Номенклатура,
                      |   ХозрасчетныйДвиженияССубконто.СубконтоКт1 КАК ФизическоеЛицо,
                      |   СУММА(ХозрасчетныйДвиженияССубконто.Сумма) КАК Сумма,
                      |   ХозрасчетныйДвиженияССубконто.Регистратор КАК Документ,
                      |   СУММА(ХозрасчетныйДвиженияССубконто.КоличествоДт) КАК Количество,
                      |   ХозрасчетныйДвиженияССубконто.СубконтоКт1.Код КАК ТабельныйНомер,
                      |   ХозрасчетныйДвиженияССубконто.СубконтоДт1.БазоваяЕдиницаИзмерения КАК ЕдиницаИзмерения
                      |ИЗ
                      |   РегистрБухгалтерии.Хозрасчетный.ДвиженияССубконто(
                      |         &Начало,
                      |         &Конец,
                      |         СчетДт В ИЕРАРХИИ (&Счет10_3)
                      |            И СчетКт В ИЕРАРХИИ (&Счет71_1)) КАК ХозрасчетныйДвиженияССубконто
                      |СГРУППИРОВАТЬ ПО
                      |   ХозрасчетныйДвиженияССубконто.СчетДт,
                      |   ХозрасчетныйДвиженияССубконто.СубконтоДт1,
                      |   ХозрасчетныйДвиженияССубконто.СубконтоКт1,
                      |   ХозрасчетныйДвиженияССубконто.Регистратор,
                      |   ХозрасчетныйДвиженияССубконто.СубконтоКт1.Код,
                      |   ХозрасчетныйДвиженияССубконто.СубконтоДт1.БазоваяЕдиницаИзмерения
                      |ИТОГИ
                      |   СУММА(Сумма),
                      |   СУММА(Количество)
                      |ПО
                      |   ОБЩИЕ,
                      |   СчетДт,
                      |   Номенклатура");

Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #6 : 08-03-2009 20:19 » 

По-моему вот здесь мы уже разобрались как передать 2 счета для отбора
Записан
ArtMari
Участник

ru
Offline Offline

« Ответ #7 : 16-03-2009 15:42 » 

Помогите пожалуйста. В результате в отчете выводится: в дебет счета 10.03 и номенклатура Пенал, потом опять пишет В дебет счета 10.03 и уже все по номенклатуре карандаш и т.д. Т.е для каждого вида номенклатуры пишет еще и счет. Как сделать так, чтобы один раз счет писался, а дальше уже все шло по группировке Физическое лицо?

   
   Запрос = Новый Запрос("ВЫБРАТЬ
                         |   ХозрасчетныйДвиженияССубконто.СчетДт КАК СчетДт,
                         |   ХозрасчетныйДвиженияССубконто.СубконтоДт1 КАК Номенклатура,
                         |   ХозрасчетныйДвиженияССубконто.СубконтоКт1 КАК ФизическоеЛицо,
                         |   СУММА(ХозрасчетныйДвиженияССубконто.Сумма) КАК Сумма,
                         |   ХозрасчетныйДвиженияССубконто.Регистратор КАК Документ,
                         |   СУММА(ХозрасчетныйДвиженияССубконто.КоличествоДт) КАК Количество,
                         |   ХозрасчетныйДвиженияССубконто.СубконтоКт1.Код КАК ТабельныйНомер,
                         |   ХозрасчетныйДвиженияССубконто.СубконтоДт1.БазоваяЕдиницаИзмерения КАК ЕдиницаИзмерения,
                         |   ХозрасчетныйДвиженияССубконто.СчетДт.Код КАК Код,
                         |   ХозрасчетныйДвиженияССубконто.СчетДт.Наименование КАК ИмяСчета
                         |ИЗ
                         |   РегистрБухгалтерии.Хозрасчетный.ДвиженияССубконто(
                         |         &НачПериода,
                         |         &КонПериода,
                         |         СчетДт В ИЕРАРХИИ (&Счет10_3)
                         |            И СчетКт В ИЕРАРХИИ (&Счет71_1)) КАК ХозрасчетныйДвиженияССубконто
                    |
                    |СГРУППИРОВАТЬ ПО
                    |   ХозрасчетныйДвиженияССубконто.СчетДт,
                    |   ХозрасчетныйДвиженияССубконто.СубконтоДт1,
                    |   ХозрасчетныйДвиженияССубконто.СубконтоКт1,
                    |   ХозрасчетныйДвиженияССубконто.Регистратор,
                    |   ХозрасчетныйДвиженияССубконто.СубконтоКт1.Код,
                    |   ХозрасчетныйДвиженияССубконто.СубконтоДт1.БазоваяЕдиницаИзмерения
                         |ИТОГИ
                         |   СУММА(Сумма),
                         |   СУММА(Количество)
                         |ПО
                         |   ОБЩИЕ,
                         |   СчетДт,
                         | Номенклатура,
                    | ФизическоеЛицо");
                   

Запрос.Параметры.Вставить("НачПериода", НачПериода);
Запрос.Параметры.Вставить("КонПериода", КонПериода);
Запрос.Параметры.Вставить("Счет10_3", ПланыСчетов.Хозрасчетный.НайтиПоКоду("10.03"));
Запрос.Параметры.Вставить("Счет71_1", ПланыСчетов.Хозрасчетный.НайтиПоКоду("71.01"));

Результат = Запрос.Выполнить();

Если Результат.Пустой() Тогда
   Возврат;
КонецЕсли;

ТабДок = ЭлементыФормы.ПолеТабличногоДокумента;   
   Макет = ПолучитьМакет("МакетТопливо");
   ОбластьШапкаТаблицы= Макет.ПолучитьОбласть("Шапка");
   ОбластьСчетДт=Макет.ПолучитьОбласть("СчетДт");
   ОбластьДетали= Макет.ПолучитьОбласть("Детали");
   ОбластьИтоги= Макет.ПолучитьОбласть("ОбщиеИтоги");
    ОбластьИтогиПоГруппировке= Макет.ПолучитьОбласть("ИтогПоГруппировке");
   ОбластьИтогПоСчету= Макет.ПолучитьОбласть("ИтогПоСчету");

   ТабДок.Очистить();
   ОбластьШапкаТаблицы.Параметры.НачПериода = Формат(НачПериода, "ДФ=dd.MM.yyyy");
   ОбластьШапкаТаблицы.Параметры.КонПериода = Формат(КонПериода, "ДФ=dd.MM.yyyy");
   ТабДок.Вывести(ОбластьШапкаТаблицы);
  ТабДок.НачатьАвтогруппировкуСтрок();


ВыборкаОбщие = Результат.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
Пока ВыборкаОбщие.Следующий() Цикл
   ВыборкаСчет = ВыборкаОбщие.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
   
   Пока ВыборкаСчет.Следующий() Цикл
      ВыборкаНоменклатура = ВыборкаСчет.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
      
      Пока ВыборкаНоменклатура.Следующий() Цикл
            Выборка = ВыборкаНоменклатура.Выбрать();
            ОбластьСчетДт.Параметры.Заполнить(ВыборкаНоменклатура);
         ТабДок.Вывести(ОбластьСчетДт,1);
      ВыборкаФизЛицо = ВыборкаНоменклатура.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
      Пока ВыборкаФизЛицо.Следующий() Цикл
         Выборка = ВыборкаФизЛицо.Выбрать();

            
         Пока Выборка.Следующий() Цикл
            ОбластьДетали.Параметры.Заполнить(Выборка);
            ТабДок.Вывести(ОбластьДетали);
                       
         КонецЦикла;
              ОбластьИтогиПоГруппировке.Параметры.Заполнить(ВыборкаФизЛицо);

                 ТабДок.Вывести(ОбластьИтогиПоГруппировке);

                         
               КонецЦикла;
                  КонецЦикла;
         ОбластьИтогПоСчету.Параметры.Заполнить(ВыборкаСчет);
       ТабДок.Вывести(ОбластьИтогПоСчету);
      //заполнение итогово по счету в макете
   КонецЦикла;
   ОбластьИтоги.Параметры.Заполнить(ВыборкаОбщие);
   ТабДок.Вывести(ОбластьИтоги);
КонецЦикла;
ТабДок.ЗакончитьАвтогруппировкуСтрок();

Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #8 : 17-03-2009 08:09 » 

Вынести
ОбластьСчетДт.Параметры.Заполнить(ВыборкаНоменклатура);
ТабДок.Вывести(ОбластьСчетДт,1);
за пределы цикла
Пока ВыборкаНоменклатура.Следующий()
И не ленись - форматируй парвильно текст! Это избавит тебя минимум от 50% ошибок!!!!
Записан
ArtMari
Участник

ru
Offline Offline

« Ответ #9 : 17-03-2009 12:16 » 

Я сделала!!! Улыбаюсь)
                
             
« Последнее редактирование: 17-03-2009 15:09 от ArtMari » Записан
Страниц: [1]   Вверх
  Печать  
 

Powered by SMF 1.1.21 | SMF © 2015, Simple Machines