Форум программистов «Весельчак У»
  *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

  • Рекомендуем проверить настройки временной зоны в вашем профиле (страница "Внешний вид форума", пункт "Часовой пояс:").
  • У нас больше нет рассылок. Если вам приходят письма от наших бывших рассылок mail.ru и subscribe.ru, то знайте, что это не мы рассылаем.
   Начало  
Наши сайты
Помощь Поиск Календарь Почта Войти Регистрация  
 
Страниц: [1]   Вниз
  Печать  
Автор Тема: Разность двух дат (1С: 8.0)  (Прочитано 9800 раз)
0 Пользователей и 1 Гость смотрят эту тему.
Juli1000
Гость
« : 03-07-2009 12:20 » 

Всем, доброго времени суток)
Помоги,пожалуйста, разобраться со след. проблемой.
Необходимо вывести в отчёт(построенный с помощью компоновщика) результат разности 2-х дат, а именно ТекущаяДата() и ДатаПрихода(она известна). Результат получить в виде количества дней для дальнейшего сравнения с числом.
Заранее спасибо))))
Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #1 : 04-07-2009 08:16 » 

В 8 тип Дата включает в себя дату и время и задается в секундах от 01.01.0001.
Соответственно если просто отнять 2 даты - получится разница в секундах.
Для себя с написал пару функций, которые разместил в одном из глобальных модулей (из названий думаю понятно будет зачем они):
Код:
// Вычисляет _разницу_ (в днях) между двумя датами.
// Чтобы вычислить _длину_ периода - нужно добавить 1
Функция глРазницаДат(ДатаС, ДатаПо) Экспорт
Разн=Цел((НачалоДня(ДатаПо) - НачалоДня(ДатаС)) / (60 * 60 * 24));
Возврат Разн;
КонецФункции // глРазницаДат()

// Вычисляет _длину_ периода (в днях) между двумя датами. Кон-Нач+1
Функция глДлинаПериода(ДатаС, ДатаПо) Экспорт
Возврат глРазницаДат(ДатаС, ДатаПо)+1;
КонецФункции // глРазницаДат()

Функция глДобавитьДень(Дат, ЧислоДней) Экспорт
Возврат Дат+ЧислоДней*(60 * 60 * 24);
КонецФункции // глДобавитьДень()
Записан
Juli1000
Гость
« Ответ #2 : 06-07-2009 07:04 » 

Kivals,спсибо большое)всё отлично заработало))))
Записан
Страниц: [1]   Вверх
  Печать  
 

Powered by SMF 1.1.21 | SMF © 2015, Simple Machines