Форум программистов «Весельчак У»
  *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

  • Рекомендуем проверить настройки временной зоны в вашем профиле (страница "Внешний вид форума", пункт "Часовой пояс:").
  • У нас больше нет рассылок. Если вам приходят письма от наших бывших рассылок mail.ru и subscribe.ru, то знайте, что это не мы рассылаем.
   Начало  
Наши сайты
Помощь Поиск Календарь Почта Войти Регистрация  
 
Страниц: [1]   Вниз
  Печать  
Автор Тема: Выделени цветом всей строки в Табличном поле  (Прочитано 10539 раз)
0 Пользователей и 1 Гость смотрят эту тему.
Dest
Опытный

ru
Offline Offline

« : 21-08-2009 06:51 » 

Хочу чтоб в табличном поле выделялась вся текущая строка, а не ячейка. Поковырялся в оформлении строки, нашел как выделять строки заполненные в зависимости от значения, а как выделить текущую не пойму. Может кто уже делал подобное?
Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #1 : 21-08-2009 07:26 » 

А в чем проблема в условии проверить на текущую строку?
Записан
Dest
Опытный

ru
Offline Offline

« Ответ #2 : 21-08-2009 08:04 » 

Как изменить цвет фона ячейки табличного поля в зависимости от значения, выводимого в нее?
Код:
Процедура ТоварыПриПолученииДанных(Элемент, ОформленияСтрок)

Для Каждого ОформлениеСтроки Из ОформленияСтрок Цикл
[b]ЗначениеЯчейкиОстаток = ОформлениеСтроки.Ячейки.Остаток.Значение; [/b]тут именно при получении данных, а не при смене строки

Если ЗначениеЯчейкиОстаток <> Неопределено Тогда

Если ЗначениеЯчейкиОстаток < 10 Тогда
ОформлениеСтроки.Ячейки.Остаток.ЦветФона = WebЦвета.Красный;

ИначеЕсли ЗначениеЯчейкиОстаток > 100 Тогда
ОформлениеСтроки.Ячейки.Остаток.ЦветФона = WebЦвета.Желтый;
КонецЕсли;
КонецЕсли;
КонецЦикла;

КонецПроцедуры


А событие ПриАктивизацииСтроки() не имеет параметра ОформленияСтрок
Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #3 : 21-08-2009 08:14 » 

Условие Если ОформлениеСтроки.ДанныеСтроки=Элемент.ТекущаяСтрока Тогда... пробовал?
Записан
Dest
Опытный

ru
Offline Offline

« Ответ #4 : 21-08-2009 08:20 » 

Ну и не получилось
Записан
Dest
Опытный

ru
Offline Offline

« Ответ #5 : 21-08-2009 08:31 » 

все проблема решилась
Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #6 : 21-08-2009 08:33 » 

Отписался бы как именно решилась...
Записан
Dest
Опытный

ru
Offline Offline

« Ответ #7 : 22-08-2009 00:08 » 

не посмотрел сразу как следует
Код:
ЭлементыФормы.Список.РежимВыделенияСтроки =РежимВыделенияСтрокиТабличногоПоля.Строка;
Записан
Страниц: [1]   Вверх
  Печать  
 

Powered by SMF 1.1.21 | SMF © 2015, Simple Machines