Форум программистов «Весельчак У»
  *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

  • Рекомендуем проверить настройки временной зоны в вашем профиле (страница "Внешний вид форума", пункт "Часовой пояс:").
  • У нас больше нет рассылок. Если вам приходят письма от наших бывших рассылок mail.ru и subscribe.ru, то знайте, что это не мы рассылаем.
   Начало  
Наши сайты
Помощь Поиск Календарь Почта Войти Регистрация  
 
Страниц: [1]   Вниз
  Печать  
Автор Тема: Отмена Форматирования числа  (Прочитано 4976 раз)
0 Пользователей и 1 Гость смотрят эту тему.
Элексир
Помогающий

ru
Offline Offline
Пол: Мужской

« : 04-10-2009 12:51 » 

Всем здравствуйте. Подскажите, как решить мою проблемку.
Я вытаскиваю из excel значения ячеек. Но они там уже отформатированы. Поставлен "разделитель групп разрядов" вместо "." используется ",". Как мне преобразовать числа в стандартный 1с вид типа "4506.28" а не "4 506, 28"?
« Последнее редактирование: 04-10-2009 13:56 от Sel » Записан
Mr_Lambert_13
Гость
« Ответ #1 : 04-10-2009 14:29 » 

В 1С я конечно новичок, но есть опыт работы с компьютерами. Сейчас проверил одну теорию открыл Excel вбил пару чисел через разделитесь "," и пару через точку, сохранил, закрыл. Зашёл в Панель Управления - Язык и Региональные стандарты изменил разделитель целой и дробной части на "." открываю снова Excel и там все числа изменились. Т.е. было  123,45 а стало 123.45. А вот по поводу пробела не знаю.
Записан
Элексир
Помогающий

ru
Offline Offline
Пол: Мужской

« Ответ #2 : 04-10-2009 15:26 » 

Mr_Lambert_13, спасибо за помощь, я также попробовал, но это форматирует уже восмерька.


Мне это вобще нужно для семерки. но там как выцеплять значения я не знаю. поэтому делаю в восьмерке. а она кидает форматированные цифры в текст. А семерка не хочет их читать.
можно конечно в семерке написать код на поиск пробелов и запятых, но вдруг что нибудь в 8-ке есть. 
Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #3 : 05-10-2009 11:26 » 

А Excel их видит как числа?
Тогда 1С (и 7.7, и 8.Х) прекрасно понимает данные через ActiveSheet.Cells(Row,Col).Value
Записан
Элексир
Помогающий

ru
Offline Offline
Пол: Мужской

« Ответ #4 : 05-10-2009 20:00 » 

Да Excel их разбирает.
Код:
Процедура КнопкаВыполнитьНажатие(Кнопка)
Т = Новый ТекстовыйДокумент;
КС=0;     
КК=0;
КС=КС+8;
КК=КК+3;
Экзель.ОткрытьФайл(Файло);
КоличествоЛистов = Экзель.ПолучитьКоличествоЛистов();
Экзель.ОткрытьЛист(КоличествоЛистов);
КоличествоКолонок = Экзель.ПолучитьКоличествоКолонок();
КоличествоСтрок = Экзель.ПолучитьКоличествоСтрок();
пока (КоличествоСтрок-КС)>6 цикл
Если (КС+6)<КоличествоСтрок тогда
КС=КС+6;
ЗначениеЯчейки=СокрЛП(Экзель.ПолучитьЗначениеЯчейки(КС, 4));
Сообщить("ЛицСч "+Прав(ЗначениеЯчейки,4));
Т.ДобавитьСтроку(ЗначениеЯчейки);
КонецЕсли;

Если (КК+6)<КС тогда
КК=КК+6;
ЗначениеЯчейки2=СокрЛП(Экзель.ПолучитьЗначениеЯчейки(КК,8));
Сообщить(ЗначениеЯчейки2);
Т.ДобавитьСтроку(ЗначениеЯчейки2);
КонецЕсли;
КонецЦикла;
Т.Записать("C:\Док.txt","utf-8");//,"windows-1251");
КонецПроцедуры
Kivals, посмотри пожалуйста код
Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #5 : 06-10-2009 08:55 » 

Что за объект "Экзель" и почему у него русские методы?
Записан
Элексир
Помогающий

ru
Offline Offline
Пол: Мужской

« Ответ #6 : 06-10-2009 15:28 » 

это внешняя компонента. которая подключается при открытии формы.
А что можно использовать что то другое?
Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #7 : 07-10-2009 06:02 » 

Естественно. Как раз в паралельной теме именно про Excel: http://forum.shelek.ru/index.php/topic,21956.msg215943.html#msg215943
Записан
Страниц: [1]   Вверх
  Печать  
 

Powered by SMF 1.1.21 | SMF © 2015, Simple Machines