Форум программистов «Весельчак У»
  *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

  • Рекомендуем проверить настройки временной зоны в вашем профиле (страница "Внешний вид форума", пункт "Часовой пояс:").
  • У нас больше нет рассылок. Если вам приходят письма от наших бывших рассылок mail.ru и subscribe.ru, то знайте, что это не мы рассылаем.
   Начало  
Наши сайты
Помощь Поиск Календарь Почта Войти Регистрация  
 
Страниц: 1 [2]  Все   Вниз
  Печать  
Автор Тема: Еженедельный отчет, а также ежемесячный отчет  (Прочитано 20880 раз)
0 Пользователей и 1 Гость смотрят эту тему.
Rinat
Гость
« Ответ #30 : 04-12-2009 11:23 » 

Здравствуите, я на этом саите первыи раз, я начинающии программист в 1С, у меня к Вам вопрос, буду весьма признателен Вам если Вы мне поможете.
Суть вопроса в следующем. Можно ли сделать так чтобы в 8.1 формировалась такая же лицевая карта как и в 7.7, и если можно, то что нужно для этого?
Записан
staff
Помогающий

ua
Offline Offline
Пол: Мужской

« Ответ #31 : 04-12-2009 11:27 » 

написать программу для вывода лицевой карты
Записан
Rinat
Гость
« Ответ #32 : 04-12-2009 11:29 » 

А как это сделать?
Записан
Rinat
Гость
« Ответ #33 : 04-12-2009 11:31 » 

Можно ли просто скопировать макет и поменять и поставить его на 8ку.
Записан
staff
Помогающий

ua
Offline Offline
Пол: Мужской

« Ответ #34 : 04-12-2009 11:32 » 

извините но вы сейчас понимаете что хотите, вы перед тем как задать вопрос сначала обдумайте его, так как ничего понять не возможно, есть код процедуры формирования лицевой карты, где она должна выводится, откуда брать значения и т. д..
Записан
Rinat
Гость
« Ответ #35 : 04-12-2009 11:39 » 

Я работаю вторую неделю, и пока для меня эти термины даже не знакомы...
Записан
staff
Помогающий

ua
Offline Offline
Пол: Мужской

« Ответ #36 : 04-12-2009 11:43 » 

вы хоть в 1С программировали раньше?
Записан
Rinat
Гость
« Ответ #37 : 04-12-2009 12:19 » 

неа, до этого никогда.
Записан
staff
Помогающий

ua
Offline Offline
Пол: Мужской

« Ответ #38 : 04-12-2009 12:26 » 

h**p://v8.1c.ru/overview/   посмотрите этот сайт там описаны некоторые принципы для программирования в 1С
« Последнее редактирование: 04-12-2009 12:32 от Алексей1153++ » Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #39 : 04-12-2009 13:01 » 

Rinat, макет скопировать можно, алгоритм формирования придется переписывать.
Попробуй в просторах Интернета найти ЕСИС для 8 (Единая справочно-информационная система), в ней есть книга А.П. Габец, Д.И. Гончаров "1С:Предприятие 8.0 Простые примеры разработки" - начни изучение с нее
Записан
Rinat
Гость
« Ответ #40 : 04-12-2009 13:15 » 

Благодарю Вас, спасибо Вам.
Записан
staff
Помогающий

ua
Offline Offline
Пол: Мужской

« Ответ #41 : 04-12-2009 14:13 » 

по поводу формирования недельного отчета, последний день месяца ноября (30 ноября) припадает на понедельник и исходя из запроса у меня получается что 30 ноября относится к декабрю. Как переделать запрос так, чтобы 30 ноября у меня относилось к 5 неделе ноября месяца?
Записан
staff
Помогающий

ua
Offline Offline
Пол: Мужской

« Ответ #42 : 08-12-2009 12:32 » 

как скомбинировать отчет так, что бы сперва выводился отчет по суткам с 1 по 7, а потом общий недельный по этим 7 дням?
Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #43 : 08-12-2009 14:42 » 

Как переделать запрос так, чтобы 30 ноября у меня относилось к 5 неделе ноября месяца?
Никак. Только вложенным запросом с ручным определением периода
как скомбинировать отчет так, что бы сперва выводился отчет по суткам с 1 по 7, а потом общий недельный по этим 7 дням?
Я ошибся в посте http://forum.shelek.ru/index.php/topic,22601.msg219695.html#msg219695, чем ввел тебя в заблуждение - извиняюсь. На самом деле ИТОГИ ПО можно (и нужно) также использовать для получения промежуточных итогов, но при этом выборку нужно делать по группировкам:
Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
Попробуй сам разобраться как привязать блок ИТОГИ ПО к нужному тебе функционалу
Записан
staff
Помогающий

ua
Offline Offline
Пол: Мужской

« Ответ #44 : 09-12-2009 11:43 » 

теперь я сам запутался (((
у меня есть суточный отчет:
Код:
Запрос = Новый запрос;
Запрос.Текст =
"ВЫБРАТЬ
| ТеоретическийБалансПодсолнечника.Регистратор КАК Регистратор,
...................
| СУММА(ТеоретическийБалансПодсолнечника.x) КАК x,
...................
| СУММА(ТеоретическийБалансПодсолнечника.c) КАК c,
...................
|ИЗ
| РегистрНакопления.ТеоретическийБалансПодсолнечника КАК ТеоретическийБалансПодсолнечника
|ГДЕ
| ТеоретическийБалансПодсолнечника.Период МЕЖДУ &НачалоДня И &КонецДня
|
|СГРУППИРОВАТЬ ПО
| ТеоретическийБалансПодсолнечника.Регистратор
|
|УПОРЯДОЧИТЬ ПО
| Регистратор
|ИТОГИ
| СУММА(z),
................
| СУММА(x),
...................
| СУММА(c),
...................
|ПО
| Регистратор
|АВТОУПОРЯДОЧИВАНИЕ";

а так же и недельный:
Код:
Запрос = Новый запрос;
Запрос.Текст =
"ВЫБРАТЬ
| КОНЕЦПЕРИОДА(ТеоретическийБалансПодсолнечника.Период, НЕДЕЛЯ) КАК Регистратор,
| (СУММА(ТеоретическийБалансПодсолнечника.z2)+СУММА(ТеоретическийБалансПодсолнечника.x2))/СУММА(ТеоретическийБалансПодсолнечника.k) КАК k1,
.............
|ИЗ
| РегистрНакопления.ТеоретическийБалансПодсолнечника КАК ТеоретическийБалансПодсолнечника
|ГДЕ
| ТеоретическийБалансПодсолнечника.Период МЕЖДУ &НачалоДня И &КонецДня
|
|СГРУППИРОВАТЬ ПО
| КОНЕЦПЕРИОДА(ТеоретическийБалансПодсолнечника.Период, НЕДЕЛЯ)
|
|УПОРЯДОЧИТЬ ПО
| Регистратор
|ИТОГИ
| СУММА(k1),
....................
| СУММА(k5)
|ПО
| Регистратор
|АВТОУПОРЯДОЧИВАНИЕ";


как их соединить в единое целое так, чтобы выводилась неделя с понедельника по воскресенье, а в конце недели общий недельный отчет по этим 7 дням?
Записан
staff
Помогающий

ua
Offline Offline
Пол: Мужской

« Ответ #45 : 14-12-2009 15:12 » 

сгруппировал два запроса в одну процедуру

Код:
Процедура КнопкаСформировать1Нажатие(Элемент)
// Вставить содержимое обработчика.
Запрос = Новый запрос;
Запрос.Текст =
"ВЫБРАТЬ
| ТеоретическийБалансПодсолнечника.Регистратор КАК Регистратор,
| СУММА(ТеоретическийБалансПодсолнечника.z) КАК z,
....................
| СУММА(ТеоретическийБалансПодсолнечника.x) КАК x,
....................
| СУММА(ТеоретическийБалансПодсолнечника.c) КАК c,
....................
|ИЗ
| РегистрНакопления.ТеоретическийБалансПодсолнечника КАК ТеоретическийБалансПодсолнечника
|ГДЕ
| ТеоретическийБалансПодсолнечника.Период МЕЖДУ &НачалоДня И &КонецДня
|
|СГРУППИРОВАТЬ ПО
| ТеоретическийБалансПодсолнечника.Регистратор
|
|УПОРЯДОЧИТЬ ПО
| Регистратор
|ИТОГИ
| СУММА(z),
......................
| СУММА(x),
................
| СУММА(c),
................
|ПО
| Регистратор
|АВТОУПОРЯДОЧИВАНИЕ";
Запрос.УстановитьПараметр("НачалоДня", НачалоДня(НачПериода));
Запрос.УстановитьПараметр("КонецДня", КонецДня(КонПериода));
Результат = Запрос.Выполнить();
ВыборкаРегистратор = Результат.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
темп = Новый ТабличныйДокумент;
ТабДок = ПолучитьМакет("Макет");

ОбластьВведение = ТабДок.ПолучитьОбласть("Введение");
Темп.Вывести(ОбластьВведение);

Пока ВыборкаРегистратор.Следующий() цикл
если ВыборкаРегистратор<>Неопределено тогда
ОбластьРегистратор = ТабДок.ПолучитьОбласть("Регистратор");
ОбластьРегистратор.Параметры.Дата=ВыборкаРегистратор.Регистратор.Дата;
ОбластьРегистратор.Параметры.z=ВыборкаРегистратор.z;
......
ОбластьРегистратор.Параметры.x=ВыборкаРегистратор.x;
......
ОбластьРегистратор.Параметры.c=ВыборкаРегистратор.c;
.......
Темп.Вывести(ОбластьРегистратор);
    конецесли;
конеццикла;

Запрос = Новый запрос;
Запрос.Текст =
"ВЫБРАТЬ
        |КОНЕЦПЕРИОДА(ТеоретическийБалансПодсолнечника.Период, НЕДЕЛЯ) КАК Регистратор,
| СУММА(ТеоретическийБалансПодсолнечника.k) КАК k,
............
|ИЗ
| РегистрНакопления.ТеоретическийБалансПодсолнечника КАК ТеоретическийБалансПодсолнечника
|ГДЕ
| ТеоретическийБалансПодсолнечника.Период МЕЖДУ &НачалоДня И &КонецДня
|
|СГРУППИРОВАТЬ ПО
| КОНЕЦПЕРИОДА(ТеоретическийБалансПодсолнечника.Период, НЕДЕЛЯ)
|
|УПОРЯДОЧИТЬ ПО
| Регистратор
|ИТОГИ
| СУММА(k1),
.......
|ПО
| Регистратор
|АВТОУПОРЯДОЧИВАНИЕ";
Запрос.УстановитьПараметр("НачалоДня", НачалоДня(НачПериода));
Запрос.УстановитьПараметр("КонецДня", КонецДня(КонПериода));
Результат = Запрос.Выполнить();
ВыборкаПериод = Результат.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);

Пока ВыборкаПериод.Следующий() цикл
если ВыборкаПериод<> неопределено тогда
ОбластьПериод = ТабДок.ПолучитьОбласть("Период");
ОбластьПериод.Параметры.Дата1=ВыборкаПериод.Регистратор;
ОбластьПериод.Параметры.k=ВыборкаПериод.k;
........
Темп.Вывести(ОбластьПериод);

конецесли;
конеццикла;

ТабФорма = Отчеты.ТеоретическийБалансПодсолнечника.ПолучитьФорму("ФормаТаблицы");
ТабФорма.Открыть();
ТабФорма.ЭлементыФормы.Результат.Вывести(Темп);
КонецПроцедуры

вот что у меня при выводе получается, а хотелось что бы прошла неделя (с понедельника по воскресенье и в конце недельный общий отчет) вывелся отчет и так далее

* суточно-недельный отчет.PNG (50.37 Кб - загружено 194 раз.)
Записан
staff
Помогающий

ua
Offline Offline
Пол: Мужской

« Ответ #46 : 23-02-2010 09:06 » 

добрый день
по поводу формирования отчета, после недельных работ с доводкой процедуры так ничего толком и не получилось, все равно недельный данные формируются в конце ежедневных отчетов ((((
что можете посоветовать с группировкой процедуры???
Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #47 : 23-02-2010 10:07 » 

staff, выкладывай cf - буду разбираться
Offtopic:
Ну вот наконец-то до тебя добрался Улыбаюсь
Записан
staff
Помогающий

ua
Offline Offline
Пол: Мужской

« Ответ #48 : 23-02-2010 10:07 » 

сделано
« Последнее редактирование: 23-02-2010 10:12 от staff » Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #49 : 23-02-2010 11:27 » 

Конфигурация -> Отчеты -> ТеоретическийБалансПодсолнечника -> ФормаОтчета
Процедура КнопкаСформировать1Нажатие(Элемент) и Процедура КнопкаСформировать5Нажатие(Элемент)

по этим двум процедурам у меня проблемы ((((

Сначал рассказываю идею. Ты пишешь текст запроса в таком виде (псевдокод):
Код:
ТекстЗапроса="
  |ВЫБРАТЬ
  |  (Выражение, например: КОНЕЦПЕРИОДА(ТаблицаЗапроса.Период, НЕДЕЛЯ)) КАК Группировка1,
  |  (Выражение, например: ТаблицаЗапроса.Регистратор) Группировка2,
  |  СУММА(ТаблицаЗапроса.ПолеСуммы) КАК СуммаПоляСуммы,
  |  ...,
  |  СУММА(ТаблицаЗапроса.ПолеКво) КАК СуммаПоляКво
  |ИЗ
  |  НазваниеТаблицыВКонфигураторе КАК ТаблицаЗапроса
  |СГРУППИРОВАТЬ ПО
  |  (Выражение аналогичное Группировка 1),
  |  (Выражение аналогичное Группировка 2)
  |ИТОГИ
  |  СУММА(СуммаПоляСуммы),
  |  ...,
  |  СУММА(СуммаПоляКво)
  |ПО
  |  Группировка1,
  |  Группировка2
  |";

Потом обход по результатам запроса выполняется так:
Код:
Результат=Запрос.Выполнить();
Выборка1=Результат.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
Пока Выборка1.Следующий() Цикл
// Здесь работаем с итогами по Группировке 1
// Здесь что-то делаем ДО детализации по группировке 2
Выборка2=Выборка1.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
// !!! Внимание: выборка 2 - это выборка из выборки 1
Пока Выборка2.Следующий() Цикл
// Здесь работаем с итогами по Группировке 2
КонецЦикла;
// Здесь что-то делаем ПОСЛЕ детализации по группировке 2
КонецЦикла;
Заметь: чем больше полей в блоке запроса ИТОГИ...ПО... (т.е. чем больше группировок итогов) - тем больше вложенных циклов у тебя будет

Вот собственно и все.

В итоге КнопкаСформировать1Нажатие() получилась вот такая (почитай в синтакс помощнике про ЗаполнитьЗначенияСвойств()):
Код:
Процедура КнопкаСформировать1Нажатие(Элемент)
// Вставить содержимое обработчика.
Запрос = Новый запрос;
Запрос.Текст =
"ВЫБРАТЬ
| ТеоретическийБалансПодсолнечника.Регистратор КАК Регистратор,
| КОНЕЦПЕРИОДА(ТеоретическийБалансПодсолнечника.Период, НЕДЕЛЯ) КАК КонецНедели,
| СУММА(ТеоретическийБалансПодсолнечника.z) КАК z,
| СУММА(ТеоретическийБалансПодсолнечника.z1) КАК z1,
| СУММА(ТеоретическийБалансПодсолнечника.z2) КАК z2,
| СУММА(ТеоретическийБалансПодсолнечника.z3) КАК z3,
| СУММА(ТеоретическийБалансПодсолнечника.z4) КАК z4,
| СУММА(ТеоретическийБалансПодсолнечника.z8) КАК z8,
| СУММА(ТеоретическийБалансПодсолнечника.z9) КАК z9,
| СУММА(ТеоретическийБалансПодсолнечника.z10) КАК z10,
| СУММА(ТеоретическийБалансПодсолнечника.z11) КАК z11,
| СУММА(ТеоретическийБалансПодсолнечника.z12) КАК z12,
| СУММА(ТеоретическийБалансПодсолнечника.z13) КАК z13,
| СУММА(ТеоретическийБалансПодсолнечника.z14) КАК z14,
| СУММА(ТеоретическийБалансПодсолнечника.z15) КАК z15,
| СУММА(ТеоретическийБалансПодсолнечника.z16) КАК z16,
| СУММА(ТеоретическийБалансПодсолнечника.z17) КАК z17,
| СУММА(ТеоретическийБалансПодсолнечника.z18) КАК z18,
| СУММА(ТеоретическийБалансПодсолнечника.z19) КАК z19,
| СУММА(ТеоретическийБалансПодсолнечника.x) КАК x,
| СУММА(ТеоретическийБалансПодсолнечника.x1) КАК x1,
| СУММА(ТеоретическийБалансПодсолнечника.x2) КАК x2,
| СУММА(ТеоретическийБалансПодсолнечника.x3) КАК x3,
| СУММА(ТеоретическийБалансПодсолнечника.x4) КАК x4,
| СУММА(ТеоретическийБалансПодсолнечника.x8) КАК x8,
| СУММА(ТеоретическийБалансПодсолнечника.x9) КАК x9,
| СУММА(ТеоретическийБалансПодсолнечника.x10) КАК x10,
| СУММА(ТеоретическийБалансПодсолнечника.x11) КАК x11,
| СУММА(ТеоретическийБалансПодсолнечника.x12) КАК x12,
| СУММА(ТеоретическийБалансПодсолнечника.x13) КАК x13,
| СУММА(ТеоретическийБалансПодсолнечника.x14) КАК x14,
| СУММА(ТеоретическийБалансПодсолнечника.x15) КАК x15,
| СУММА(ТеоретическийБалансПодсолнечника.x16) КАК x16,
| СУММА(ТеоретическийБалансПодсолнечника.x17) КАК x17,
| СУММА(ТеоретическийБалансПодсолнечника.x18) КАК x18,
| СУММА(ТеоретическийБалансПодсолнечника.x19) КАК x19,
| СУММА(ТеоретическийБалансПодсолнечника.c) КАК c,
| СУММА(ТеоретическийБалансПодсолнечника.c2) КАК c2,
| СУММА(ТеоретическийБалансПодсолнечника.c4) КАК c4,
| СУММА(ТеоретическийБалансПодсолнечника.c5) КАК c5,
| СУММА(ТеоретическийБалансПодсолнечника.c6) КАК c6,
| СУММА(ТеоретическийБалансПодсолнечника.c7) КАК c7,
| СУММА(ТеоретическийБалансПодсолнечника.c9) КАК c9,
| СУММА(ТеоретическийБалансПодсолнечника.c10) КАК c10,
| СУММА(ТеоретическийБалансПодсолнечника.c11) КАК c11,
| СУММА(ТеоретическийБалансПодсолнечника.c12) КАК c12,
| СУММА(ТеоретическийБалансПодсолнечника.c13) КАК c13,
| СУММА(ТеоретическийБалансПодсолнечника.c14) КАК c14,
| СУММА(ТеоретическийБалансПодсолнечника.c15) КАК c15,
| СУММА(ТеоретическийБалансПодсолнечника.c16) КАК c16,
| СУММА(ТеоретическийБалансПодсолнечника.c17) КАК c17,
| СУММА(ТеоретическийБалансПодсолнечника.c18) КАК c18,
| СУММА(ТеоретическийБалансПодсолнечника.c19) КАК c19,
| СУММА(ТеоретическийБалансПодсолнечника.c20) КАК c20,
| СУММА(ТеоретическийБалансПодсолнечника.c21) КАК c21,
| СУММА(ТеоретическийБалансПодсолнечника.c22) КАК c22,
| СУММА(ТеоретическийБалансПодсолнечника.c23) КАК c23,
| СУММА(ТеоретическийБалансПодсолнечника.c24) КАК c24,
| СУММА(ТеоретическийБалансПодсолнечника.c25) КАК c25,
| СУММА(ТеоретическийБалансПодсолнечника.c26) КАК c26,
| СУММА(ТеоретическийБалансПодсолнечника.c27) КАК c27,
| СУММА(ТеоретическийБалансПодсолнечника.c28) КАК c28,
| СУММА(ТеоретическийБалансПодсолнечника.c29) КАК c29,
| СУММА(ТеоретическийБалансПодсолнечника.c30) КАК c30,
| СУММА(ТеоретическийБалансПодсолнечника.c31) КАК c31,
| СУММА(ТеоретическийБалансПодсолнечника.c32) КАК c32,
| СУММА(ТеоретическийБалансПодсолнечника.c33) КАК c33,
| СУММА(ТеоретическийБалансПодсолнечника.c34) КАК c34,
| СУММА(ТеоретическийБалансПодсолнечника.c35) КАК c35,
| СУММА(ТеоретическийБалансПодсолнечника.k) КАК k,
| СУММА(ТеоретическийБалансПодсолнечника.k2) КАК k2,
| СУММА(ТеоретическийБалансПодсолнечника.k3) КАК k3,
| СУММА(ТеоретическийБалансПодсолнечника.k4) КАК k4,
| СУММА(ТеоретическийБалансПодсолнечника.k5) КАК k5
|ИЗ
| РегистрНакопления.ТеоретическийБалансПодсолнечника КАК ТеоретическийБалансПодсолнечника
|ГДЕ
| ТеоретическийБалансПодсолнечника.Период МЕЖДУ &НачалоДня И &КонецДня
|
|СГРУППИРОВАТЬ ПО
| ТеоретическийБалансПодсолнечника.Регистратор,
| КОНЕЦПЕРИОДА(ТеоретическийБалансПодсолнечника.Период, НЕДЕЛЯ)
|
|УПОРЯДОЧИТЬ ПО
| Регистратор
|ИТОГИ
| СУММА(z),
| СУММА(z1),
| СУММА(z2),
| СУММА(z3),
| СУММА(z4),
| СУММА(z8),
| СУММА(z9),
| СУММА(z10),
| СУММА(z11),
| СУММА(z12),
| СУММА(z13),
| СУММА(z14),
| СУММА(z15),
| СУММА(z16),
| СУММА(z17),
| СУММА(z18),
| СУММА(z19),
| СУММА(x),
| СУММА(x1),
| СУММА(x2),
| СУММА(x3),
| СУММА(x4),
| СУММА(x8),
| СУММА(x9),
| СУММА(x10),
| СУММА(x11),
| СУММА(x12),
| СУММА(x13),
| СУММА(x14),
| СУММА(x15),
| СУММА(x16),
| СУММА(x17),
| СУММА(x18),
| СУММА(x19),
| СУММА(c),
| СУММА(c2),
| СУММА(c4),
| СУММА(c5),
| СУММА(c6),
| СУММА(c7),
| СУММА(c9),
| СУММА(c10),
| СУММА(c11),
| СУММА(c12),
| СУММА(c13),
| СУММА(c14),
| СУММА(c15),
| СУММА(c16),
| СУММА(c17),
| СУММА(c18),
| СУММА(c19),
| СУММА(c20),
| СУММА(c21),
| СУММА(c22),
| СУММА(c23),
| СУММА(c24),
| СУММА(c25),
| СУММА(c26),
| СУММА(c27),
| СУММА(c28),
| СУММА(c29),
| СУММА(c30),
| СУММА(c31),
| СУММА(c32),
| СУММА(c33),
| СУММА(c34),
| СУММА(c35),
| СУММА(k),
| СУММА(k2),
| СУММА(k3),
| СУММА(k4),
| СУММА(k5)
|ПО
| КонецНедели,
| Регистратор
|АВТОУПОРЯДОЧИВАНИЕ";
Запрос.УстановитьПараметр("НачалоДня", НачалоДня(НачПериода));
Запрос.УстановитьПараметр("КонецДня", КонецДня(КонПериода));

темп = Новый ТабличныйДокумент;
ТабДок = ПолучитьМакет("Макет");

ОбластьВведение = ТабДок.ПолучитьОбласть("Введение");
Темп.Вывести(ОбластьВведение);

Результат = Запрос.Выполнить();
ВыборкаПериод = Результат.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
Пока ВыборкаПериод.Следующий() Цикл
ВыборкаРегистратор = ВыборкаПериод.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
Пока ВыборкаРегистратор.Следующий() Цикл
Если ВыборкаРегистратор=Неопределено Тогда Продолжить; КонецЕсли;

ОбластьРегистратор = ТабДок.ПолучитьОбласть("Регистратор");
ОбластьРегистратор.Параметры.Дата=ВыборкаРегистратор.Регистратор.Дата;
ЗаполнитьЗначенияСвойств(ОбластьРегистратор.Параметры, ВыборкаРегистратор,
  "z,z1,z2,z3,z4,z8,z9,z10,z11,z12,z13,z14,z15,z16,z17,z18,z19,"+
  "x,x1,x2,x3,x4,x8,x9,x10,x11,x12,x13,x14,x15,x16,x17,x18,x19,"+
  "c,c2,c4,c5,c6,c7,c9,c11,c12,c13,c14,c15,c16,c17,c19,c20,c21,"+
  "c22,c23,c24,c25,c26,c27,c28,c29,c30,c31,c32,c33,c34,c35"+
  "");
Темп.Вывести(ОбластьРегистратор);
КонецЦикла;

ОбластьПериод = ТабДок.ПолучитьОбласть("Период");
ОбластьПериод.Параметры.Дата1=ВыборкаПериод.Регистратор;
ЗаполнитьЗначенияСвойств(ОбластьПериод.Параметры, ВыборкаПериод,
  "k,k2,k3,k4,k5");
ОбластьПериод.Параметры.k1=//ВыборкаПериод.k1;
  ((ВыборкаПериод.z2) + (ВыборкаПериод.x2)) / (ВыборкаПериод.k);
ОбластьПериод.Параметры.k6=//ВыборкаПериод.k6;
  ((ВыборкаПериод.z4) + (ВыборкаПериод.x4)) / (ВыборкаПериод.k);
//ОбластьПериод.Параметры.k7=ВыборкаПериод.k7;
//ОбластьПериод.Параметры.k8=ВыборкаПериод.k8;
//ОбластьПериод.Параметры.k9=ВыборкаПериод.k9;
//ОбластьПериод.Параметры.k10=ВыборкаПериод.k10;
//ОбластьПериод.Параметры.k11=ВыборкаПериод.k11;
//ОбластьПериод.Параметры.k12=ВыборкаПериод.k12;
//ОбластьПериод.Параметры.k13=ВыборкаПериод.k13;
//ОбластьПериод.Параметры.k14=ВыборкаПериод.k14;
//ОбластьПериод.Параметры.k15=ВыборкаПериод.k15;
//ОбластьПериод.Параметры.k16=ВыборкаПериод.k16;
//ОбластьПериод.Параметры.k17=ВыборкаПериод.k17;
//ОбластьПериод.Параметры.k18=ВыборкаПериод.k18;
//ОбластьПериод.Параметры.k19=ВыборкаПериод.k19;
//ОбластьПериод.Параметры.k20=ВыборкаПериод.k20;
//ОбластьПериод.Параметры.k21=ВыборкаПериод.k21;
//ОбластьПериод.Параметры.k22=ВыборкаПериод.k22;
//ОбластьПериод.Параметры.k23=ВыборкаПериод.k23;
//ОбластьПериод.Параметры.k24=ВыборкаПериод.k24;
//ОбластьПериод.Параметры.k25=ВыборкаПериод.k25;
//ОбластьПериод.Параметры.k26=ВыборкаПериод.k26;
//ОбластьПериод.Параметры.k27=ВыборкаПериод.k27;
Темп.Вывести(ОбластьПериод);
КонецЦикла;
ТабФорма = Отчеты.ТеоретическийБалансПодсолнечника.ПолучитьФорму("ФормаТаблицы");
ТабФорма.Открыть();
ТабФорма.ЭлементыФормы.Результат.Вывести(Темп);
КонецПроцедуры

Мне было лень прописывать все коэффициенты в результате - это сделаешь сам по аналогии с k1 и k6.
Аналогично для КнопкаСформировать5Нажатие().
Записан
staff
Помогающий

ua
Offline Offline
Пол: Мужской

« Ответ #50 : 23-02-2010 11:31 » 

понял, сейчас попробую реализовать
Записан
Страниц: 1 [2]  Все   Вверх
  Печать  
 

Powered by SMF 1.1.21 | SMF © 2015, Simple Machines