Форум программистов «Весельчак У»
  *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

  • Рекомендуем проверить настройки временной зоны в вашем профиле (страница "Внешний вид форума", пункт "Часовой пояс:").
  • У нас больше нет рассылок. Если вам приходят письма от наших бывших рассылок mail.ru и subscribe.ru, то знайте, что это не мы рассылаем.
   Начало  
Наши сайты
Помощь Поиск Календарь Почта Войти Регистрация  
 
Страниц: [1]   Вниз
  Печать  
Автор Тема: Табличный документ построителя отчета  (Прочитано 4887 раз)
0 Пользователей и 1 Гость смотрят эту тему.
Dest
Опытный

ru
Offline Offline

« : 26-01-2010 03:25 » 

1с 8.0
Здравствуйте люди!
Создаю отчет с использованием построителя отчетов, макет генерируется автоматически, и у меня возникло парачка вопросов:
1. Как задать заголовок табличного документа, не тот заголовок (Построитель.ТекстЗаголовка = "..."), что в самом документе в области заголовок, а то место, где обычно пишется "Таблица";
2.В табличном документе есть колонка "Количество",  соответственно там должно быть число, но там стоит тип строка и почему-то у меня там ничего не выводится (может потому, что количество = 0), я попытался изменить тип значения на число

Код:
КЧ = новый КвалификаторыЧисла(10,2);
Число = новый ОписаниеТипов(КЧ);

Макет = Построитель.Макет;

ТекущаяОбласть = Неопределено;
Пока Истина Цикл
ТекущаяОбласть = Макет.НайтиТекст("Количество", ТекущаяОбласть);

Если ТекущаяОбласть = Неопределено тогда
Прервать;
Иначе
Если ТекущаяОбласть.Параметр <> Неопределено тогда
ТекущаяОбласть.СодержитЗначение = истина;
ТекущаяОбласть.типЗначения = Число;      //вот меняю тип области где сидит параметр "Количество"
КонецЕсли;
КонецЕсли
КонецЦикла;

Построитель.Макет = Макет;

тип изменился, но все равно там ничего не выводится. Я получил из построителя запрос, выполнил там действительно количество равно нулю. Почему у меня  в табличном документе в столбце "количестве" ничего не выводится?
« Последнее редактирование: 26-01-2010 03:29 от Dest » Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #1 : 26-01-2010 08:37 » 

Опубликуй скриншот (не понял где тебе нужно название поменять) и текст запроса (чтобы разобраться с количеством)
Записан
Dest
Опытный

ru
Offline Offline

« Ответ #2 : 26-01-2010 23:25 » 

Код:
Текст = "ВЫБРАТЬ
        | ПартииТоваровНаСкладахОстатки.Номенклатура.Код КАК Код,
        | ПартииТоваровНаСкладахОстатки.Номенклатура КАК Номенклатура,
        | ПРЕДСТАВЛЕНИЕ(ПартииТоваровНаСкладахОстатки.Номенклатура),
        | ПартииТоваровНаСкладахОстатки.Склад КАК Склад,
        | ПРЕДСТАВЛЕНИЕ(ПартииТоваровНаСкладахОстатки.Склад),
        | ПартииТоваровНаСкладахОстатки.КоличествоОстаток КАК Количество,
        | ПартииТоваровНаСкладахОстатки.СтоимостьОстаток КАК Стоимость
        |ИЗ
        | РегистрНакопления.ПартииТоваровНаСкладах.Остатки(&Дата, Склад = &Склад) КАК ПартииТоваровНаСкладахОстатки
        |ГДЕ
        | (ПартииТоваровНаСкладахОстатки.КоличествоОстаток <= 0
        | ИЛИ ПартииТоваровНаСкладахОстатки.СтоимостьОстаток <= 0)
|Упорядочить По ПартииТоваровНаСкладахОстатки.Склад.Наименование 
|";

* Таб.bmp (306.29 Кб - загружено 253 раз.)
Записан
Страниц: [1]   Вверх
  Печать  
 

Powered by SMF 1.1.21 | SMF © 2015, Simple Machines