Форум программистов «Весельчак У»
  *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

  • Рекомендуем проверить настройки временной зоны в вашем профиле (страница "Внешний вид форума", пункт "Часовой пояс:").
  • У нас больше нет рассылок. Если вам приходят письма от наших бывших рассылок mail.ru и subscribe.ru, то знайте, что это не мы рассылаем.
   Начало  
Наши сайты
Помощь Поиск Календарь Почта Войти Регистрация  
 
Страниц: [1]   Вниз
  Печать  
Автор Тема: Сортировка недоступной колонки  (Прочитано 10726 раз)
0 Пользователей и 1 Гость смотрят эту тему.
Gunslinger
Постоялец

ru
Offline Offline

« : 22-03-2010 09:32 » 

Есть недоступная колонка. Должна быть кнопка, по нажатию которой происходит сортировка Табличной части документа по значениям в этой колонке.. Чето как-то так...

Процедура Кнопка1Нажатие(Элемент)
         ЭлементыФормы.ТабличнаяЧасть1.Колонки.ЗвонокПринят.Сортировать
      КонецПроцедуры
подскажите как сделать чтобы это заработало

Добавлено через 21 час, 30 минут и 36 секунд:
Все нашел сам.
« Последнее редактирование: 23-03-2010 07:03 от Gunslinger » Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #1 : 23-03-2010 07:37 » 

Ну так напиши метод, раз уж начал тему Улыбаюсь
В принципе можно колонку добавить в стандартную настройку сортировки, чтобы пользователь сам решал - сортировать по ней или нет.
Записан
Gunslinger
Постоялец

ru
Offline Offline

« Ответ #2 : 23-03-2010 10:00 » 

Процедура Кнопка1Нажатие(Элемент)
         ТабличнаяЧасть1.Сортировать("ИмяКолонки Возр");
      КонецПроцедуры
Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #3 : 23-03-2010 10:49 » 

Да - все верно, для табличной части сортировка возможна только таким образом.
Для списков (ДокументСписок, СправочникСписок, ...) возможна интерактивная сортировка пользователем. Чтобы добавить в нее поля (по умолчанию включены не все) можно использовать следующий код:
Код:
ТабПоле=ЭтаФорма.ЭлементыФормы.<Название табличного поля>;
Порядок=ТабПоле.НастройкаПорядка.Найти("<Название колонки>");
Если Порядок=Неопределено Тогда
Порядок=ТабПоле.НастройкаПорядка.Добавить("<Название колонки>", Истина);
КонецЕсли;
Порядок.Доступность = Истина;
Записан
Антон
Новенький

ru
Offline Offline

« Ответ #4 : 09-02-2011 16:19 » 

Gunslinger,
Здравствуйте.
В теме на счет сортировки не совсем понял….
 У меня сортировка почему-то работает при подборе номенклатуры только по артикулу, наименованию и коду а по другим колонкам не работает. Смотрю отбор и сортировку. А там только три – артикул , код и наименование. Как добавить сортировку по дополнительным критериям, например по номенклатурной группе . Подскажите, пожалуйста, что делать по подробнее (где делают эти настройки в конфигураторе?, если да то куда заходить пробовал создавать новый критерий отбора, он появляется в списке сортировок но не активный.
Подскажите пожалуйста.
Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #5 : 09-02-2011 18:06 » 

Попробуй в конфигураторе у нужных реквизитов установить:
Индексировать = Индексировать с доп. упорядочиванием
Записан
Антон
Новенький

ru
Offline Offline

« Ответ #6 : 10-02-2011 07:06 » 

 :)это то я понял, я немогу найти эти реквизиты, где именно нужно установить эту настройку в каком разделе...

пробую во вкладке Общие \критерии отбора\ зоздаю новый критерий он добавляется в окно сортировки но становится(серым) не активным. видимо не там делаю

заранее спасибо.
Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #7 : 10-02-2011 11:35 » 

В реквизитах самого объекта конфигурации:

* 1cv8_prop_index.png (25.85 Кб - загружено 2724 раз.)
Записан
Страниц: [1]   Вверх
  Печать  
 

Powered by SMF 1.1.21 | SMF © 2015, Simple Machines