Форум программистов «Весельчак У»
  *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

  • Рекомендуем проверить настройки временной зоны в вашем профиле (страница "Внешний вид форума", пункт "Часовой пояс:").
  • У нас больше нет рассылок. Если вам приходят письма от наших бывших рассылок mail.ru и subscribe.ru, то знайте, что это не мы рассылаем.
   Начало  
Наши сайты
Помощь Поиск Календарь Почта Войти Регистрация  
 
Страниц: [1]   Вниз
  Печать  
Автор Тема: ТекСтрокаСписокМатериалов  (Прочитано 3486 раз)
0 Пользователей и 1 Гость смотрят эту тему.
anton13
Участник

ru
Offline Offline

« : 08-04-2010 17:29 » 

Постоянно в макетах и регистрах такая переменная ТекСтрокаСписокМатериалов. Откуда она берётся и чему равняется? Её не объявляют?
« Последнее редактирование: 08-04-2010 17:37 от Sel » Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #1 : 08-04-2010 18:47 » 

Может ты хотя бы напишешь что за конфигурацию используешь?
Записан
anton13
Участник

ru
Offline Offline

« Ответ #2 : 09-04-2010 02:41 » 

В смысле конфигупацию я делаю код с помощью конструктора процедура проведения документа:


Процедура ОбработкаПроведения(Отказ, Режим)
   //{{__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
   // Данный фрагмент построен конструктором.
   // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
   Для Каждого ТекСтрокаСписокМатериалов Из СписокМатериалов Цикл
      // регистр МатериалыОстатки Приход
      Движение = Движения.МатериалыОстатки.Добавить();
      Движение.ВидДвижения = ВидДвиженияНакопления.Приход;
      Движение.Период = Дата;
      Движение.Наименование = ТекСтрокаСписокМатериалов.Материалы;
      Движение.Количество = ТекСтрокаСписокМатериалов.КолУп;
   КонецЦикла;
   // записываем движения регистров
   Движения.МатериалыОстатки.Записать();
   //}}__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
КонецПроцедуры
Записан
Dest
Опытный

ru
Offline Offline

« Ответ #3 : 09-04-2010 03:34 » 

Код:
Для Каждого ТекСтрокаСписокМатериалов Из СписокМатериалов Цикл
...
 КонецЦикла;

Это цикл. Тут ты обходишь элементы из "СписокМатериалов" по одному с первого по последний.
ТекСтрокаСписокМатериалов - это переменная (итератор), которая содержит текущий элемент из "СписокМатериалов". Этот итератор может назваться как угодно, его не нужно объявлять.

Почти тоже самое, только по другому  Улыбаюсь  . Без итератора:

  
Код:
к=0;
   Пока  к=СписокМатериалов.Количество() Цикл
      ТекСтрокаСписокМатериалов = СписокМатериалов.Получить(к);
      Движение = Движения.МатериалыОстатки.Добавить();
      Движение.ВидДвижения = ВидДвиженияНакопления.Приход;
      Движение.Период = Дата;
      Движение.Наименование = ТекСтрокаСписокМатериалов.Материалы;
      Движение.Количество = ТекСтрокаСписокМатериалов.КолУп;
      к=к+1;
   КонецЦикла;

   Движения.МатериалыОстатки.Записать();
« Последнее редактирование: 09-04-2010 03:37 от Dest » Записан
anton13
Участник

ru
Offline Offline

« Ответ #4 : 09-04-2010 04:36 » 

Что цикл это и так понятно. Я не пойму откуда берётся значение этой переменной если оно до этого не задаётся или эта переменая из справочника?
Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #5 : 09-04-2010 05:35 » 

По-моему Dest все доступно объяснил. Значение переменной берется последовательно из коллекции СписокМатериалов на каждой итерации цикла. В зависимости от типа коллекции - соответствующий тип будет и у переменной цикла. Если СписокМатериалов - это ТабличнаяЧасть, то ТекСтрокаСписокМатериалов - это СтрокаТабличнойЧасти.
Неужели в VB нет циклов for each ? Это и есть прототип "Для каждого"
Записан
anton13
Участник

ru
Offline Offline

« Ответ #6 : 09-04-2010 06:17 » 

А понял ей значение присваивается в самом цикле. Прошу прощение за глупость.
« Последнее редактирование: 09-04-2010 16:36 от anton13 » Записан
Страниц: [1]   Вверх
  Печать  
 

Powered by SMF 1.1.21 | SMF © 2015, Simple Machines