Форум программистов «Весельчак У»
  *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

  • Рекомендуем проверить настройки временной зоны в вашем профиле (страница "Внешний вид форума", пункт "Часовой пояс:").
  • У нас больше нет рассылок. Если вам приходят письма от наших бывших рассылок mail.ru и subscribe.ru, то знайте, что это не мы рассылаем.
   Начало  
Наши сайты
Помощь Поиск Календарь Почта Войти Регистрация  
 
Страниц: [1]   Вниз
  Печать  
Автор Тема: ошибка во время проводки документа НачислениеЗП  (Прочитано 4348 раз)
0 Пользователей и 1 Гость смотрят эту тему.
staff
Помогающий

ua
Offline Offline
Пол: Мужской

« : 14-06-2010 14:00 » 

Добрый день, во время проведения документа НачислениеЗП выдается ошибка:

Код:
тбНиО.НайтиЗначение(НиО, НомСтроки, "Код");
{Документ.НачислениеЗП.Модуль Документа(193)}: Значение не представляет агрегатный объект (НайтиЗначение)
часть кода в котором появляется ошибка:

Код:
Функция ПолучитьНиО(НиО)
Перем НомСтроки;

Если ТипЗначенияСтр(НиО)="Строка" Тогда
тбНиО.НайтиЗначение(НиО, НомСтроки, "Код");
Иначе
тбНиО.НайтиЗначение(НиО, НомСтроки, "НиО");
КонецЕсли;
тбНиО.ПолучитьСтрокуПоНомеру(НомСтроки);
Возврат тбНиО.НиО;
КонецФункции

а также когда производится Расчет сумм индексации для всех сотрудников то ошибка:

Код:
Не могу найти сведения о индексе инфляции
В справочнике "Налоги и отчисления" не обнаружен элемент с кодом ИндексИнфл!
глПарсить(ноИндексИнфляции.Дополнительно.Получить(НП),спДоп);
{Документ.НачислениеЗП.Форма.Модуль(69)}: Значение не представляет агрегатный объект (Дополнительно)

часть кода с появившейся ошибкой:

Код:
Процедура СоздатьТбИндексИнфляции(НП, ПорогИндексации)
Перем ноИндексИнфляции;

спДоп = СоздатьОбъект("СписокЗначений");
глПолучитьНиО(ноИндексИнфляции, "ИндексИнфл", "о индексе инфляции");
глПарсить(ноИндексИнфляции.Дополнительно.Получить(НП),спДоп);
ПорогИндексации = Число(спДоп.Получить("ПорогИндексации"));

    глТбИндексИнфляции = СоздатьОбъект("ТаблицаЗначений");
глТбИндексИнфляции.НоваяКолонка("Месяц","Дата");
глТбИндексИнфляции.НоваяКолонка("Коэф","Число",7,4);
глТбИндексИнфляции.НоваяКолонка("Контролька","Число",1,0);

Периодический = СоздатьОбъект("Периодический");
Периодический.ИспользоватьОбъект("Ставка",ноИндексИнфляции);
Периодический.ВыбратьЗначения();
Пока Периодический.ПолучитьЗначение() = 1 Цикл
глТбИндексИнфляции.НоваяСтрока();
глТбИндексИнфляции.Месяц = НачМесяца(Периодический.ДатаЗнач);
глТбИндексИнфляции.Коэф = Периодический.Значение;
глТбИндексИнфляции.Контролька = 1;
КонецЦикла;
КонецПроцедуры

что не хватает данным кодам для нормального расчета ЗП??

конфигурация 1С "Бухгалтерский Учет" для Украины 7.70.210
Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #1 : 22-06-2010 16:59 » 

Не хватает элемента справочника с заданным кодом. Возможно - "ИндексИнфл"
Проверь чтобы в справочнике "Налоги и отчисления" (или что-то подобное - не помню как точно в ЗиК) был элемент с кодом "ИндексИнфл". Регистр имеет значение!
Записан
staff
Помогающий

ua
Offline Offline
Пол: Мужской

« Ответ #2 : 23-06-2010 06:30 » 

в данной конфигурации не задействованы Регистр, в нем нет ни одного значения
Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #3 : 23-06-2010 10:20 » 

Регистр символов при написании кода элемента справочника (case dependent) Улыбаюсь
Записан
Страниц: [1]   Вверх
  Печать  
 

Powered by SMF 1.1.21 | SMF © 2015, Simple Machines