Форум программистов «Весельчак У»
  *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

  • Рекомендуем проверить настройки временной зоны в вашем профиле (страница "Внешний вид форума", пункт "Часовой пояс:").
  • У нас больше нет рассылок. Если вам приходят письма от наших бывших рассылок mail.ru и subscribe.ru, то знайте, что это не мы рассылаем.
   Начало  
Наши сайты
Помощь Поиск Календарь Почта Войти Регистрация  
 
Страниц: [1]   Вниз
  Печать  
Автор Тема: Вопрос по фильтрации элементов справочника  (Прочитано 2599 раз)
0 Пользователей и 1 Гость смотрят эту тему.
Ольга111
Интересующийся

ua
Offline Offline

« : 16-06-2010 15:44 » 

Здравствуйте, уважаемые программисты! Надеюсь на Вашу помощь. Вопрос, наверное, простой. Организую фильтрацию в модуле формы списка справочника следующим образом:
Код:
Процедура Фильтрация()   
Список = СоздатьОбъект("СписокЗначений");
СпрТовары = СоздатьОбъект("Справочник.Товары");
СпрТовары.ВыбратьЭлементы();
Пока СпрТовары.ПолучитьЭлемент()=1 Цикл
   Если СпрТовары.ЭтоГруппа()=1 Тогда
      Продолжить;
   КонецЕсли;
   Если СпрТовары.МинПартия > 50 Тогда
      Список.ДобавитьЗначение(СпрТовары.ТекущийЭлемент());
   КонецЕсли;
КонецЦикла;
ИспользоватьСписокЭлементов(Список);
КонецПроцедуры
Для того, чтобы снова показать все элементы делаю аналогично:
Код:
Процедура ВсеТовары()
Список = СоздатьОбъект("СписокЗначений");
СпрТовары = СоздатьОбъект("Справочник.Товары");
СпрТовары.ВыбратьЭлементы();
Пока СпрТовары.ПолучитьЭлемент()=1 Цикл
   Если СпрТовары.ЭтоГруппа()=1 Тогда
      Продолжить;
   КонецЕсли;
        Список.ДобавитьЗначение(СпрТовары.ТекущийЭлемент());
  КонецЦикла;                   
ИспользоватьСписокЭлементов(Список);                   
КонецПроцедуры
Показывается полный список, но нет возможности добавить новый элемент в справочник. Подскажите, пожалуйста, как это исправить? Например, чтобы в процедуре Фильтрация(), по второму нажатию на кнопку, отменялся фильтр и можно было добавлять новые элементы в справочник. Или как-то иначе. Заранее благодарна Вам за ответы.  Здесь была моя ладья... Не понял Жаль
           
Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #1 : 22-06-2010 17:03 » 

Внимательно читай синтакс-помощник по ИспользоватьСписокЭлементов():
Цитата
Параметры:
<СписокЗначений> - необязательный параметр. Значение типа - ''СписокЗначений'' - должен представлять собой список элементов справочника, выбранных для просмотра. Если это значение пустое, то фильтр отключается.
Записан
Страниц: [1]   Вверх
  Печать  
 

Powered by SMF 1.1.21 | SMF © 2015, Simple Machines