Форум программистов «Весельчак У»
  *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

  • Рекомендуем проверить настройки временной зоны в вашем профиле (страница "Внешний вид форума", пункт "Часовой пояс:").
  • У нас больше нет рассылок. Если вам приходят письма от наших бывших рассылок mail.ru и subscribe.ru, то знайте, что это не мы рассылаем.
   Начало  
Наши сайты
Помощь Поиск Календарь Почта Войти Регистрация  
 
Страниц: [1]   Вниз
  Печать  
Автор Тема: Как создать список контрагентов  (Прочитано 4719 раз)
0 Пользователей и 1 Гость смотрят эту тему.
Sulik
Помогающий

ru
Offline Offline
Пол: Мужской

« : 28-06-2010 07:37 » 

Создан внешний отчет с одним макетом и двумя формами: ОсновнаяФорма, ФормаНастроек.
На ОсновнаяФорма размещена кнопка Настройки для открытия ФормаНастроек.
На ФормаНастроек размещено:  кнопка открытия формы выбора справочника "Контрагенты" ;Поле списка, куда помещается выбранный контрагент.
1 Как открыть ФормаНастроек
2 Как открыть форму справочника "Контрагенты" для выбора, так чтобы после выбора одного контрагента форма не закрывалась(т.е.
   как "подбор")
3 Как добавить выбранного контрагента в Поле списка и "записать"  в СписокЗначений.
Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #1 : 28-06-2010 08:59 » 

1.
Код:
Форма=ПолучитьФормуНастроек(,ЭтаФорма,);
Форма.Открыть();
2.
Код:
ФормаПодбора = Справочники.Контрагенты.ПолучитьФормуВыбора(,ЭтаФорма,);
ФормаПодбора.МножественныйВыбор = Истина;
ФормаПодбора.ЗакрыватьПриВыборе = Ложь;
ФормаПодбора.Открыть();
В свойствах вызывающей формы должен быть назначен обработчик события "ОбработкаВыбора":
Код:
Процедура ОбработкаВыбора(ЗначениеВыбора, Источник)
МассивВыбранныхЭлементов = Новый Массив;
Если ТипЗнч(ЗначениеВыбора) = Тип("СправочникСсылка.Номенклатура") Тогда
МассивВыбранныхЭлементов.Добавить(ЗначениеВыбора);
ИначеЕсли ТипЗнч(ЗначениеВыбора) = Тип("Массив") Тогда
МассивВыбранныхЭлементов = ЗначениеВыбора;
КонецЕсли;

Для каждого Элемент Из МассивВыбранныхЭлементов Цикл
//действия с очередным элементом
КонецЦикла;
КонецПроцедуры
(По Книге знаний mista.ru)
3. Это уже самостоятельно поищи Улыбаюсь
Записан
Sulik
Помогающий

ru
Offline Offline
Пол: Мужской

« Ответ #2 : 28-06-2010 16:49 » 

Спасибо, большое!
Первые 2 кода приспособил нормально. В третьем коде в цикле перепробовал много чего(Например: ВыбСписок.Добавить(элемент) ; ВыбСписок.Добавить(МассивВыбранныхЭлементов), где ВыбСписок - поле списка)
Но на экране в поле списка значений нет.
Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #3 : 28-06-2010 21:35 » 

Отладчиком посмотри какой тип у элемента и подходит ли он списку
Записан
Sulik
Помогающий

ru
Offline Offline
Пол: Мужской

« Ответ #4 : 29-06-2010 06:42 » 

Невнимательность меня сгубит.
Не прочитал строку
Цитата
В свойствах вызывающей формы должен быть назначен обработчик события "ОбработкаВыбора":
Все получилось.
Спасибо!
Записан
Страниц: [1]   Вверх
  Печать  
 

Powered by SMF 1.1.21 | SMF © 2015, Simple Machines