Форум программистов «Весельчак У»
  *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

  • Рекомендуем проверить настройки временной зоны в вашем профиле (страница "Внешний вид форума", пункт "Часовой пояс:").
  • У нас больше нет рассылок. Если вам приходят письма от наших бывших рассылок mail.ru и subscribe.ru, то знайте, что это не мы рассылаем.
   Начало  
Наши сайты
Помощь Поиск Календарь Почта Войти Регистрация  
 
Страниц: [1]   Вниз
  Печать  
Автор Тема: Отчёт "Начисление зарплаты"  (Прочитано 3588 раз)
0 Пользователей и 1 Гость смотрят эту тему.
Will
Интересующийся

ru
Offline Offline

« : 29-04-2011 20:14 » 

Здравствуйте!
ОЧЕНЬ нужна помощь!!! В 1С 8.1

Есть документ "Товарный чек":
Имеется реквизит 'Менеджер'
Табличная часть 'ТаблицаЧек' с реквизитами:
- Наименование,
- Количество,
- Цена,
- СуммаСНДС

Форма документа выглядит так:

Табличная часть заполняется товарами и в подвале считается итоговая сумма.

Нужно реализовать Отчет "Начисление зарплаты менеджеру" за определённый период.
Менеджер получает 10% от суммы продаж.

Примерный вид отчёта:


Суть задания:
При выписке товарного чека Менеджер выбирается из справочника.
У каждого менеджера будет своё количество чеков и свой % с продаж.
В отчёте в столбце "Сотрудник" - имя менеджера,
в "Документ начисления" - товарные чеки данного менеджера, т.е. типа: Товарный чек № 000021 от 15.02.2009.
В "Сумма" - 10% от суммы каждого товарного чека соответственно.

Проблема в следующем:
Не знаю, как сделать выборку менеджера и соответствующих ему документов, так же как считать сумму.
В итоге отчёт должен выглядеть примерно так:


Процедуру начинала писать, но это бред полнейший получается...
_______________________________________________________
Процедура КнопкаСформироватьНажатие(Кнопка)
   Запрос = Новый Запрос;
   Запрос.Текст = "ВЫБРАТЬ
   |ЗарплатаМенеджера.Менеджер КАК Сотрудник
   |ИЗ                                      
   |Документ.ТоварныйЧек.Менеджер
   |КАК ЗарплатаМенеджера
   |СГРУППИРОВАТЬ ПО
   |ЗарплатаМенеджера.Менеджер";
   Результат = Запрос.Выполнить().Выбрать();
   ТабДок = Новый ТабличныйДокумент;
   Макет = Отчеты.НачислениеЗарплаты.ПолучитьМакет("Макет");
        //Заголовок
   Область = Макет.ПолучитьОбласть("Шапка");
   ТабДок.Вывести(Область);
        //Менеджер
       Пока Результат.Следующий() Цикл
          Область = Макет.ПолучитьОбласть("Строка");
          Область.Параметры.Сотрудник = Результат.Сотрудник;
          ТабДок.Вывести(Область);
       КонецЦикла;
       ТабДок.ОтображатьСетку = Ложь;
       ТабДок.Защита = Ложь;
       ТабДок.ТолькоПросмотр = Ложь;
       ТабДок.ОтображатьЗаголовки = Ложь;
       ТабДок.Показать()
КонецПроцедуры


Добавлено через 11 часов, 30 минут и 5 секунд:
Как в таблицу отчёта вывести реквизит из документа? (1С 8.1)
Надо чтобы при нажатии в отчете кнопки "Сформировать" формировался отчет - в печатной форме в таблице столбец Сотрудник заполнялся менеджерами из товарных чеков, за определённый период.

 Есть документ "ТоварныйЧек"
 У него есть реквизит "Менеджер"


Есть отчет "НачислениеЗарплаты", в табличной части - параметр "Сотрудник"


Такая моя процедура, судя по всему, не правильная:

 Процедура КнопкаСформироватьНажатие(Кнопка)
 Запрос = Новый Запрос;
 Запрос.Текст = "ВЫБРАТЬ
 |ЗарплатаМенеджера.Менеджер КАК Сотрудник
 |ИЗ
 |Документ.ТоварныйЧек.Менеджер
 |КАК ЗарплатаМенеджера
 |СГРУППИРОВАТЬ ПО
 |ЗарплатаМенеджера.Менеджер";
 Результат = Запрос.Выполнить().Выбрать();
 ТабДок = Новый ТабличныйДокумент;
 Макет = Отчеты.НачислениеЗарплаты.ПолучитьМакет("Макет");
 //Заголовок
 Область = Макет.ПолучитьОбласть("Шапка");
 ТабДок.Вывести(Область);
 //Менеджер
 Пока Результат.Следующий() Цикл
 Область = Макет.ПолучитьОбласть("Строка");
 Область.Параметры.Сотрудник = Результат.Сотрудник;
 ТабДок.Вывести(Область);
 КонецЦикла;
 ТабДок.ОтображатьСетку = Ложь;
 ТабДок.Защита = Ложь;
 ТабДок.ТолькоПросмотр = Ложь;
 ТабДок.ОтображатьЗаголовки = Ложь;
 ТабДок.Показать()
 КонецПроцедуры
« Последнее редактирование: 30-04-2011 07:44 от Will » Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #1 : 30-04-2011 08:27 » 

Такая моя процедура, судя по всему, не правильная:
Ну и в чем ее неправильность? Напиши что именно не получается? (писать за тебя тут не будут, а помочь разобраться в ошибках - всегда пожалуйста)
Записан
Will
Интересующийся

ru
Offline Offline

« Ответ #2 : 30-04-2011 08:45 » 

Уже всё, получилось ))
Списибо)
Записан
Страниц: [1]   Вверх
  Печать  
 

Powered by SMF 1.1.21 | SMF © 2015, Simple Machines