Форум программистов «Весельчак У»
  *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

  • Рекомендуем проверить настройки временной зоны в вашем профиле (страница "Внешний вид форума", пункт "Часовой пояс:").
  • У нас больше нет рассылок. Если вам приходят письма от наших бывших рассылок mail.ru и subscribe.ru, то знайте, что это не мы рассылаем.
   Начало  
Наши сайты
Помощь Поиск Календарь Почта Войти Регистрация  
 
Страниц: [1]   Вниз
  Печать  
Автор Тема: При открытии документа в журнале  (Прочитано 2561 раз)
0 Пользователей и 1 Гость смотрят эту тему.
kiser
Участник

by
Offline Offline

« : 12-02-2012 08:33 » 

Доброго времени суток.

Поставили мне такую задачу:
"Журнал "По поставщикам"
   - добавить колонку "формирование цены"
   - если нажимаешь дважды на эту колонку открывается документ "Формирование цены"
   - если нажимаешь дважды на другую колонку открывается документ "Поступление ТМЦ""

Вроде элементарно все. Да вот проблема: никак не найду какой процедурой или функцией в журнале отслеживать момент начала открытия документа в журнале, вроде ПриНачалеВыбораЗначения() в документах.
Подскажите кто знает. 1С 7.7

Добавлено через 3 часа, 55 минут и 10 секунд:
Нашел сам)
Если кому понадобится, то вот как это делается:

Код:
Процедура ПриВыбореСтроки()
Если Форма.ТекущаяКолонка() = "ФормированиеЦен" Тогда

...

СтатусВозврата(0);
Возврат;
КонецЕсли;
КонецПроцедуры


Процедура ПриОткрытии()
Форма.ОбработкаВыбораСтроки(1);
КонецПроцедуры
« Последнее редактирование: 12-02-2012 12:29 от kiser » Записан
Страниц: [1]   Вверх
  Печать  
 

Powered by SMF 1.1.21 | SMF © 2015, Simple Machines