Форум программистов «Весельчак У»
  *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

  • Рекомендуем проверить настройки временной зоны в вашем профиле (страница "Внешний вид форума", пункт "Часовой пояс:").
  • У нас больше нет рассылок. Если вам приходят письма от наших бывших рассылок mail.ru и subscribe.ru, то знайте, что это не мы рассылаем.
   Начало  
Наши сайты
Помощь Поиск Календарь Почта Войти Регистрация  
 
Страниц: [1]   Вниз
  Печать  
Автор Тема: ГиперСсылка в ТабДок  (Прочитано 3457 раз)
0 Пользователей и 1 Гость смотрят эту тему.
Marta_Li
Постоялец

by
Offline Offline

« : 17-08-2012 13:33 » 

Помогите, пожалуйста, нужно в ТабДок вызывать выполнение процедуры по нажатию на область с Гиперссылка=Истина.
Как и где вызвать эту команду?
Спасибо.
Код:
Процедура ВывестиОтчет(ТабДок) Экспорт
…..
МассивДокументов = КритерииОтбора.ДокументыПоДоговоруКонтрагента.Найти(ВыборкаДетали.Ссылка);
Если МассивДокументов.Количество() > 0 Тогда
       ОбластьДетали.Параметры.ЕстьДокументы = МассивДокументов.Количество();
       ОбластьДетали.Области.ЕстьДокументы.ГиперСсылка = Истина;
Иначе
       ОбластьДетали.Параметры.ЕстьДокументы = "";
       ОбластьДетали.Области.ЕстьДокументы.ГиперСсылка = Ложь;
КонецЕсли;
…..
Процедура ВывестиСписокДокументовПоДоговору(ДоговорКонтрагента)
           
            ФормаСпискаДокументов = КритерииОтбора.ДокументыПоДоговоруКонтрагента.ПолучитьФорму("ФормаСписка");
            ФормаСпискаДокументов.ПараметрОтборПоЗначению = ДоговорКонтрагента;
            ФормаСпискаДокументов.Открыть();
           
КонецПроцедуры
Записан
Marta_Li
Постоялец

by
Offline Offline

« Ответ #1 : 20-08-2012 06:25 » 

Мне уже подсказали, удачно:
 Внимание! Говорит и показывает...
Если табличный документ находится в форме, тогда при его заполнении нужно еще в параметр расшифровки ячейки передавать договор контрагента. А для события   поля табличного документа "Выбор"  ввести процедуру
Код:
Процедура ТабДокВыбор(Элемент, Область, СтандартнаяОбработка)
СтандартнаяОбработка = Ложь;
ВывестиСписокДокументовПоДоговору(Область.Расшифровка);
КонецПроцедуры
Записан
Страниц: [1]   Вверх
  Печать  
 

Powered by SMF 1.1.21 | SMF © 2015, Simple Machines