Форум программистов «Весельчак У»
  *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

  • Рекомендуем проверить настройки временной зоны в вашем профиле (страница "Внешний вид форума", пункт "Часовой пояс:").
  • У нас больше нет рассылок. Если вам приходят письма от наших бывших рассылок mail.ru и subscribe.ru, то знайте, что это не мы рассылаем.
   Начало  
Наши сайты
Помощь Поиск Календарь Почта Войти Регистрация  
 
Страниц: [1]   Вниз
  Печать  
Автор Тема: срочно нужна помощь! с 1с формой  (Прочитано 7541 раз)
0 Пользователей и 1 Гость смотрят эту тему.
NaXeL
Новенький

ru
Offline Offline

« : 20-09-2012 11:12 » 

Всем привет!
нужна помощь с формой. Есть стандартная формаЭлемента при выборе фасона или комплекта что бы код из справочника (фасон либо комплект) дублировался в форму Код в номенклатуре помогите пожалуйста. спасибо.

* 1.jpg (235.75 Кб - загружено 834 раз.)
* 2.jpg (291.32 Кб - загружено 235 раз.)
Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #1 : 20-09-2012 11:27 » 

В событии ПриИзменении каждого из полей - присваивай нужные значения
Записан
NaXeL
Новенький

ru
Offline Offline

« Ответ #2 : 21-09-2012 08:16 » 

Не хочет отображать например
я выбираю комплект и надо что бы его "Код" (номер) отобразился в строке "Код" но что то не получается.

Процедура КомплектПриИзменении(Элемент)

Если комплект = истина  тогда   
Код = комплект.Код

      КонецЕсли;
                         
   КонецПроцедуры    //   

что надо дополнить
Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #3 : 24-09-2012 09:15 » 

Что значит (Если комплект = истина) ?
Записан
Dest
Опытный

ru
Offline Offline

« Ответ #4 : 25-09-2012 00:34 » 

Цитата
Что значит (Если комплект = истина) ?
Комплект - реквизит справочника номенклатура. Доступен непосредственно в модуле формы.

Вот это:
Код:

Если комплект = истина  тогда  
      Код = комплект.Код
КонецЕсли;
Я так пониманию не прокатит. Тут вы переменной код присваиваете значение кода комплекта.
                        
Вот так можно сделать
Код:
Если Комплект тогда   //Это условие  равнозначно  Комплект = истина  ;)
        ЭлементыФормы.Код.Данные = Неопределено;
ЭлементыФормы.Код.Значение = Комплект.Код;
КонецЕсли
« Последнее редактирование: 25-09-2012 00:45 от Dest » Записан
NaXeL
Новенький

ru
Offline Offline

« Ответ #5 : 25-09-2012 12:10 » 

т.е. Когда выбираешь из списка "Комплект" и то что выбрал отображался в строке ввода в формеЭлемента.
например в строке "Код" формеЭлемента должен высветиться код того наименования которое выбираешь в "Комплекте".

Записан
Dest
Опытный

ru
Offline Offline

« Ответ #6 : 25-09-2012 20:30 » 

Вы сами поняли, что написали? Я нет.
Может я, что-то не так понял в постановке задачи.
Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #7 : 28-09-2012 05:58 » 

Dest, Мой вопрос был направлен на то, чтобы NaXeL задумался над своими действиями. Он сравнивает значение реквизита (типа справочник) с булевой величиной. Это условие никогда не выполнится, т.к. разные типы.
2 NaXeL: поставь точку останова на эту строку и посмотри какого типа у тебя Комплект. Ищи функцию проверки заполненности реквизита/значения.

Цитата
Если Комплект тогда   //Это условие  равнозначно  Комплект = истина  Ага
Не согласен. В данном случае как раз наоборот.
Когда "Если Комплект = Истина ...." - 1С сравнит что типы несоответствует, тип(Комплект) не приводится к типу Булево - и вернет Ложь
Когда "Если Комплект ..." - 1С посмотрит что тип не приводтся к Булево и вылетит с исключением.

Т.е. если переменная может быть не булевого типа (например Неопределено или NULL в результате запроса) - то лучше ее сравнивать с Истиной.
Записан
Страниц: [1]   Вверх
  Печать  
 

Powered by SMF 1.1.21 | SMF © 2015, Simple Machines