Форум программистов «Весельчак У»
  *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

  • Рекомендуем проверить настройки временной зоны в вашем профиле (страница "Внешний вид форума", пункт "Часовой пояс:").
  • У нас больше нет рассылок. Если вам приходят письма от наших бывших рассылок mail.ru и subscribe.ru, то знайте, что это не мы рассылаем.
   Начало  
Наши сайты
Помощь Поиск Календарь Почта Войти Регистрация  
 
Страниц: [1]   Вниз
  Печать  
Автор Тема: Отчёт по реквизиту  (Прочитано 2463 раз)
0 Пользователей и 1 Гость смотрят эту тему.
vadhome
Новенький

ua
Offline Offline

« : 09-11-2012 08:25 » 

Ребят помогите. Нужно сделать простой отчёт по спец товару. Другими словами, Есть номенклатура у которой стоит реквизит спецтовар. Как сделать так чтобы в отчёте выводился именно он. Вот я тут попробовал но у меня ничего не выводит(( Хелп!


Код: (1C v8)
//*******************************************
Процедура Сформировать()
      ТМЦ = СоздатьОбъект("Справочник.ТМЦ");
Таб=СоздатьОбъект("Таблица");
Таб.ИсходнаяТаблица("Таблица");
Таб.ВывестиСекцию("Шапка");
ТМЦ.ВыбратьЭлементы();
Номер=1;
Пока ТМЦ.ПолучитьЭлемент()=1 цикл
  Если ТМЦ.СпецТовар=Перечисление.ДаНет.Да Тогда    
      Таб.ВывестиСекцию("ТМЦ");
  номер=номер+1;
  КонецЕсли;                      
КонецЦикла;      
Таб.ТолькоПросмотр(1);
    Таб.Показать("Перечень специальных препаратов");

КонецПроцедуры
Записан
AndyG
Постоялец

by
Offline Offline

« Ответ #1 : 12-11-2012 05:55 » 

Код вроде правильный, только при твоем условии реквизит должен ОБЯЗАТЕЛЬНО содержать Перечисление.ДаНет.Да.
Работать должно, возможно косяк в самой таблице?
Но подобные обращения к справочнику, на мой взгляд, удобнее сделать с помощью запроса с условием
Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #2 : 13-11-2012 15:55 » 

Справочник иерархический? у тебя выбираются только элементы верхнего уровня (в ТМЦ там часто только группы)...
AndyG прав - СпецТовар точно имеет тип Перечисление.ДаНет и заполнено?
Опять же AndyG прав - выбирать лучше запросом. Или же отбором по реквизиту (ВыбратьЭлементыПоРеквизиту) - если у реквизита стоит признак отбора в конфигураторе
Записан
Страниц: [1]   Вверх
  Печать  
 

Powered by SMF 1.1.21 | SMF © 2015, Simple Machines