Форум программистов «Весельчак У»
  *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

  • Рекомендуем проверить настройки временной зоны в вашем профиле (страница "Внешний вид форума", пункт "Часовой пояс:").
  • У нас больше нет рассылок. Если вам приходят письма от наших бывших рассылок mail.ru и subscribe.ru, то знайте, что это не мы рассылаем.
   Начало  
Наши сайты
Помощь Поиск Календарь Почта Войти Регистрация  
 
Страниц: [1]   Вниз
  Печать  
Автор Тема: Сравнение количества материала  (Прочитано 3624 раз)
0 Пользователей и 1 Гость смотрят эту тему.
Vogde
Участник

ru
Offline Offline

« : 02-07-2013 10:35 » 

Всем хорошего дня! В очередной раз я прошу вашей помощи. Суть вопроса такова: В документе Оказание Услуги при заполнении поля Количество необходимо создать программно сравнение количества материала на складе и введенного количества.

Я создал в общем модуле функцию по выборке остатков материала из регистра накопления, (хотел из отчета " Материал" но что не получилось). Вот она:

Код: (1C v8)
 Функция КоличествоМатериала(АктуальнаяДата,ЭлементНоменклатуры)Экспорт
     Отбор = Новый Структура("Номенклатура",ЭлементНоменклатуры);
     ЗначениеРесурсов = РегистрыНакопления.ОстаткиМатериалов.Остатки(АктуальнаяДата,Отбор);
     Возврат ЗначениеРесурсов.Количество;
 КонецФункции

И в модуле формы обработку выбора:
Код: (1C v8)
Процедура ПереченьНоменклатурыКоличествоОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
    Если ВыбранноеЗначение > РаботаСОтчетами.КоличествоМатериала(Объект.Дата) Тогда
        Предупреждение("На складе не хватает материала");
        Возврат;
    КонецЕсли;
КонецПроцедуры

 Но нужных мне результатов не достиг. Подскажите где ошибки? И правильный ли алгоритм действий?
« Последнее редактирование: 02-07-2013 11:53 от Kivals » Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #1 : 02-07-2013 11:55 » 

А что происходит? Какие ошибки выдает компилятор?
Записан
Vogde
Участник

ru
Offline Offline

« Ответ #2 : 02-07-2013 12:28 » 

Компилятор ошибок не выдает. Но или функция или процедура написаны не так потому что введенное количество не проверяется
Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #3 : 02-07-2013 17:50 » 

Обработчик создавал из элемента формы? Т.е. я хочу спросить - он у тебя точно привязан к событию элемента?
Если здесь все ок - стань отладчиком на первую строку (условие) и пройдись построчно, мониторя в табло значения переменных.
Записан
Vogde
Участник

ru
Offline Offline

« Ответ #4 : 04-07-2013 16:09 » 

Kivals, Большое спасибо за совет и помощь
Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #5 : 05-07-2013 08:07 » new

Vogde, что было-то? Улыбаюсь
Записан
Страниц: [1]   Вверх
  Печать  
 

Powered by SMF 1.1.21 | SMF © 2015, Simple Machines