Форум программистов «Весельчак У»
  *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

  • Рекомендуем проверить настройки временной зоны в вашем профиле (страница "Внешний вид форума", пункт "Часовой пояс:").
  • У нас больше нет рассылок. Если вам приходят письма от наших бывших рассылок mail.ru и subscribe.ru, то знайте, что это не мы рассылаем.
   Начало  
Наши сайты
Помощь Поиск Календарь Почта Войти Регистрация  
 
Страниц: [1]   Вниз
  Печать  
Автор Тема: Помощь с переносом документ-регистр-отчет(таблица)  (Прочитано 2734 раз)
0 Пользователей и 1 Гость смотрят эту тему.
brix
Новенький

ua
Offline Offline

« : 29-12-2015 17:03 » 

О великие 1с-умы. Подскажите студенту которого замучила проблема в его курсовой по 1с:Предприятие (версии 7.7) и да получит каждый ответивший +10 к карме.
А проблема заключается в том... что я уже 4й день не понимаю в чем проблема. Перерыл тонны материалов и делая все с точностью по инструкциям ничего не выходит.
в общем, суть такова:

Нужно конфигурировать все для работы с Ювелирного магазина.
у меня есть справочник "Изделие", в котором записана инфа о изделии (Название, стоимость, материал)
Есть Документ "ПродажаТовара", который создан для записи в журнал информации о закупке товара, теперь подробнее:
Реквизиты шапки: КоличествоИзделия, Изделие (объект справочник.Издение), Стоимость

Настройка:
[spoiler]
[/spoiler]

Модуль Документа:
Код:
Процедура ОбработкаПроведения()
Если КоличествоИзделия = 0 Тогда
    Предупреждение("Не указано количество");
    НеПроводитьДокумент();
КонецЕсли;     
Если Изделие.Выбран() = 0 тогда
Предупреждение("Не выбрано изделие");
    НеПроводитьДокумент();           
КонецЕсли;                           

                       
  Регистр.ПродаваемыйТовар.Изделие = Изделие;       
  Регистр.ПродаваемыйТовар.КолПрод = КоличествоИзделия;
  Регистр.ПродаваемыйТовар.Прибыль = Изделие.ЦенаП*КоличествоИзделия;   
  Регистр.ПродаваемыйТовар.ДвижениеПриходВыполнить();

КонецПроцедуры
Здесь, Изделие.ЦенаП - цена продажи

Регистр.ПродаваемыйТовар
[spoiler]
[/spoiler]


Отчет.ПродавТов
вывод информации о проданных товарах

Форма
[spoiler]
[/spoiler]
Модуль
Код:
// Процедура генерации запроса Сформировать.
//
Процедура Сформировать()
Перем Запрос, ТекстЗапроса, Таб;
//Создание объекта типа Запрос
Запрос = СоздатьОбъект("Запрос");
ТекстЗапроса =
"//{{ЗАПРОС(Сформировать)   
|Период с ВыбДата по ВыбДатаКон;
|Издел = Регистр.ПродаваемыйТовар.Изделие;
|Приб = Регистр.ПродаваемыйТовар.Прибыль;
|Кол = Регистр.ПродаваемыйТовар.КолПрод;
|Группировка Издел;
|"//}}ЗАПРОС
;
// Если ошибка в запросе, то выход из процедуры
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
Возврат;
КонецЕсли;     


// Подготовка к заполнению выходных форм данными запроса
Таб = СоздатьОбъект("Таблица");
Таб.ИсходнаяТаблица("");
// Заполнение полей "Заголовок"
Таб.ВывестиСекцию("Шапка");
Состояние("Заполнение выходной таблицы...");


Пока Запрос.Группировка(1) = 1 Цикл   
Таб.ВывестиСекцию("Строка");
КонецЦикла;

Таб.Опции(0);
// Вывод заполненной формы
Таб.ТолькоПросмотр(1);
Таб.Показать("");

КонецПроцедуры   

Таблица
[spoiler]
[/spoiler]

И все было бы хорошо вот только когда я формирую отчет ничего не выводиться
[spoiler]
[/spoiler]
Хотя в журнале информация есть
[spoiler]
[/spoiler]

Пройдя по коду в отладчике стало ясно что "Запрос.Группировка(1)" возвращает ноль, в цикл не входится, а значит информация в регистр не была записана (или записана коряво, или групировка не проходит). не могу понять в чем проблема, чувствую себя идиотом, помогите пжлст, а то 5го числа уже сдавать надо(.
Записан
brix
Новенький

ua
Offline Offline

« Ответ #1 : 29-12-2015 21:00 » 

Уже понял сам, ошибка в том то нет ненулевой функции в запросе. Модераторы, закрывайте тему)
Записан
Страниц: [1]   Вверх
  Печать  
 

Powered by SMF 1.1.21 | SMF © 2015, Simple Machines