Форум программистов «Весельчак У»
  *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

  • Рекомендуем проверить настройки временной зоны в вашем профиле (страница "Внешний вид форума", пункт "Часовой пояс:").
  • У нас больше нет рассылок. Если вам приходят письма от наших бывших рассылок mail.ru и subscribe.ru, то знайте, что это не мы рассылаем.
   Начало  
Наши сайты
Помощь Поиск Календарь Почта Войти Регистрация  
 
Страниц: [1]   Вниз
  Печать  
Автор Тема: v8.3: Как программно сформировать внешнюю печатную форму документа  (Прочитано 1736 раз)
0 Пользователей и 1 Гость смотрят эту тему.
zerbite
Интересующийся

ru
Offline Offline

« : 15-01-2016 07:44 » 

Имеется обработка в которой есть реквизит Объект.ПрихНакл, в которой хранится ссылка на документ ПоступлениеТоваровУслуг, для этого документа прописана внешняя печатная форма "Приемо-сдаточный акт", из документа все печатает. а как эту форму сформировать из обработки, или с любого другого случайного места?
Записан
zerbite
Интересующийся

ru
Offline Offline

« Ответ #1 : 19-01-2016 06:48 » 

Все почти заработало..., форма формируется но не выводиться на экран...
заменять Возврат ТабличныйДокумент; на ТабличныйДокумент.Показать();  не хотелось бы, потому как это поломается механизм стандартной печати из документа, кроме того показать - просто выведет на экран, а удобно когда он выводить в обработку печать документов со всем функционалом.

есть процедура из которой я вызываю внешнюю печатную форму:
Код:
Процедура ПечатьИзВПФ(ИмяВПФ);  //
    СсылкаНаВПФ = Справочники.ДополнительныеОтчетыИОбработки.НайтиПоНаименованию(ИмяВПФ);
    Если СсылкаНаВПФ.Пустая() Тогда
        Сообщить("В справочнике 'Внешние обработки' не нашли внешнюю печатную форму с наименованием '"+ИмяВПФ+"'");
        Возврат;
    КонецЕсли;
        
    Попытка
        ИмяВременногоФайла = КаталогВременныхФайлов()+"тмп_впф.epf";
    Исключение
        Сообщить ("Невозможно создать файл обработке в каталоге временных файлов <<"+
        +КаталогВременныхФайлов()+">>. Возможно, не хватает прав доступа в Windows в папку для данного сеанса 1С ");
        Возврат;
    КонецПопытки;    
    
    ДвоичныеДанные = СсылкаНаВПФ.ХранилищеОбработки.Получить();        
    ДвоичныеДанные.Записать(ИмяВременногоФайла);
    
    Попытка
        ОбрОбъект = ВнешниеОбработки.Создать(ИмяВременногоФайла);
        //ОбрОбъект.ДокОбъект = ЭтотОбъект; // НЕ исп. метод скопировать. Передать ТАК - особенности ВДГБ;
    Исключение
        Сообщить("Ошибка создания объекта из временного файла обработки "+ИмяВременногоФайла);
        Возврат;
    КонецПопытки;
    
    МассивОбъектовНазначения = Новый Массив;
    МассивОбъектовНазначения.Добавить(Объект.ПрихНакл);

ОбъектыПечати =    Новый СписокЗначений;

КоллекцияПечатныхФорм = Новый ТаблицаЗначений;
КоллекцияПечатныхФорм.Колонки.Добавить("ИмяМакета");
КоллекцияПечатныхФорм.Колонки.Добавить("ИмяВРЕГ");
КоллекцияПечатныхФорм.Колонки.Добавить("СинонимМакета");
КоллекцияПечатныхФорм.Колонки.Добавить("ТабличныйДокумент");
КоллекцияПечатныхФорм.Колонки.Добавить("Экземпляров");
КоллекцияПечатныхФорм.Колонки.Добавить("Картинка");
КоллекцияПечатныхФорм.Колонки.Добавить("ПолныйПутьКМакету");
КоллекцияПечатныхФорм.Колонки.Добавить("ИмяФайлаПечатнойФормы");
стр=КоллекцияПечатныхФорм.Добавить();
стр.ИмяМакета="ПриемоСдаточныйАкт";
стр.ИмяВРЕГ="ПРИЕМОСДАТОЧНЫЙАКТ";
стр.Экземпляров=1;

//ИмяМакета=ПриемоСдаточныйАкт, ИмяВРЕГ=ПРИЕМОСДАТОЧНЫЙАКТ, СинонимМакета=, ТабличныйДокумент=, Экземпляров=1, Картинка=, ПолныйПутьКМакету=, ИмяФайлаПечатнойФормы=,

// Проба печати
    Попытка
        ОбрОбъект.печать(МассивОбъектовНазначения, КоллекцияПечатныхФорм, ОбъектыПечати, Ложь);
        //ТаблДок.Вывести();
    Исключение
        А=1; // Точка останова для отладки!
        Сообщить(ПодробноеПредставлениеОшибки(ИнформацияОбОшибке() )); // ВНЕШНЮЮ печатную форму из справончика ВПФ можно спокойно поправить!
    КонецПопытки;    
            
КонецПроцедуры    

и есть внешняя печатная форма:
прикрепляю внешним файлом, целиком текст не влез в сообщение...

* Модуль ВПФ.txt (69.91 Кб - загружено 76 раз.)
* Clip2net_160119092632.png (86.58 Кб - загружено 67 раз.)
« Последнее редактирование: 19-01-2016 06:52 от zerbite » Записан
zerbite
Интересующийся

ru
Offline Offline

« Ответ #2 : 19-01-2016 12:21 » 


ответ оказался очень простой

Код:
ВыполняемаяОбработка=НайтиВПФ();
    Если ВыполняемаяОбработка.Пустая() Тогда
        Возврат;
    КонецЕсли;
    ОбъектыНазначения=Новый Массив;
    ОбъектыНазначения.Добавить(Объект.ПрихНакл);
    //Если УправлениеПечатьюКлиент.ПроверитьДокументыПроведены(ОбъектыНазначения) Тогда
        ПараметрыОткрытия=Новый Структура("ИсточникДанных, ПараметрыИсточника");
        ПараметрыОткрытия.ИсточникДанных=ВыполняемаяОбработка;
        ПараметрыОткрытия.ПараметрыИсточника=Новый Структура("ИдентификаторКоманды, ОбъектыНазначения");
        ПараметрыОткрытия.ПараметрыИсточника.ИдентификаторКоманды="ПриемоСдаточныйАкт";
        ПараметрыОткрытия.ПараметрыИсточника.ОбъектыНазначения=ОбъектыНазначения;
       
        ОткрытьФорму("ОбщаяФорма.ПечатьДокументов", ПараметрыОткрытия);   

код должен выполняться на клиенте, а функция НайтиВПФ() - должны быть на сервере и возвращать ссылку из Справочники.ДополнительныеОтчетыИОбработки

Записан
Страниц: [1]   Вверх
  Печать  
 

Powered by SMF 1.1.21 | SMF © 2015, Simple Machines