Форум программистов «Весельчак У»
  *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

  • Рекомендуем проверить настройки временной зоны в вашем профиле (страница "Внешний вид форума", пункт "Часовой пояс:").
  • У нас больше нет рассылок. Если вам приходят письма от наших бывших рассылок mail.ru и subscribe.ru, то знайте, что это не мы рассылаем.
   Начало  
Наши сайты
Помощь Поиск Календарь Почта Войти Регистрация  
 
Страниц: [1]   Вниз
  Печать  
Автор Тема: Проблема со СпискомЗначений в форме отчета...Помогите пжлтса...  (Прочитано 3865 раз)
0 Пользователей и 1 Гость смотрят эту тему.
navagdenie
Гость
« : 20-11-2008 08:52 » 

Помогите пжлста совсем начинающему программисту...
В форме отчета необходимо вывести список значений (номера квитанций из документов) для отбора...Значения присваивает, но в форму не выводит...Мучаюсь вторую неделю...Помогите...
Вот код:
Процедура ЗагрузитьДок()
Если (ПустоеЗначение(НачДата2)=1) или (ПустоеЗначение(КонДата2)=1) тогда
Предупреждение("Выберите период!");
Возврат;
КонецЕсли;

СписокДок=СоздатьОбъект("СписокЗначений");
Документы=СоздатьОбъект("СписокЗначений");

Док = СоздатьОбъект("Документ.Заселение");

Док.ВыбратьДокументы(НачДата2, КонДата2);
Пока Док.ПолучитьДокумент()=1 цикл
ТекДок=Док.ТекущийДокумент();
ТекДок.ВыгрузитьТабличнуюЧасть(ТабДок);
ТабДок.ВыбратьСтроки();
Пока ТабДок.ПолучитьСтроку()=1 Цикл
НКвит=ТабДок.НомерКвитанции;
Документы.ДобавитьЗначение(НКвит);
КонецЦикла;
КонецЦикла;
Для н=1 по Документы.РазмерСписка() цикл
Значение=Документы.ПолучитьЗначение(н, НКвит);
Сообщить(Значение);
СписокДок.ДобавитьЗначение(Значение);
КонецЦикла;

СписокДок.Сортировать();

КонецПроцедуры


В форму вставлен список с идентификатором СписокДок.
Закоментировала СоздатьОбъект("СписокЗначений"), идентификатор списка скопировала из формы м вставила в модуль, после запуска отчета выдает ошибку "{Отчет.ОтчетЗаселение.Форма.Модуль(198)}: Значение не представляет агрегатный объект (ДобавитьЗначение)"

Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #1 : 20-11-2008 09:14 » 

Скорее всего у тебя на форме не СписокЗначений.
Возможно (это только догадка) - у тебя таблица занчений.
прицепи обработку сюда - посмотрим
Записан
navagdenie
Гость
« Ответ #2 : 20-11-2008 09:25 » 

Это отчет, он не внешний...Глупый вопрос, но как мне его тогда сюда вставить? Краснею
Записан
navagdenie
Гость
« Ответ #3 : 20-11-2008 09:28 » 

Блин, пасип огромное, но уже разобралась...Дурочка, взяла, объявила его как переменную и мучалась 2 недели...
Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #4 : 20-11-2008 10:03 » 

Улыбаюсь

Для невнешнего отчета по правой кнопке в дереве конфигурации можно выбрать "Сохранить как внешний отчет" (и загрузить из внешнего отчета тоже) - удобно при отладке на большой конфигурации - быстрее сохраняется отдельным отчетом и не надо перезапускать конфу....
Записан
Страниц: [1]   Вверх
  Печать  
 

Powered by SMF 1.1.21 | SMF © 2015, Simple Machines