Форум программистов «Весельчак У»
  *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

  • Рекомендуем проверить настройки временной зоны в вашем профиле (страница "Внешний вид форума", пункт "Часовой пояс:").
  • У нас больше нет рассылок. Если вам приходят письма от наших бывших рассылок mail.ru и subscribe.ru, то знайте, что это не мы рассылаем.
   Начало  
Наши сайты
Помощь Поиск Календарь Почта Войти Регистрация  
 
Страниц: [1]   Вниз
  Печать  
Автор Тема: Нумерация ячеек в ТабличномПоле  (Прочитано 5594 раз)
0 Пользователей и 1 Гость смотрят эту тему.
integer
Гость
« : 22-05-2009 14:34 » 

Здравствуйте , не нашел ответа.

используется 1С 8.1

1.имеется элемент "ТабличноеПоле", рядом кнопка, по нажатию на кнопку в таблице должно появиться десять строк и десять столбцов, причем каждая ячейка должна быть пронумированна (<номер строки><номер столбца>) : например (1.1) (1.2).


я вот пишу цикл чтобы вставить десять строк и столбцов, но как ячейки пронумировать? можете привести пример того , что должно быть написано в кнопке?

Код:
Процедура заполнитьНажатие(Элемент)
//рисует десять строк и колонок
перем кв;
кв=0;
пока кв<10 цикл
ЭлементыФормы.ТП1.ДобавитьСтроку();
    ЭлементыФормы.ТП1.Колонки.Добавить();
кв=кв+1;
КонецЦикла;

вот, а нумеровать как?

Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #1 : 22-05-2009 14:44 » 

двойной цикл:
по строкам 0..9
   и по стобцам 0..9
      В ячейку (Строка,Столбец) записать значение: "Строка"+":"+"Столбец"
Записан
integer
Гость
« Ответ #2 : 22-05-2009 15:47 » 

двойной цикл:
по строкам 0..9
   и по стобцам 0..9
      В ячейку (Строка,Столбец) записать значение: "Строка"+":"+"Столбец"
можно пример кода пожалуйста?
Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #3 : 22-05-2009 17:00 » 

Код:
И1=0;
Для каждого Строка Из ЭлементыФормы.ТП1 Цикл
И1=И1+1;
И2=0;
Для каждого Кол Из ЭлементыФормы.ТП1.Колонки Цикл
И2=И2+1;
Ячейка=Строка[Колонка.Имя];
Ячейка.Значение=""+И1+":"+И2;
КонецЦикла;
КонецЦикла;
Записан
integer
Гость
« Ответ #4 : 23-05-2009 13:44 » 

Kivals,
спасибо большое!


есть еще один вопрос - как из одного табличного поля скопировать строку в другое ТП?


Цитата
И1=0;
   Для каждого Строка Из ЭлементыФормы.ТП1 Цикл
      И1=И1+1;
      И2=0;
      Для каждого Колонка Из ЭлементыФормы.ТП1.Колонки Цикл
         И2=И2+1;
         Ячейка=Строк

Цитата
итератор для значения не определен

почему? переменные ввел, проверил, вроде все должно быть правильно
« Последнее редактирование: 26-05-2009 01:40 от Алексей1153++ » Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #5 : 25-05-2009 10:19 » 

В какой именно строке?
Записан
integer
Гость
« Ответ #6 : 25-05-2009 11:56 » 

{Обработка.Обработка1.Форма.Форма(17)}: Итератор для значения не определен
   Для каждого Строка Из ЭлементыФормы.ТП1 Цикл

Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #7 : 25-05-2009 18:12 » 

Для ТП1 тип Значения - таблица значений или что?
Записан
integer
Гость
« Ответ #8 : 25-05-2009 19:50 » 

Да таблица значений

я извиняюсь за мою дурость
« Последнее редактирование: 26-05-2009 01:39 от Алексей1153++ » Записан
Страниц: [1]   Вверх
  Печать  
 

Powered by SMF 1.1.21 | SMF © 2015, Simple Machines