Форум программистов «Весельчак У»
  *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

  • Рекомендуем проверить настройки временной зоны в вашем профиле (страница "Внешний вид форума", пункт "Часовой пояс:").
  • У нас больше нет рассылок. Если вам приходят письма от наших бывших рассылок mail.ru и subscribe.ru, то знайте, что это не мы рассылаем.
   Начало  
Наши сайты
Помощь Поиск Календарь Почта Войти Регистрация  
 
Страниц: [1]   Вниз
  Печать  
Автор Тема: Формирование отчета.  (Прочитано 3055 раз)
0 Пользователей и 1 Гость смотрят эту тему.
aptemii
Гость
« : 26-06-2009 07:04 » 

Сам админ, а не программер, так заранее прошу не ругать за детские ошибки.
Код отчета:
Процедура Сформировать()
        Запрос = СоздатьОбъект("Запрос");
      
      ТекстЗапроса = "
      |ИнвКомпьютеров=Регистр.ОстаткиКомпьютеров.Компьютер;
      |Расположение=Регистр.ОстаткиКомпьютеров.Расположение;
      |Сотрудник=Регистр.ОстаткиКомпьютеров.Сотрудник;
      |Группировка Компьютер;
      |Группировка Расположение;
      |Условие(Компьютер в ВыбрКомпьютерГруппа);
      |Условие(Расположение в ВыбрРасположение);
      |";
         
         Если Запрос.Выполнить(ТекстЗапроса)=0 Тогда
            Возврат;
         КонецЕсли;
         
      Таб = СоздатьОбъект("Таблица");
      Таб.ВывестиСекцию("Заголовок");
      
      Пока Запрос.Группировка(1)=1 Цикл
         Если Запрос.Компьютер.ЭтоГруппа()=1 Тогда
               Таб.ВывестиСекцию("Компьютер");
         Иначе
            Таб.ВывестиСекцию("Расположение");
            Если Фл_НеВыводитьРасположение = 0 Тогда
               Пока Запрос.Группировка(2)=1 Цикл
                  Таб.ВывестиСекцию("Сотрудник");
               КонецЦикла;
         КонецЕсли;
      КонецЕсли;
   КонецЦикла;
   Таб.Опции(0);
   Таб.Показать("ОстаткиКомпьютеров", "");
   
КонецПроцедуры

И ошибки:

Если Запрос.Выполнить(ТекстЗапроса)=0 Тогда
{Отчет.ОстаткиКомпьютеров.Форма.Модуль(15)}: Группировка Компьютер <<?>> ;
Запр
« Последнее редактирование: 29-06-2009 08:15 от Sel » Записан
aptemii
Гость
« Ответ #1 : 26-06-2009 07:04 » 

И ошибки:

Если Запрос.Выполнить(ТекстЗапроса)=0 Тогда
{Отчет.ОстаткиКомпьютеров.Форма.Модуль(15)}: Группировка Компьютер <<?>> ;
Запр
Записан
aptemii
Гость
« Ответ #2 : 26-06-2009 07:05 » 

Если Запрос.Выполнить(ТекстЗапроса)=0 Тогда
{Отчет.ОстаткиКомпьютеров.Форма.Модуль(15)}: Группировка Компьютер <<?>> ;
Запр
Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #3 : 26-06-2009 07:32 » 

Несоответствие имен:
или этус строку поменяй
      |Компьютер=Регистр.ОстаткиКомпьютеров.Компьютер;
или эту:
      |Группировка ИнвКомпьютеров;
Записан
Страниц: [1]   Вверх
  Печать  
 

Powered by SMF 1.1.21 | SMF © 2015, Simple Machines