Форум программистов «Весельчак У»
  *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

  • Рекомендуем проверить настройки временной зоны в вашем профиле (страница "Внешний вид форума", пункт "Часовой пояс:").
  • У нас больше нет рассылок. Если вам приходят письма от наших бывших рассылок mail.ru и subscribe.ru, то знайте, что это не мы рассылаем.
   Начало  
Наши сайты
Помощь Поиск Календарь Почта Войти Регистрация  
 
Страниц: [1]   Вниз
  Печать  
Автор Тема: Не могу выгрузить в документ поступление на лицевой счет договоры  (Прочитано 2656 раз)
0 Пользователей и 1 Гость смотрят эту тему.
Grand
Гость
« : 13-08-2009 06:35 » 

Программа 1С бюджетная конфигурация
проблема в том что в справочнике договоров есть совпадения по номеру договов из-за этого неплучаеться нормально выгрузить в документ
Код программы
Если     СпрКонтрагенты.НайтиПоКоду(НомерДоговора) = 1 Тогда   
   Док.Контрагент = СпрКонтрагенты.ТекущийЭлемент();
            
Если СпрДоговоры.НайтиПоНаименованию(Номердоговора)= 1 Тогда
   Док.НомерДого = СпрДоговоры.ТекущийЭлемент();
   Док.ОснованиеРасчетов = СпрДоговоры.ТекущийЭлемент();
Если    Док.ОснованиеРасчетов.ПринадлежитГруппе("002")=1 Тогда
        Док.ОснованиеРасчетов = СпрДоговоры.ТекущийЭлемент();
Иначе
Если СпрДоговоры.НайтиПоКоду(НомерДоговора) = 1 Тогда
   Док.ОснованиеРасчетов = СпрДоговоры.ТекущийЭлемент();
КонецЕсли;
КонецЕсли;КонецЕсли;   
 
Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #1 : 16-08-2009 09:00 » 

Варианты решения:
  • Убрать проверку уникальности. Возникнет проблема: по номеру будет находится первый из договоров, что может не соотвтствовать условиям поиска
  • Уменьшить период периодичности номера до 1 дня. Нельзя вводить одинаковые номера договора в течении одного дня. При поиске нужно будет указывать дату с точностью до дня
  • Добавить префикс/суффикс к номеру договора основываясь на других его параметрах: код контрагента, код товара, вид поставки, ...
Записан
Страниц: [1]   Вверх
  Печать  
 

Powered by SMF 1.1.21 | SMF © 2015, Simple Machines