Форум программистов «Весельчак У»
  *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

  • Рекомендуем проверить настройки временной зоны в вашем профиле (страница "Внешний вид форума", пункт "Часовой пояс:").
  • У нас больше нет рассылок. Если вам приходят письма от наших бывших рассылок mail.ru и subscribe.ru, то знайте, что это не мы рассылаем.
   Начало  
Наши сайты
Помощь Поиск Календарь Почта Войти Регистрация  
 
Страниц: [1]   Вниз
  Печать  
Автор Тема: Нужна помощь новичку  (Прочитано 6596 раз)
0 Пользователей и 1 Гость смотрят эту тему.
Vovik78
Гость
« : 06-03-2010 22:21 » 

Ситуация такая:
Имеем Документ с Полем Выбора (ВидТехники)
-  кликаем на кнопку выбора и выбираем элемент 2
В поле выбора отображается "ML-1640"
Вопрос:
 - Как сделать, чтобы после выбора данного элемента в поле выбора отбразились еще и названия груп?
в общем в конечном этоге там Нужно " Принтер SAMSUNG ML-1640".

* Untitled-1.jpg (365.28 Кб - загружено 216 раз.)
Записан
Dest
Опытный

ru
Offline Offline

« Ответ #1 : 06-03-2010 23:47 » 

Нужно сделать хитро. Берешь и делаешь поле ввода ((1) Вид техники)  такого размера чтоб там была только кнопка. Рядом размещаешь еще одно поле ввода (2). Для поля ввода (1) наверняка уже существует идентификатор, например ном,  задаешь для него формулу, например пр(). Для поля ввода (2) указываешь идентификатор ном2. В модуле формы документа "прием на ремонт" пишешь
Код:
Процедура пр ()
ном2 = Ном.Родитель.Наименование+" "+ном.Наименование;
КонецПроцедуры

* Безымянный.png (13.1 Кб - загружено 196 раз.)
« Последнее редактирование: 06-03-2010 23:49 от Dest » Записан
Vovik78
Гость
« Ответ #2 : 07-03-2010 01:08 » 

Вот Спасибо тебе огромное!  Класс!
А может еще подскажешь такой момент - а то тоже уперся и не знаю как сделать
Ставим на документ флажок. И нужно, чтобы в момент установки влажка на документе отображалось в отдельном поле дата и время установки этого флажка. И желательно, чтобы он сразу блокировался и не давал потом себя снять и поставить заново чтобы изменмть дату и время установки.
Во как замутил  Улыбаюсь
Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #3 : 09-03-2010 08:50 » 

Для проверки состояния: вешай событие на нажатие флажка, проверяй что нужно и выполняй нужные действия
Для блокировки: испольхуешь функцию для любого текстового поля на форме (обычно называют УстДоступность() или Доустпность()) - в ней ставишь Форма.Флажок.Доступность(1-Флажок) где флажок - название реквизита в документе и на форме
Записан
Novichok2
Гость
« Ответ #4 : 19-03-2010 10:41 » 

Как в конфигураторе вызвать на редактирование форму "сведения о номенклатуре - новий"
Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #5 : 19-03-2010 15:26 » 

В 7.7 справочник может иметь не более чем одну форму для элемента и группы (кроме того эти формы могут быть совмещены, если установлен флажок "Одна форма для элемента и группы"), причем эта форма используется как для нового элемента, так и для редактирования существующего.
А открыть ее можно из контекстного меню:

* 1cv7_ref_el_form.PNG (10.78 Кб - загружено 955 раз.)
Записан
Novichok2
Гость
« Ответ #6 : 06-04-2010 09:20 » 

 А черт его знает...

* 1с.JPG (77.31 Кб - загружено 212 раз.)
* 1с.JPG (77.31 Кб - загружено 185 раз.)
Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #7 : 06-04-2010 10:17 » 

Во-первых в номенклатуре должен быть реквизит Производитель нужного типа.
Во-вторых после этого в редакторе формы вызываешь "Вставить - Реквизиты..." или Ctrl+E
Записан
Fialka
Гость
« Ответ #8 : 03-05-2010 18:08 » 

Помогите пожалуйста с написанием проводки приходной накладной. Создана чистая конфигурация
реквизиты табличной части: товар, цена,Количество, сумма, НДС, итого.  Д41 К60-без НДС, Д19 К60 - с НДС.


Процедура ОбработкаПроведения()
   
   ВыбратьСтроки();

Выдает такую ошибку. Что я делаю не правильно?     

Операция.НоваяПроводка();
{Документ.ПриходнаяНакладная.Модуль Документа(16)}: Недопустимая операция




   
   Пока ПолучитьСтроку()=1 Цикл
      Операция.НоваяПроводка();
      Операция.Дебет.Счет = СчетПоКоду("41"); 
      Операция.Дебет.Номенклатура = Товар;
      Операция.Кредит.Количество = Количество;
      Операция.Кредит.Счет = СчетПокоду("60");
      Операция.Сумма = Сумма;
      Операция.СодержаниеПроводки = "ПриходнаяНакладная";
      
      Операция.НоваяПроводка();
      Операция.Дебет.Счет = СчетПоКоду("19");
      Операция.Кредит.Номенклатура = Товар;   
      Операция.Кредит.Количество = Количество;
      Операция.Кредит.Счет = СчетПоКоду("60");
      Операция.Комментарий = "Учет НДС";
      Операция.Сумма = Окр(Сумма*0.18,2);      
      
   КонецЦикла ;
   
КонецПроцедуры
Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #9 : 05-05-2010 22:19 » 

А для этого документа включен бух. учет и что установлено в поле "Создавать операцию"?

* 1cv7_doc_properties.png (21.31 Кб - загружено 965 раз.)
Записан
Страниц: [1]   Вверх
  Печать  
 

Powered by SMF 1.1.21 | SMF © 2015, Simple Machines