Форум программистов «Весельчак У»
  *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

  • Рекомендуем проверить настройки временной зоны в вашем профиле (страница "Внешний вид форума", пункт "Часовой пояс:").
  • У нас больше нет рассылок. Если вам приходят письма от наших бывших рассылок mail.ru и subscribe.ru, то знайте, что это не мы рассылаем.
   Начало  
Наши сайты
Помощь Поиск Календарь Почта Войти Регистрация  
 
Страниц: [1]   Вниз
  Печать  
Автор Тема: ТТН  (Прочитано 9176 раз)
0 Пользователей и 1 Гость смотрят эту тему.
Gunslinger
Постоялец

ru
Offline Offline

« : 14-05-2010 07:35 » 

Подскажите как сделать чтобы при вызове печатной формы ТТН поля которые вводились в предыдущую ТТН перенеслись в новую.. какую-то выгрузку полей в отдельный файл текстовый делать, или есть штатные средства?
Записан
Dest
Опытный

ru
Offline Offline

« Ответ #1 : 14-05-2010 11:30 » 

А если создать ТТН копированием?
Записан
Gunslinger
Постоялец

ru
Offline Offline

« Ответ #2 : 14-05-2010 12:02 » 

Хорошо бы. но не получается. ТТН формируется с документом "реализация товаров и услуг" и после распечатки не сохраняется
Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #3 : 14-05-2010 12:33 » 

А какая связь между новой ТТН и старой? или тебе просто нужно восстановить предыдущие значения?
Записан
Gunslinger
Постоялец

ru
Offline Offline

« Ответ #4 : 17-05-2010 04:35 » 

Да. Мне нужно избежать постоянного ввода в ТТН полей "Организация" "Автомобиль" "ГосНомер" "Водитель" "Удостоверение" "Пунтк погрузки"...  В моей ситуации эти поля постоянно одни и те же... хотя ТТН и вводится с разных документов.. Были такие ситуации?
Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #5 : 17-05-2010 09:38 » 

СохранитьЗначение()/ВосстановитьЗначение()
ЗнчениеВФайл()/ЗначениеИзФайла()
или заведи константы
Записан
Gunslinger
Постоялец

ru
Offline Offline

« Ответ #6 : 21-05-2010 03:58 » 

ЗначениеВФайл()/ЗначениеИзФайла()
А нету конкретных примеров с этой функцией? а то те что в справке описаны нифига не понятные
Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #7 : 21-05-2010 05:37 » 

Что не понятно? Указанное вторым параметром значение (чаще всего - Структуру или ТаблицуЗначений) система умеет записывать в файл во внутреннем формате чтобы потом восстановить (возможно - при следующем запуске)
Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #8 : 21-05-2010 05:38 » 

Но более правильно было бы завести в базе соответствующие объекты для хранения
Записан
Gunslinger
Постоялец

ru
Offline Offline

« Ответ #9 : 21-05-2010 05:51 » 

мне нельзя менять дерево конфигурации, поэтому и нужны внешние файлы.. но все-таки хотелось бы увидеть реально работающий код с использованием этих функций..
Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #10 : 21-05-2010 07:28 » 

Поиском религия не дает пользоваться?
Я помогу, если ты реально столкнешься с проблемой, а пока я не вижу никаких действий с твоей стороны кроме как просьб "напиши за меня".
Опубликуй код что ты пробовал и что у тебя не получилось.
Записан
Gunslinger
Постоялец

ru
Offline Offline

« Ответ #11 : 24-05-2010 06:16 » 

Процедура Кнопка1Нажатие(Элемент)
КЧ = Новый КвалификаторыЧисла(12,2);
КС = Новый КвалификаторыСтроки(20);
Массив = Новый Массив;
Массив.Добавить(Тип("Строка"));
ОписаниеТиповС = Новый ОписаниеТипов(Массив, , КС);
Массив.Очистить();
Массив.Добавить(Тип("Число"));
ОписаниеТиповЧ = Новый ОписаниеТипов(Массив, , ,КЧ);

// Создание таблицы значений
ТаблицаЗначений = Новый ТаблицаЗначений;
// добавим в таблицу значений три колонки
ТаблицаЗначений.Колонки.Добавить("МаркаАвтомобиля",ОписаниеТиповС,"МаркаАвтомобиля");
ТаблицаЗначений.Колонки.Добавить("МаркаПрицепа",ОписаниеТиповС,
    "МаркаПрицепа");
ТаблицаЗначений.Колонки.Добавить("Водитель",ОписаниеТиповС,"Водитель");
// добавим строку
Стр=ТаблицаЗначений.Добавить();
Стр.МаркаАвтомобиля=МаркаАвтомобиля;
Стр.МаркаПрицепа=МаркаПрицепа;
Стр.Водитель=Водитель;

   Диалог = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Сохранение);
    Диалог.ПолноеИмяФайла = "test";
    Диалог.Каталог = "C:\";
    Диалог.Заголовок = "Укажите файл для списка запросов";
    Диалог.Фильтр = "Файлы запросов (*.sel)|*.sel|Все файлы (*.*)|*.*";
    Диалог.Расширение = "sel";
    Если Диалог.Выбрать() Тогда
        ИмяФайла = Диалог.ПолноеИмяФайла;
        ИмяПути = Диалог.Каталог;
    Иначе
       Сообщить("!", СтатусСообщения.Важное);
    КонецЕсли;

ЗначениеВФайл(ИмяФайла, ТаблицаЗначений);

КонецПроцедуры

Процедура Кнопка2Нажатие(Элемент)
ПолученноеЗначение = ЗначениеИзФайла ("C:\test.sel");
МаркаАвтомобиля = ПолученноеЗначение.Колонки.Получить(МаркаАвтомобиля);
МаркаПрицепа = ПолученноеЗначение.Колонки.Получить (МаркаПрицепа);
Водитель = ПолученноеЗначение.Колонки.Получить (Водитель);
КонецПроцедуры
 Вот код... Когда в файл выгружается одно значение-проблем нет, а из таблицы значений выгрузить не получается
Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #12 : 24-05-2010 12:01 » 

Что ты пытаешься сделать этим кодом:
Код:
МаркаАвтомобиля = ПолученноеЗначение.Колонки.Получить(МаркаАвтомобиля);
МаркаПрицепа = ПолученноеЗначение.Колонки.Получить (МаркаПрицепа);
Водитель = ПолученноеЗначение.Колонки.Получить (Водитель);
Записан
Gunslinger
Постоялец

ru
Offline Offline

« Ответ #13 : 24-05-2010 12:12 » 

этим кодом, как и
ПолученноеЗначение = ЗначениеИзФайла ("C:\test.sel");
МаркаАвтомобиля = ПолученноеЗначение.Получить(МаркаАвтомобиля);
МаркаПрицепа = ПолученноеЗначение.Получить(МаркаПрицепа);
Водитель = ПолученноеЗначение.Получить(Водитель);
вот этим я пытался заполнить поля реквизитов...
Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #14 : 24-05-2010 12:23 » 

Тебе сначала нужно получить строку таблицы значений, т.е.
Код:
ПолученноеЗначение = ЗначениеИзФайла ("C:\test.sel");
// Если ты уверен, что строка одна, а по предыдущему коду - она у тебя таки одна:
Стр = ПолученноеЗначение[0];
МаркаАвтомобиля = Стр.МаркаАвтомобиля;
// Или Стр.Получить("МаркаАвтомобиля");
...
Кстати если ты всегда планируешь в таблице значений иметь только одну строку - то логичнее було бы использовать Структуру или Соответствие.
Записан
Gunslinger
Постоялец

ru
Offline Offline

« Ответ #15 : 25-05-2010 11:16 » 

Спасибо за помощь...
Еще вопрос чисто из области теории - полдня седня ковырялся, так и не нашел в каком месте передается в форму ссылка на документ, уверен что тут все очень просто - но чето я затупил, подскажите плз
Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #16 : 25-05-2010 11:27 » 

В какую именно форму? Экранную форму документа?
Записан
Gunslinger
Постоялец

ru
Offline Offline

« Ответ #17 : 25-05-2010 12:25 » 

в форму ТТН, верхняя строчка "Документ"
Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #18 : 25-05-2010 12:27 » 

ничего не понял Улыбаюсь
Форма ТТН - это может быть экранная форма (для ввода данных), печатная форма, форма списка ТТН...
Скриншот хотя опубликуй...
Записан
Gunslinger
Постоялец

ru
Offline Offline

« Ответ #19 : 25-05-2010 12:43 » 

Ну да, экранная форма, для ввода данных
Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #20 : 25-05-2010 13:44 » 

Если ты в Конфигураторе в этой форме переключишься на закладку Реквизиты ты увидишь что-то типа ДокументОбъект=ДокументОбъект.ТТН
Ну а поскольку форма у тебя привязана к объекту - то получается в форме тебе доступны все методы и свойства данного объекта, одно из которых - Ссылка.
Записан
Страниц: [1]   Вверх
  Печать  
 

Powered by SMF 1.1.21 | SMF © 2015, Simple Machines