Форум программистов «Весельчак У»
  *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

  • Рекомендуем проверить настройки временной зоны в вашем профиле (страница "Внешний вид форума", пункт "Часовой пояс:").
  • У нас больше нет рассылок. Если вам приходят письма от наших бывших рассылок mail.ru и subscribe.ru, то знайте, что это не мы рассылаем.
   Начало  
Наши сайты
Помощь Поиск Календарь Почта Войти Регистрация  
 
Страниц: [1]   Вниз
  Печать  
Автор Тема: Планы обмена  (Прочитано 6459 раз)
0 Пользователей и 1 Гость смотрят эту тему.
staff
Помогающий

ua
Offline Offline
Пол: Мужской

« : 16-08-2010 06:48 » 

во время выполнения обмена данными по узлу выскакивает ошибка "МодульВнешнегоСоединения: Метод объекта не обнаружен (ПользовательОпределен)

код процедуры в которой выскакивает данная ошибка:

Код:
Процедура ПриНачалеРаботыСистемы()

Если ИмяПользователя() = "_ТестированиеРолей" Тогда
Возврат;
КонецЕсли;

// Вызов исключения, если не прошла процедура определения пользователя
УправлениеПользователями.ПользовательОпределен();

КонецПроцедуры
Записан
staff
Помогающий

ua
Offline Offline
Пол: Мужской

« Ответ #1 : 16-08-2010 08:53 » 

можно закрывать тему проблема решилась, не хватало парочки функций
Записан
staff
Помогающий

ua
Offline Offline
Пол: Мужской

« Ответ #2 : 16-08-2010 09:58 » 

снова по плану обмена

теперь лезет другая ошибка

{ОбщийМодуль.МодульОбмен82Web(278)}: Ошибка при вызове конструктора (COMОбъект): Недопустимая строка с указанием класса: Недопустимая строка с указанием класса
Обмен НЕ произведен.
Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #3 : 16-08-2010 14:04 » 

Возможно нужный объект не зарегистрирован в системе? Какой объект пытается создать?
Записан
staff
Помогающий

ua
Offline Offline
Пол: Мужской

« Ответ #4 : 17-08-2010 06:02 » 

1С пытается создать COMConnector чтобы соединиться с другой базой 1С и вытянуть необходимые данные из документов и справочников. Проблему с СОМ соединением решил путем прохождения "подводных ям", теперь другие ошибки лезут, когда через отладчик смотрю что происходит во время обработки и где лезут новые ошибки, то получается в цикле обработки
Код:
Пока ВозможностьЧтенияXML(ЧтениеXML) Цикл
Данные = ПрочитатьXML(ЧтениеXML);
Данные.ОбменДанными.Отправитель = УзелОтправитель;
Данные.ОбменДанными.Загрузка = Истина;

#Если Клиент Тогда
Состояние("Загрузка: " + Строка(Данные));
#КонецЕсли
ЭтиДанные = Данные;
Данные.Записать();
СчетчикДанных = СчетчикДанных + 1;
КонецЦикла;
в строке
Код:
Данные = ПрочитатьXML(ЧтениеXML);
идет переход на
Код:
ОтменитьТранзакцию();
Соединение.ОтменитьТранзакцию();
Отказ = Истина;
и выдает ошибку {ПланОбмена.______(213)}: Ошибка при вызове метода контекста (ПрочитатьXML): Ошибка преобразования данных XML: [43,4]
Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #5 : 17-08-2010 08:07 » 

Заходи отладчиком внутрь ПрочитатьXML - смотри где там вылетает
Записан
Страниц: [1]   Вверх
  Печать  
 

Powered by SMF 1.1.21 | SMF © 2015, Simple Machines