Форум программистов «Весельчак У»
  *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

  • Рекомендуем проверить настройки временной зоны в вашем профиле (страница "Внешний вид форума", пункт "Часовой пояс:").
  • У нас больше нет рассылок. Если вам приходят письма от наших бывших рассылок mail.ru и subscribe.ru, то знайте, что это не мы рассылаем.
   Начало  
Наши сайты
Помощь Поиск Календарь Почта Войти Регистрация  
 
Страниц: [1]   Вниз
  Печать  
Автор Тема: Новичок.Изменение реквизитов Справочник-Контрагент.  (Прочитано 6670 раз)
0 Пользователей и 1 Гость смотрят эту тему.
Nodir2525
Участник

Offline Offline

« : 06-10-2010 07:52 » 

Контрагент
---ДокументСерия
---ДокументНомер

Документ
---ИзмРеквизитКлиент
-------ДокументСерия
-------ДокументНомер

Я хочу изменит реквизиты в Справочник.Контрагент. (ДокументСерия,ДокументНомер)

Что надо писать мне в модуль документа- Документ.ИзмРеквизитКлиент!!!

У меня в контрагенте модуль Форма элемента только
- Процедура ПриОткрытии()
- Процедура ПриВыбореЗакладки(НомерЗакладки, ЗначениеЗакладки)

Реквизиты водились через документ.
модуль документа

Процедура ОбработкаПроведения()
    СпрК=СоздатьОбъект("Справочник.Контрагент");
    СпрК.Новый();
   СпрК.Наименование=СокрЛП(Фамилия)+" "+СокрЛП(Имя)+" "+СокрЛП(Отчество);
    СпрК.Записать();     
УстановитьРеквизитСправочника(СпрК,"ДокументСерия",ДокументСерия,ДатаДок);
УстановитьРеквизитСправочника(СпрК,"ДокументНомер",ДокументНомер,ДатаДок);
КонецПроцедуры
Записан
AndyG
Постоялец

by
Offline Offline

« Ответ #1 : 06-10-2010 08:09 » 

Опять вопрос поставлен некорректно - приходится додумывать...
я так понял ты хочешь поменять реквизиты справочника из справочника?
должно меняться в диалоге
Но ДокументСерия,ДокументНомер - это ПЕРИОДИЧЕСКИЕ реквизиты,
те они устанавливаются на определенную дату
когда открываешь справочник ввиде списка - установи курсор на нужном элементе
и жми на значек в пенели с названием ИСТОРИЯ - вот там и увидишь значения по датам и сможешь их поменять.
Иначе просто меняешь значения на дату которая в заголовке окна справочника

Если из документа:

Процедура ОбработкаПроведения()
    СпрК=СоздатьОбъект("Справочник.Контрагент");
    ИмяДляПоиска=СокрЛП(Фамилия)+" "+СокрЛП(Имя)+" "+СокрЛП(Отчество);   
    Если СпрК.НайтиПоНаименованию(ИмяДляПоиска,0,1)=0 Тогда
         СпрК.Новый();
        СпрК.Наименование=ИмяДляПоиска;
        СпрК.Записать(); 
    КонецЕсли;   
      УстановитьРеквизитСправочника(СпрК,"ДокументСерия",ДокументСерия,ДатаДок);
    УстановитьРеквизитСправочника(СпрК,"ДокументНомер",ДокументНомер,ДатаДок);
КонецПроцедуры
« Последнее редактирование: 06-10-2010 08:16 от AndyG » Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #2 : 06-10-2010 08:30 » 

Nodir2525, Да - я тоже не понял что и откуда ты хочешь менять...
Записан
Nodir2525
Участник

Offline Offline

« Ответ #3 : 06-10-2010 12:01 » 

Изменение через документ.
Открываю документ изменение.
Клиент = Справочник. Контрагент – Наименование;
Я выбираю один из Клиентов который действующий в контрагенте.
Выбираю Клиент:
---Когда выбираю Клиент,  Справочник. Контрагент – Наименование пустой.
ФИО не видно.Не понял (на краю значки видно)

Процедура ОбработкаПроведения()
    СпрК=СоздатьОбъект("Справочник.Контрагент");
    Клиент=СокрЛП(Фамилия)+" "+СокрЛП(Имя)+" "+СокрЛП(Отчество);   
    Если СпрК.НайтиПоНаименованию(Клиент,0,1)=0 Тогда
         СпрК.Новый();
        СпрК.Наименование=Клиент;
        СпрК.Записать(); 
    КонецЕсли;   
      УстановитьРеквизитСправочника(СпрК,"ДокументСерия",ДокументСерия,ДатаДок);
    УстановитьРеквизитСправочника(СпрК,"ДокументНомер",ДокументНомер,ДатаДок);
КонецПроцедуры

не работает!!!
На справочник. контрагенте реквизите не меняется.
Ошибка!!!
СпрК.Записать(); 
{Документ.ИзмРеквизитКлиентФиз.Модуль Документа(8)}: Неверно задан код!

1).Как связывать "Клиент" с Контрагентом?
2). Когда выбираю Клиент,  Справочник. Контрагент – Наименование пустой.
ФИО не видно.Не понял (на краю значки видно)
3). Ошибка!!!
СпрК.Записать(); 
{Документ.ИзмРеквизитКлиентФиз.Модуль Документа(8)}: Неверно задан код!

Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #4 : 06-10-2010 15:44 » 

Давай хотя бы скриншот сюда, а то еще больше запутал Улыбаюсь
Записан
Nodir2525
Участник

Offline Offline

« Ответ #5 : 07-10-2010 04:36 » 

У меня
Контрагент
--Фамилия
--Имя
--Отчество
--ДокументНомер
--ДокументСерия

Документ
--Фамилия
--Имя
--Отчество
--ДокументНомер
--ДокументСерия

В Контрагенте существует несколько ФИО.
Надо один из ФИО изменит реквизиты.
Как через документ изменит реквизиты в справочник. контрагенте.
Модуль Документа-???
Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #6 : 07-10-2010 14:53 » 

несколько ФИО - это в смысле разные значения периодических ревизитов в разное время?
Если так - то это тот случай, что мы разбирали: сначала ОбработкаПроведения() найди нужный тебе элемент справочника а потом используй УстановитьРеквизитСправочника()
Записан
Страниц: [1]   Вверх
  Печать  
 

Powered by SMF 1.1.21 | SMF © 2015, Simple Machines