Форум программистов «Весельчак У»
  *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

  • Рекомендуем проверить настройки временной зоны в вашем профиле (страница "Внешний вид форума", пункт "Часовой пояс:").
  • У нас больше нет рассылок. Если вам приходят письма от наших бывших рассылок mail.ru и subscribe.ru, то знайте, что это не мы рассылаем.
   Начало  
Наши сайты
Помощь Поиск Календарь Почта Войти Регистрация  
 
Страниц: [1]   Вниз
  Печать  
Автор Тема: Вопросы ПРОФЕССИОНАЛАМ  (Прочитано 7203 раз)
0 Пользователей и 1 Гость смотрят эту тему.
kidman
Гость
« : 18-04-2006 08:19 » 

Вопросы ПРОФЕССИОНАЛАМ
Даная тема создана чтоб задавать глупые вопросы по существу.

Вопрос 1: Подскажите как.... Найти нужный документ в "Общем журнале докуметов"
и проверить его на корректность заполнения, основываясь на некоторые элементы "Справочника".
Заранее благодарен.
« Последнее редактирование: 18-04-2006 08:22 от kidman » Записан
Harry
Модератор

ua
Offline Offline

« Ответ #1 : 18-04-2006 08:46 » 

Для того, чтобы задавать вопросы по существу, хоть и глупые - весь форум, а не только этот пост. Здесь говорим только об общем журнале. Итак:
Если общий журнал хорошо написан, там должна быть возможность фильтрации по типу документов. Отбираешь, выбираешь нужный, открываешь... а дальше я не понял. Что за документ, какие элементы справочника используем? Поподробнее...
Записан

Слабый пол силен в силу слабости сильного пола к слабому
kidman
Гость
« Ответ #2 : 18-04-2006 10:27 » 

ДА это все известно....
Мне необходимо...программно из внешнего обработчика....
ПОДРОБНО: Создаем документ "Инвентаризация" туда забиваем товар и факт.количество. Сохраняем.

Затем открываем внешний обработчик и запускаем проверку, те. выбираем
 группу товаров в справочнике и сравниваем эти товары и вид товара в документах "Инвентаризация" с группой в справочнике. Каждый товар должен лежать в своей группе иначе ...(так вот эта проверка и не работает)....

если есть подробный учебник по языку 1с... или подскажите где его можно слить
Спасибо.
Записан
Harry
Модератор

ua
Offline Offline

« Ответ #3 : 18-04-2006 11:08 » 

Создаешь новую обработку, кидаешь на нее контрол ВыбГруппа типа Справочник.Товары, причем в процедуре ПриОткрытии() задаешь условие, что если ВыбГруппа.ЭтоГруппа()=0 тогда обработка не запускается.

Процедура ПриОткрытии()
   Если ВыбГруппа.ЭтоГруппа()=0 Тогда
      Возврат;
   КонецЕсли;
КонецПроцедуры

//Основная процедура следующая:

             Процедура Сформировать()
   Док=СоздатьОбъект("Документ.Инвентаризация");
   Док.Выбрать("Выберите документ");  //выбираем нужную инвентаризацию
             Док.ВыбратьСтроки();
             Пока Док.ПолучитьСтроку()=1 Цикл
                 Если Док.Товар.Родитель<>ВыбГруппа.Родитель Тогда //сравниваем группы элементов
                     Сообщить(Док.Товар.Наименование); //или Док.Товар.Код
                     Сообщить("Товар принадлежит группе "+Док.Товар.Родитель);
                       //Если не совпали, выводим, к какой же группе относится товар
                 КонецЕсли;
             КонецЦикла;
            КонецПроцедуры

Учебник по 1С 7,7 есть в ссылках на форуме (тема, посвященная полезным ссылкам). Не найдешь - пиши мыло, пришлю.
Записан

Слабый пол силен в силу слабости сильного пола к слабому
kidman
Гость
« Ответ #4 : 19-04-2006 06:21 » 

Вопро
Записан
Harry
Модератор

ua
Offline Offline

« Ответ #5 : 19-04-2006 07:12 » 

Мануал скинул. Написан тяжко, почти без примеров, но помочь может. Рекомендую при написании пользоваться синтаксис-помощником (правой кнопкой и там одноименная команда). На порядок полезнее, если забываю синтаксис команд - пользуюсь им и сейчас.
Насчет сообщений - можно только пиктограммки менять. Цвет и стиль - нет.
Записан

Слабый пол силен в силу слабости сильного пола к слабому
kidman
Гость
« Ответ #6 : 19-04-2006 07:34 » 

Harry,
Спасибо!
Записан
Harry
Модератор

ua
Offline Offline

« Ответ #7 : 19-04-2006 11:38 » 

Что-то письма возвращаются, с двух ящиков уже посылал. Ты адрес правильно указал?
Записан

Слабый пол силен в силу слабости сильного пола к слабому
kidman
Гость
« Ответ #8 : 19-04-2006 12:30 » 

Harry,
Извини !....перепутал...
dmtrfoxerr@nm.ru
Записан
Harry
Модератор

ua
Offline Offline

« Ответ #9 : 19-04-2006 14:27 » 

То-то Улыбаюсь
Ушло.
Записан

Слабый пол силен в силу слабости сильного пола к слабому
Страниц: [1]   Вверх
  Печать  
 

Powered by SMF 1.1.21 | SMF © 2015, Simple Machines