Форум программистов «Весельчак У»
  *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

  • Рекомендуем проверить настройки временной зоны в вашем профиле (страница "Внешний вид форума", пункт "Часовой пояс:").
  • У нас больше нет рассылок. Если вам приходят письма от наших бывших рассылок mail.ru и subscribe.ru, то знайте, что это не мы рассылаем.
   Начало  
Наши сайты
Помощь Поиск Календарь Почта Войти Регистрация  
 
Страниц: [1]   Вниз
  Печать  
Автор Тема: вопросы по Qt  (Прочитано 2834 раз)
0 Пользователей и 1 Гость смотрят эту тему.
Алексей++
глобальный и пушистый
Глобальный модератор

ru
Offline Offline
Сообщений: 13


WWW
« : 05-09-2010 16:23 » 

вот такие вопросы имеются:

1)
Например, если в ресурсы засунута картинка, то в QImage картинка прекрасно вставляется
QImage im(":/pict/file.png");
А вот с QSound почему-то не получается создать из ресурса , хотя из файла, лежащего на диске, всё нормально работает.
Глюк QSound или что-то не так делаю ?

2) в объект типа QSound загружен файл. Первый раз звук проигрывается с некоторой задержкой на долю секунды. Когда звук привязан к кадру в анимации, это очень заметно - кадр немного спотыкается. Повторно звук уже без тормоза проигрывается. Можно как-то "инициализировать" звук заранее ?

3) если по какой либо причине QSound не смог загрузить звук из файла, то play вякает из спикера - как от этого избавиться ?
Записан

Страниц: [1]   Вверх
  Печать  
 

Powered by SMF 1.1.21 | SMF © 2015, Simple Machines