Форум программистов «Весельчак У»
  *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

  • Рекомендуем проверить настройки временной зоны в вашем профиле (страница "Внешний вид форума", пункт "Часовой пояс:").
  • У нас больше нет рассылок. Если вам приходят письма от наших бывших рассылок mail.ru и subscribe.ru, то знайте, что это не мы рассылаем.
   Начало  
Наши сайты
Помощь Поиск Календарь Почта Войти Регистрация  
 
Страниц: [1]   Вниз
  Печать  
Автор Тема: Гиперссылка  (Прочитано 9938 раз)
0 Пользователей и 1 Гость смотрят эту тему.
mir-mup
Гость
« : 22-09-2010 12:49 » 

Необходимо создать кнопку на форме, которая открывает ВНЕШНИЙ файл, с жеского диска(и прикрепляет гиперссылку чтобы потом можно было по ней, или по другой кнопке, открыть этот файл). Очень долго бьюсь нарыл кучу литературы, но ничего не выходит:
http://www.sql.ru/forum/actualthread.aspx?bid=63&tid=547230&pg=1
http://www.forum.mista.ru/topic.php?id=506312

не могу понять что делаю не так. Очень прошу помощи.
Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #1 : 22-09-2010 17:48 » 

Ничего не понял про гиперссылки - зачем они тебе нужны?
Чтобы открыть файл (гиперссылку) зарегистрированным в системе приложением нужно выполнить ЗапуститьПриложение(), передав в качестве первого параметра полный путь к файлу или гиперссылку.
Записан
mir-mup
Гость
« Ответ #2 : 23-09-2010 05:06 » 

Архив томов книг чтобы не бегать каждый раз и не брать книжку с полки, реквизиты какие нужно разумеется поставил уже сам заговздка только в гиперссылке(для чего нужно).  Причём в базе храниться документы не должны(вес).
должна быть гиперссылка на форме чтобы можно было открыть/прикрепить внешний файл ворд или картинку(ранне отсканированную) по этой гиперссылке ссылке.
Очень прошу помощи долбаюсь уже неделю.
Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #3 : 23-09-2010 13:51 » 

Почему обязательно гиперссылка? чем не устраивает посто кнопка?
Для "гиперссылки" суть будет та же: отлавливаешь событие нажатия и вызываешь ЗапуститьПриложение() с указанием пути к файлу.
Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #4 : 23-09-2010 13:56 » 

Опубликуй код как ты делаешь...
Записан
mir-mup
Гость
« Ответ #5 : 24-09-2010 06:26 » 

согласен на любые варианты ссылка кнопка.... надпись.
делаю так:
создаю справочник
создаю в нем реквизиты(рекв. объект тип строка, рекв. фото тип хранилище значения)
Создаю форму элемента справочника:
Объект
Декорация надпись(флаг гипрессылака, надпись нажатие "текст процедуры".):
текст процедуры такой:
//пример открытия и чтения файла:
Процедура МегаКнопаНажатие(Элемент)
    //открываем диалог выбора файла
    Диалог = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
    Диалог.Заголовок = "Выберите файл...";
    Диалог.ПредварительныйПросмотр = Ложь;
    Диалог.МножественныйВыбор = Ложь;
    Диалог.Фильтр = "Текстовые файлы (*.doc)|*.doc";
    Диалог.Каталог = "D:\";
    Если Диалог.Выбрать() Тогда
        ПутьКФайлу = Диалог.ПолноеИмяФайла;
    Иначе
        Возврат;
    КонецЕсли;
    //читаем файл
    Текст = Новый ЧтениеТекста(ПутьКФайлу, КодировкаТекста.UTF8);
    Строка = Текст.ПрочитатьСтроку();
    Пока Строка <> Неопределено Цикл
        Строка = Текст.ПрочитатьСтроку();
        Сообщить(Строка);
    КонецЦикла;
КонецПроцедуры

далее запускаю обрабочик:
выбрать файл можно который нужно привязывать а открыть привязанный нет ни кнопки ни фига короче нет.
повторюсь еще раз:
задача такая нужно чтобы ПОЛЬЗОВАТЕЛЬ мог привязать  внешний файл, чтобы при надобности его открыть по кнопке(надписи или хз какого элемента)
Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #6 : 24-09-2010 11:30 » 

Offtopic:
Процедура МегаКнопаНажатие(Элемент) - повеселило Улыбаюсь

Цитата
флаг гипрессылака, надпись нажатие "текст процедуры"
А вот это не понял - ты привязал свою процедуру к событию Нажатие надписи? Или просто создал процедуру с таким именем?

P.S. Научись пользоваться тегами [code][/code]
Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #7 : 24-09-2010 11:32 » 

Да - и если я правильно понимаю задачу - то тебе нужно как минимум 2 кнопки (а лучше 3): выбрать файл, открыть файл, очистить путь к файлу. У каждой кнопки (гиперссылки - не важно) будет свой обработчик события, который и будет делать то, что нужно.
Записан
mir-mup
Гость
« Ответ #8 : 24-09-2010 11:41 » 

Улыбаюсь да именно. Две кнопки или три. Как я понял нужно поместить гиперссылку в реквезит(хранилще данных)
а от туда при нажатии ссылаться на внешний файл.
как это организованно например в ворде. 
Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #9 : 24-09-2010 12:08 » 

Цитата
Как я понял нужно поместить гиперссылку в реквезит(хранилще данных)
Нужно завести реквизит ПутьКФайлу, куда поместить локальный путь к файлу - гиперссылка тут ни при чем. Тип реквизита - строка неограниченной длины
Кнопка "Изменить" этот путь меняет на выбранный файл (этот код у тебя написан)
Кнопка "Открыть" выполняет ЗапуститьПриложение(ПутьКФайлу), если файл существует
Кнопка "Очистить" присваивает пути пустую строку (файл не связан)
Записан
mir-mup
Гость
« Ответ #10 : 27-09-2010 06:03 » 

Спасибо за подсказку все правельно так и делаю, но вот как в декорации НайтиФайл прописать код чтобы найти файл.  и в декорации ОткрытьФайл код, чтобы его открыть.... вот самая большая загвоздка...  долбаюсь уже не меренное время.... и очень прошу Вашей помощи уважаемые Гуру.
Записан
mir-mup
Гость
« Ответ #11 : 27-09-2010 08:04 » 

Создал рекв. ПутьКФайлу. длинна не ограниченная, строка.
создал две дикорации на них код.

Процедура ДекорацияНажатие(Элемент)
        //открываем диалог выбора файла
 
    Диалог = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
    Диалог.Заголовок = "Выберите файл...";
    Диалог.ПредварительныйПросмотр = Ложь;
    Диалог.МножественныйВыбор = Ложь;
    Диалог.Фильтр = "Текстовые файлы (*.doc)|*.doc";
    Диалог.Каталог = "D:\";
    Если Диалог.Выбрать() Тогда
        ПутьКФайлу = Диалог.ПолноеИмяФайла;
    Иначе
        Возврат;
    КонецЕсли;
    //читаем файл
 
    Текст = Новый ЧтениеТекста(ПутьКФайлу, КодировкаТекста.ANSI);
    Строка = Текст.ПрочитатьСтроку();
    Пока Строка <> Неопределено Цикл
        Строка = Текст.ПрочитатьСтроку();
        Сообщить(Строка);
    КонецЦикла;

КонецПроцедуры



&НаКлиенте
Процедура СсылкаНаФайлНажатие(Элемент)
    // Вставить содержимое обработчика.
 
   
    Сообщить(ПутьКФайлу);
   
    //Текст = Новый ЧтениеТекста(ПутьКФайлу, КодировкаТекста.ANSI);
 
    //Текст.Открыть();       
 
    ЗапуститьПриложение(ПутьКФайлу);
КонецПроцедуры
после закрытия формы ссылка перестает работать. (при открытой работает)
Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #12 : 27-09-2010 10:01 » 

ПутьКФайлу - это реквизит чего? Форма соответствует какому объекту?
Записан
mir-mup
Гость
« Ответ #13 : 27-09-2010 10:46 » 

да могу скинуть базу там один справочник 114 кб всего весит. тормознулся и не знаю что дальше делать...
Записан
mir-mup
Гость
« Ответ #14 : 27-09-2010 10:47 » 

да реквизит ПутьКФайлу тип строка, неопр длинны. Не знаю как в него запихать путь чтоб он сохранялся в этом реквезите.
Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #15 : 27-09-2010 10:50 » 

Прикрепи сюда к собщению
Записан
mir-mup
Гость
« Ответ #16 : 27-09-2010 10:57 » 

база 8.2  справочник ИмпортДокументов

* 1Cv8.dt (140.26 Кб - загружено 137 раз.)
Записан
mir-mup
Гость
« Ответ #17 : 27-09-2010 13:41 » 

Большое спасибо за помощь, эту задчу уже решил.   Спасибо что помогали.
Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #18 : 27-09-2010 19:03 » 

mir-mup, напиши что не так было, а то руки так и не дошли скачать и разобраться...
Записан
Страниц: [1]   Вверх
  Печать  
 

Powered by SMF 1.1.21 | SMF © 2015, Simple Machines