Форум программистов «Весельчак У»
  *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

  • Рекомендуем проверить настройки временной зоны в вашем профиле (страница "Внешний вид форума", пункт "Часовой пояс:").
  • У нас больше нет рассылок. Если вам приходят письма от наших бывших рассылок mail.ru и subscribe.ru, то знайте, что это не мы рассылаем.
   Начало  
Наши сайты
Помощь Поиск Календарь Почта Войти Регистрация  
 
Страниц: [1]   Вниз
  Печать  
Автор Тема: Не выполняется процедура  (Прочитано 2747 раз)
0 Пользователей и 1 Гость смотрят эту тему.
Sulik
Помогающий

ru
Offline Offline
Пол: Мужской

« : 19-11-2010 13:15 » 

Доброго всем вечера. Почему после КонецЦикла не запускается процедура ЗапуститьПриложение. После КонецЦикла ничего не выполняется, даже на точку останова не реагирует.

Код:
Процедура НаДискНажатие(Элемент)

 КаталогВызоваСбис = "C:\Sbis\Prog";
//КаталогСохранения = "C:\Sbis\Send";

Отказ = Ложь;
СохранитьДокументы(Отказ, РежимДиалогаВопрос.ОКОтмена);
Если Отказ Тогда
Возврат;
КонецЕсли;

СохранениеТекущихДанных();

Длг = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.ВыборКаталога);
Длг.Каталог = УправлениеПользователями.ПолучитьЗначениеПоУмолчанию(глЗначениеПеременной("глТекущийПользователь"),"ОсновнойКаталогФайлов");
Длг.Заголовок = "Укажите каталог";

Если Длг.Выбрать() Тогда
КаталогСохранения = Длг.Каталог;
СтрокаСообщений = "";
Для каждого ЭлементСоответствия Из СоответствиеСсылокИОбъектов Цикл
Пачка = ЭлементСоответствия.Ключ;
Если НЕ Пачка.Пустая() Тогда
ОбъектДействия = ЭлементСоответствия.Значение;

ИмяФайла = ПроцедурыПерсонифицированногоУчета.ПолучитьИмяФайлаПФ(ОбъектДействия.Ссылка, Год(ОтчетныйПериод));

ЕстьОшибки = Ложь;
ТекстФайла = РегламентированнаяОтчетность.ПолучитьТекстФайла(ОбъектДействия, ЕстьОшибки);
Если ЕстьОшибки Тогда
Возврат;
КонецЕсли;

ИмяФайла = КаталогСохранения + "\" + ИмяФайла;
ТекстовыйДокумент = Новый ТекстовыйДокумент;
ТекстовыйДокумент.УстановитьТекст(ТекстФайла);
ТекстовыйДокумент.Записать(ИмяФайла,КодировкаТекста.ANSI);
СтрокаСообщений = СтрокаСообщений + " по документу " + СокрЛП(ОбъектДействия) + " сформирован файл " + ИмяФайла + Символы.ПС;


КонецЕсли;
 
КонецЦикла;

     Попытка
    ЗапуститьПриложение(КаталогВызоваСбис + "\\run_dipost.bat " + "/r:ЗакачатьИУдалитьПапкуКакОтчеты(\""" + КаталогСохранения + """);");
    Предупреждение("Файлы успешно переданы в ""СБиС++ Электронная отчетность""!");
  Исключение
    Предупреждение("При запуске приложения для отправки отчетности произошла ошибка:" + Символы.ПС + ОписаниеОшибки());
  КонецПопытки;
    Сообщить(ЭлементСоответствия);
    Предупреждение(СтрокаСообщений);
КонецЕсли;


КонецПроцедуры
« Последнее редактирование: 19-11-2010 13:19 от Sulik » Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #1 : 19-11-2010 14:35 » 

Код:
Если ЕстьОшибки Тогда
Возврат;
КонецЕсли;
Записан
Sulik
Помогающий

ru
Offline Offline
Пол: Мужской

« Ответ #2 : 19-11-2010 15:12 » 

Спасибо;
простите за невнимательность.
Записан
Страниц: [1]   Вверх
  Печать  
 

Powered by SMF 1.1.21 | SMF © 2015, Simple Machines