Форум программистов «Весельчак У»
  *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

  • Рекомендуем проверить настройки временной зоны в вашем профиле (страница "Внешний вид форума", пункт "Часовой пояс:").
  • У нас больше нет рассылок. Если вам приходят письма от наших бывших рассылок mail.ru и subscribe.ru, то знайте, что это не мы рассылаем.
   Начало  
Наши сайты
Помощь Поиск Календарь Почта Войти Регистрация  
 
Страниц: 1 [2]  Все   Вниз
  Печать  
Автор Тема: Выбрать нужный Элемент  (Прочитано 19249 раз)
0 Пользователей и 1 Гость смотрят эту тему.
Стервочка
Гость
« Ответ #30 : 21-03-2010 21:57 » 

В глобальном модуле написано
Код:
Функция глВНаличии(Оборудование) Экспорт
ВыданноеОборудование=СоздатьОбъект("Справочник.ВыданноеОборудование");
ДаНет="";
Если Оборудование.ЭтоГруппа()=0 Тогда
Если ВыданноеОборудование.НайтиПоРеквизиту("Оборудование",Оборудование,1)=1 Тогда
ДаНет="Нет";
Иначе
ДаНет="Да";
КонецЕсли;
КонецЕсли;
Возврат(ДаНет);
КонецФункции
Т.е. если в справочнике "ВыданноеОборудование" есть строка с данным оборудованием, то оно считает, что в данный момент оборудования нет вообще... Как сделать, чтоб оно считало так только в случае, если в справочнике "Номенклатура" в реквизите "КоличествоВНаличии" стоит 0??? Я уже пробовала писать все, что только могла, но ерунда какая-то...  А черт его знает...
Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #31 : 22-03-2010 18:04 » 

Код:
Если Оборудование.ЭтоГруппа()=0 Тогда
Если Оборудование.КоличествоВНаличии=0 Тогда
Если ВыданноеОборудование.НайтиПоРеквизиту("Оборудование",Оборудование,1)=1 Тогда
ДаНет="Нет";
Иначе
ДаНет="Да";
КонецЕсли;
Иначе
ДаНет="Да";
КонецЕсли;
КонецЕсли;
Записан
Стервочка
Гость
« Ответ #32 : 22-03-2010 18:05 » 

Пасыба, только я о5 тебя опередила и сделала сама))))
Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #33 : 22-03-2010 18:08 » 

Offtopic:
Ну вот, а говорила:
Я уже пробовала писать все, что только могла...
Значит - не все? Улыбаюсь)
Записан
Страниц: 1 [2]  Все   Вверх
  Печать  
 

Powered by SMF 1.1.21 | SMF © 2015, Simple Machines