Форум программистов «Весельчак У»
  *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

  • Рекомендуем проверить настройки временной зоны в вашем профиле (страница "Внешний вид форума", пункт "Часовой пояс:").
  • У нас больше нет рассылок. Если вам приходят письма от наших бывших рассылок mail.ru и subscribe.ru, то знайте, что это не мы рассылаем.
   Начало  
Наши сайты
Помощь Поиск Календарь Почта Войти Регистрация  
 
Страниц: [1]   Вниз
  Печать  
Автор Тема: Переменная не определена.  (Прочитано 13647 раз)
0 Пользователей и 1 Гость смотрят эту тему.
CofRamGrad
Участник

ua
Offline Offline
Пол: Женский

« : 30-01-2010 13:41 » 

Код:
Процедура ДействияФормыДействиеПечать(Кнопка)

Если ЭлементыФормы.СправочникСписок.ТекущиеДанные = Неопределено тогда
Возврат
КонецЕсли;

Если ЭлементыФормы.СправочникСписок.ТекущиеДанные.ЭтоГруппа Тогда
Возврат;
КонецЕсли;

УниверсальныеМеханизмы.НапечататьДокументИзФормыСписка(ЭлементыФормы.СправочникСписок.ТекущиеДанные.Ссылка);

КонецПроцедуры

Выпрыгивают ошибки:
{Справочник.ОсновныеСредства.Форма.ФормаВыбора.Форма(9,7)}: Переменная не определена (ЭлементыФормы)
Если <<?>>ЭлементыФормы.СправочникСписок.ТекущиеДанные = Неопределено тогда (Проверка: Сервер)
{Справочник.ОсновныеСредства.Форма.ФормаВыбора.Форма(13,7)}: Переменная не определена (ЭлементыФормы)
Если <<?>>ЭлементыФормы.СправочникСписок.ТекущиеДанные.ЭтоГруппа Тогда (Проверка: Сервер)

И так по многим формам справочников С ума сойти...

----------------------------------------------------------------------------

Мне сказали перенести Документ НалоговаяНакладная с 1С 8.1 на 1С 8.2!!!! При создании этого документа пришлось создать дополнительно много справочников, перечислений, общих модулей...

Подскажите пожалуйста!!! Краснею

Мне надо добить это задание до понедельника, а я в ступоре!!!! Я шокирован!

Спасибо!!!!
« Последнее редактирование: 30-01-2010 14:29 от Sel » Записан

Драаааааааааааасти!!! Улыбаюсь
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #1 : 30-01-2010 15:00 » 

В каком из режимов 8.2 ты пытаешься это выполнить?
В режиме тонкого клиента у тебя нету доступа к элементам формы...
Записан
CofRamGrad
Участник

ua
Offline Offline
Пол: Женский

« Ответ #2 : 31-01-2010 18:11 » 

Дело в том, что я практически начинала работать на 1С 8.1 и не решала глобальных задач (опыта работы 2 месяца), а вот на 1С 8.2 вообще опыта 0!!!!((( Как узнать, в каком режиме я нахожусь??? Краснею

Спасибо!

Еще я отметила все подсистемы и функциональные опции! Это плохо? Вообще, это может на что-то повлиять?
« Последнее редактирование: 31-01-2010 18:46 от Sel » Записан

Драаааааааааааасти!!! Улыбаюсь
CofRamGrad
Участник

ua
Offline Offline
Пол: Женский

« Ответ #3 : 31-01-2010 19:56 » 

Kivals,  ответь, пожалуйста!!!!!!!!!!!!!!
Записан

Драаааааааааааасти!!! Улыбаюсь
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #4 : 02-02-2010 15:59 » 

Kivals,  ответь, пожалуйста!!!!!!!!!!!!!!
На выходных часто с семьей и не читаю форум...

А что тебе нужно от "перенести Документ НалоговаяНакладная"?
Какая конфигурация на 8.2? Почему в ней нет такого документа?
Если конфа написана под 8.2 и в нее надо внедрить документ из 8.1 (НН - достаточно серьезный документ, хочу заметить) причем в режиме тонкого клиента/web интефейса - то это задача не одного дня даже для профессионала.
Опиши подробней задачу - может что-то придумаем...
Записан
CofRamGrad
Участник

ua
Offline Offline
Пол: Женский

« Ответ #5 : 03-02-2010 07:39 » 

Спасибо, там действительно задачка была веселенькая, на фирме информацию базы с версии 8.1 переносили в 8.2, при этом очень много было внесено изменений. Налоговой накладной вообще не было как всех СправочниковСсылок, Перечислений, Общих модулей и т.д. У меня была запара именно с тем, что я не знала что надо в формах явно прописывать клиент-сервер))))
Но с этим уже разобралась;)
Если еще будут вопросы, обращусь!!!;)
Записан

Драаааааааааааасти!!! Улыбаюсь
CofRamGrad
Участник

ua
Offline Offline
Пол: Женский

« Ответ #6 : 04-02-2010 09:33 » 

В общем, мою работу забраковали, сказали, что зря я добавляла кучу справочников!!! Я на руки получила 2 СОВЕРШЕННО РАЗНЫХ СИСТЕМЫ. Они внутри вообще разные.
Налоговая накладная - это документ, который должен быть напечатан на бумаге и там не имеет значения, в какой системе он выписан.
Предполагалось, что я увижу, какой это документ, как выглядит и что нужно для печати его на бумагу и СДЕЛАЮ ЭКВИВАЛЕНТ, а не копию. Вот!!!
-------------
Какие реквизиты мне надо для печати налоговой накладной в УНФ (1С 8.2), а какие нет?
Очередной раз прошу о помощи!!!! Спасибо!!!
Записан

Драаааааааааааасти!!! Улыбаюсь
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #7 : 04-02-2010 09:47 » 

К сожалению не знаком с российским налоговым законодательством.
В украинском без введения отдельного докуммента в конфиграцию не обойтись, т.к. НН выписывается по первому событию: оплате или отгрузке, т.е. если имеем:
1.1.2010: оплата 100 - выписываем НН на 100
2.1.2010: отгрузка 150 - выписываем НН на 50 (разница)
3.1.2010: оплата 20 - не выписываем НН
4.1.2010: оплата 30 - не выписываем НН
Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #8 : 04-02-2010 09:49 » 

Так что я тебе советую по-любому вводить новый документ в конфигурацию, а какие в нем будут реквизиты - в первую очередь смотри на параметры в печатной форме
Записан
CofRamGrad
Участник

ua
Offline Offline
Пол: Женский

« Ответ #9 : 04-02-2010 10:27 » 

ок! Спасибо))
Записан

Драаааааааааааасти!!! Улыбаюсь
Страниц: [1]   Вверх
  Печать  
 

Powered by SMF 1.1.21 | SMF © 2015, Simple Machines