Форум программистов «Весельчак У»
  *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

  • Рекомендуем проверить настройки временной зоны в вашем профиле (страница "Внешний вид форума", пункт "Часовой пояс:").
  • У нас больше нет рассылок. Если вам приходят письма от наших бывших рассылок mail.ru и subscribe.ru, то знайте, что это не мы рассылаем.
   Начало  
Наши сайты
Помощь Поиск Календарь Почта Войти Регистрация  
 
Страниц: [1]   Вниз
  Печать  
Автор Тема: Доступность ячейки  (Прочитано 6645 раз)
0 Пользователей и 1 Гость смотрят эту тему.
Gunslinger
Постоялец

ru
Offline Offline

« : 05-03-2010 15:21 » 

Снова здравствуйте. Вопрос: есть ли возможность сделать недоступной для редактирования одну ячейку табличной части документа? почему-то метод Доступность применяется только ко всей табличной части целиком
Записан
Dest
Опытный

ru
Offline Offline

« Ответ #1 : 06-03-2010 00:23 » 

Можно сделать не доступным конкретный столбец

* Безымянный.png (25.76 Кб - загружено 242 раз.)
Записан
Gunslinger
Постоялец

ru
Offline Offline

« Ответ #2 : 06-03-2010 18:19 » 

угу. а если мне надо будет по условию сделать его потом обратно доступным?
Записан
Dest
Опытный

ru
Offline Offline

« Ответ #3 : 06-03-2010 23:14 » 

ЭлементыФормы.Товары.Колонки.Номенклатура.Доступность = ложь;

ЭлементыФормы.ИмяТабличнойЧасти.Колонки.ИмяКолонки.Доступность = ложь;
Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #4 : 09-03-2010 09:06 » 

В 8.1 можно сделать недоступной и ячейку (вроде так):
ЭлементыФормы.ИмяТабличнойЧасти.Колонки.ИмяКолонки.ПолучитьЭлементУправления().Доступность
Записан
Gunslinger
Постоялец

ru
Offline Offline

« Ответ #5 : 12-03-2010 09:22 » 

Спасибо за помощь. Извините что не в тему но вот еще проблема: при вводе первой строки в табличную часть документа выскакивает ошибка

 {Документ.Смена.Форма.ФормаДокумента(4)}: Значение не является значением объектного типа (ЗвонокПринят)
    Стр.ЗвонокПринят=ТекущаяДата();

если нажать ок и вводить дальше то все нормально. вот код из модуля формы:

роцедура ТабличнаяЧасть1ПередНачаломДобавления(Элемент, Отказ, Копирование)
   Стр=ЭлементыФормы.ТабличнаяЧасть1.ТекущиеДанные;
    Стр.ЗвонокПринят=ТекущаяДата();
    Стр.ТипЗаказа=Перечисления.ТипЗаказа.Сейчас;
    ЭлементыФормы.ТабличнаяЧасть1.Колонки.ЗвонокПринят.Доступность=Ложь;
    ЭлементыФормы.ТабличнаяЧасть1.Колонки.ПодачаМашины.Доступность=Ложь;
    КонецПроцедуры

Процедура ТабличнаяЧасть1ТипЗаказаПриИзменении(Элемент)
         Стр=ЭлементыФормы.ТабличнаяЧасть1.ТекущиеДанные;
   Если Стр.ТипЗаказа = Перечисления.ТипЗаказа.Заказ  Тогда
      ЭлементыФормы.ТабличнаяЧасть1.Колонки.ПодачаМашины.Доступность=Истина;
         КонецЕсли;
      
      КонецПроцедуры
подскажите что я не учел
Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #6 : 12-03-2010 17:56 » 

Gunslinger, неверно выбрано событие:
не ПередНачаломДобавления, а ПриНачалеРедактирования
Записан
Страниц: [1]   Вверх
  Печать  
 

Powered by SMF 1.1.21 | SMF © 2015, Simple Machines