Форум программистов «Весельчак У»
  *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

  • Рекомендуем проверить настройки временной зоны в вашем профиле (страница "Внешний вид форума", пункт "Часовой пояс:").
  • У нас больше нет рассылок. Если вам приходят письма от наших бывших рассылок mail.ru и subscribe.ru, то знайте, что это не мы рассылаем.
   Начало  
Наши сайты
Помощь Поиск Календарь Почта Войти Регистрация  
 
Страниц: [1]   Вниз
  Печать  
Автор Тема: и снова оно(Поле агрегатного объекта необнаруженно)  (Прочитано 5723 раз)
0 Пользователей и 1 Гость смотрят эту тему.
Radistka
Помогающий

ru
Offline Offline
Пол: Женский

« : 24-01-2011 05:51 » 

при попытке запустить код, всё отрабатывает, выводит документы в таблицу. когда пробую открыть документы по расшифровке(ДокумТемп#), то получаю предупреждение "поле агрегатного объекта не обнаружено(код):11". нажимаю на ОК - предупреждение выдаётся заново, 1Ска закрывается только через диспетчер задач, сбивая индексы.


Процедура ОбработкаЯчейкиТаблицы(ЗначМ,Флаг,Табл,Адрес) 
Зап_=СоздатьОбъект("Запрос");
   КДата      = КонМесяца(КонДата); 
   НДата      = НачМесяца(НачДата);
   ДН         = Дата(0);
   ДК         = ТекущаяДата();
   
   Строка_   = Число(Сред(Адрес, 2, Найти(Адрес,"C")-1));     
   Колонка_ = Число(Прав(Адрес, СтрДлина(Адрес) - Найти(Адрес, "C")));     


   ТЗапроса =
   "//{{ЗАПРОС(Сформировать)
   |                         
   |Док                  = Документ.ПриказОбУвольнении.ТекущийДокумент;   
   |Катег               = Документ.ПриказОбУвольнении.Сотрудник.Должность.Категория;   
   |Подр               = Документ.ПриказОбУвольнении.Сотрудник.Подразделение.Раздел;
   |Основание            = Документ.ПриказОбУвольнении.ОснованиеУвольнения;
   |Сотр                                 = Документ.ПриказОбУвольнении.Сотрудник;               
   |ДатаУв               = Документ.ПриказОбУвольнении.ДатаУвольнения;
   |Должн               = Документ.ПриказОбУвольнении.Сотрудник.Должность;
   |Функция СуммС         = Счётчик();
   |                                 
   |Условие( Сотр=Сотр.ОсновнойЭлемент );
   |Условие( глДокументФункционирует(Док)=1 );     
   |Условие(Основание.Код=ЗначМ.Код);
   |
   |Группировка    Док;
   |Группировка    Сотр без групп;
   |
   |"//}}ЗАПРОС
   ;
   
   Т1=ТЗапроса+"Период С ДН по ДК;Условие((ДатаУв<=КДата) и (ДатаУв>=НДата));Условие(Основание.Код<>""06"") ;" ;
        
   Если Зап_.Выполнить(Т1) = 0 Тогда
      Сообщить("Ошибка в запросе");
      Возврат;                   
   КонецЕсли;       

   
   ДокумТемп   = СоздатьОбъект("Документ"); 
   
   Таб3 = СоздатьОбъект("Таблица");
   Таб3.ИсходнаяТаблица("Таблица2"); 
   Таб3.Опции(0,0,0,0);
   Пока Зап_.Группировка(1)=1 Цикл
      Пока Зап_.Группировка(2)=1 Цикл 
         ДокумТемп.НайтиДокумент(Зап_.Док);
         Таб3.ВывестиСекцию("Строка");
      КонецЦикла;
   КонецЦикла; 
   Таб3.ТолькоПросмотр(1);
   Таб3.Показать();
                              
КонецПроцедуры     
Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #1 : 24-01-2011 06:28 » 

Удалить индексные файлы и попробовать полное тестирование - восстановление базы.
Версия платформы - последняя?
Записан
Radistka
Помогающий

ru
Offline Offline
Пол: Женский

« Ответ #2 : 25-01-2011 01:44 » 

Да, версия последняя, но я сомневаюсь что это изза индексов или ещё чего либо-пробовала на базе 3месячной давности и на свежей, ошибка и там и там. если бы были проблемы с базой то за три месяца они бы на активно использующейся базе точно проявились бы
Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #3 : 25-01-2011 08:25 » 

Если есть возможность - сделай выгрузку базы и разверни ее на чистой машине, где не стояла еще 1С. Можно на виртуальной.
Записан
Radistka
Помогающий

ru
Offline Offline
Пол: Женский

« Ответ #4 : 26-01-2011 04:55 » 

всё было проще: забыла написать стандартную обработку флага.
Записан
Страниц: [1]   Вверх
  Печать  
 

Powered by SMF 1.1.21 | SMF © 2015, Simple Machines