Форум программистов «Весельчак У»
  *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

  • Рекомендуем проверить настройки временной зоны в вашем профиле (страница "Внешний вид форума", пункт "Часовой пояс:").
  • У нас больше нет рассылок. Если вам приходят письма от наших бывших рассылок mail.ru и subscribe.ru, то знайте, что это не мы рассылаем.
   Начало  
Наши сайты
Помощь Поиск Календарь Почта Войти Регистрация  
 
Страниц: [1]   Вниз
  Печать  
Автор Тема: Остатки товаров  (Прочитано 2941 раз)
0 Пользователей и 1 Гость смотрят эту тему.
shmyga5
Новенький

ru
Offline Offline

« : 14-04-2011 11:29 » 

Помогите пожалуйста сделать в отчетах "Остатки товаров" чтобы выводились товары с нулевым остатком
Код:
//_____________________________________________________________________________________________________
Процедура ВыбратьКаталогДБФ()
Перем ИмяКаталога; 
ИмяНачКаталога = КаталогИБ();
ИмяФайла = "Import.csv";   

Если ФС.ВыбратьФайл(1, ИмяФайла, ИмяНачКаталога,   "Выберите файл для импорта",,"csv") = 1 Тогда
ввФайл = ИмяНачКаталога + ИмяФайла;
КонецЕсли;
КонецПроцедуры //ВыбратьКаталогДБФ

//_____________________________________________________________________________________________________
Процедура ОбработкаФлВыгрузить()
Если флВыгрузитьВФайл = 0 Тогда
Форма.ввФайл.Доступность(0);
Форма.кнВыбратьКаталогДБФ.Доступность(0);           
Иначе
Форма.ввФайл.Доступность(1);
Форма.кнВыбратьКаталогДБФ.Доступность(1);           
КонецЕсли;
КонецПроцедуры //ОбработкаФлВыгрузить

//_____________________________________________________________________________________________________
Процедура ПриОткрытии()
флВыгрузитьВФайл = 0;
ОбработкаФлВыгрузить(); 
ИмяНачКаталога = КаталогИБ();
ИмяФайла = "Import.csv";                           
ввФайл = ИмяНачКаталога + ИмяФайла;
КонецПроцедуры //ПриОткрытии

//_____________________________________________________________________________________________________
Процедура УстДата()
Если ДатаКонца>=ПолучитьДатуТА() Тогда
Предупреждение("Нельзя устанавливать дату отчета после даты актуальности итогов");
ДатаКонца=ПолучитьДатуТА();
КонецЕсли;
КонецПроцедуры
//--------------------------------------
Процедура Сформировать()
    //Если флВыгрузитьВФайл  = 1 Тогда
    //    Если ФС.СуществуетФайл(ввФайл) = 0 Тогда
    //        Предупреждение("Файл импорта не найден");
    //    КонецЕсли;
    //КонецЕсли;


Заг="";                                                                   
НазваниеИзмерения="ВалютнаяСтоимость";
Если СпВал.ТекущаяСтрока()=1 Тогда
Заг=Заг+"В валюте учета товаров. ";
ИначеЕсли СпВал.ТекущаяСтрока()=2 Тогда
  Вал=Рубли;
Заг=Заг+"В рублях (пересчет). ";
ИначеЕсли СпВал.ТекущаяСтрока()=3 Тогда
Вал=Доллары;
Заг=Заг+"В долларах. ";
Иначе
Вал=Рубли;
Заг=Заг+"В рублях (по базовой стоимости). ";
НазваниеИзмерения="БазоваяСтоимость";
КонецЕсли;
ПроверкаАктуальностиОтчета('01.01.99',ДатаКонца);
//Если глПроверкаАктуальностиОтчета('01.01.80',ДатаКонца,"Детали")=0 Тогда
// Возврат;
//КонецЕсли;                          
Запрос=СоздатьОбъект("Запрос");
Если ДатаКонца>=ПолучитьДатуТА() Тогда
ДатаКонца=ПолучитьДатуТА();
ТекстЗапроса="";
Иначе
ДатаКон=ДатаКонца-1;
ТекстЗапроса="
|ПЕРИОД С ДатаКон По ДатаКонца;";
КонецЕсли;
ТекстЗапроса=ТекстЗапроса+"
|Товар=Регистр.ОстаткиТоваров.Товар;
|ВидТовара=Регистр.ОстаткиТоваров.Товар.ВидТовара;
|Производитель=Регистр.ОстаткиТоваров.Товар.Производитель;
|Страна=Регистр.ОстаткиТоваров.Товар.Производитель.Страна;
|Склад=Регистр.ОстаткиТоваров.Склад;
|МОЛ=Регистр.ОстаткиТоваров.Склад.МОЛ;
|Поставщик=Регистр.ОстаткиТоваров.Клиент;
|Партия=Регистр.ОстаткиТоваров.Документ;
|Стоимость=Регистр.ОстаткиТоваров."+НазваниеИзмерения+";
|Кол=Регистр.ОстаткиТоваров.Количество;";
Если ВыбТовар.Выбран()=0 Тогда
Заг=Заг+"По всем товарам. ";
ИначеЕсли ВыбТовар.ЭтоГруппа()=1 Тогда
ТекстЗапроса=ТекстЗапроса+"Условие (Товар.ПринадлежитГруппе(ВыбТовар)=1);";
Заг=Заг+"По товарам группы "+ВыбТовар.Наименование+". ";
Иначе
ТекстЗапроса=ТекстЗапроса+"Условие (Товар=ВыбТовар);";
Заг=Заг+"По товару "+ВыбТовар.Наименование+". ";
КонецЕсли;
Если ВыбВид.Выбран()=1 Тогда
ТекстЗапроса=ТекстЗапроса+"Условие (ВидТовара=ВыбВид);";
Заг=Заг+"По товарам вида "+СокрП(ВыбВид)+". ";
КонецЕсли;
Если ВыбМОЛ.Выбран()=1 Тогда
ТекстЗапроса=ТекстЗапроса+"Условие (МОЛ=ВыбМОЛ);";
Заг=Заг+"По складам МОЛ "+ВыбМОЛ.Наименование+". ";
ИначеЕсли ВыбСклад.Выбран()=1 Тогда
ТекстЗапроса=ТекстЗапроса+"Условие (Склад=ВыбСклад);";
Заг=Заг+"По складу "+СокрП(ВыбСклад)+". ";
КонецЕсли;
Если ВыбПоставщик.Выбран()=1 Тогда
ТекстЗапроса=ТекстЗапроса+"Условие (Поставщик=ВыбПоставщик);";
Заг=Заг+"По поставщику "+СокрП(ВыбПоставщик)+". ";
КонецЕсли;
Если ВыбМодель.Выбран()=1 Тогда
Если ВыбМодель.ЭтоГруппа()=1 Тогда
  ТекстЗапроса=ТекстЗапроса+"Условие (Модель.ПринадлежитГруппе(ВыбМодель)=1);";
Заг=Заг+"По моделям группы "+СокрП(ВыбМодель)+". ";
Иначе
ТекстЗапроса=ТекстЗапроса+"Условие (Модель=ВыбМодель);";
Заг=Заг+"По модели "+СокрП(ВыбМодель)+". ";
КонецЕсли;
КонецЕсли;
Если ВыбПроизводитель.Выбран()=1 Тогда
Если ВыбПроизводитель.ЭтоГруппа()=1 Тогда
  ТекстЗапроса=ТекстЗапроса+"Условие (Производитель.ПринадлежитГруппе(ВыбПроизводитель)=1);";
Заг=Заг+"По производителям группы "+СокрП(ВыбПроизводитель)+". ";
Иначе
ТекстЗапроса=ТекстЗапроса+"Условие (Производитель=ВыбПроизводитель);";
Заг=Заг+"По производителю "+СокрП(ВыбПроизводитель)+". ";
КонецЕсли;
КонецЕсли;
Если ВыбСтрана.Выбран()=1 Тогда
ТекстЗапроса=ТекстЗапроса+"Условие (Страна=ВыбСтрана);";
Заг=Заг+"По стране-изготовителю "+СокрП(ВыбСтрана)+". ";
КонецЕсли;
Если СпВар.ТекущаяСтрока()=1 Тогда
// Товар
ТекстЗапроса=ТекстЗапроса+"
|Группировка Товар Упорядочить по Товар.Наименование;";
ИначеЕсли СпВар.ТекущаяСтрока()=2 Тогда
// Поставщик=>Товар
ТекстЗапроса=ТекстЗапроса+"
|Группировка Поставщик;
|Группировка Товар Упорядочить по Товар.Наименование;";
ИначеЕсли СпВар.ТекущаяСтрока()=3 Тогда
// Поставщик=>Партия=>Товар
ТекстЗапроса=ТекстЗапроса+"
|Группировка Поставщик;
|Группировка Партия;
|Группировка Товар Упорядочить по Товар.Наименование;";
ИначеЕсли СпВар.ТекущаяСтрока()=4 Тогда
// Склад=>Товар
ТекстЗапроса=ТекстЗапроса+"
|Группировка Склад;
|Группировка Товар Упорядочить по Товар.Наименование;";
ИначеЕсли СпВар.ТекущаяСтрока()=5 Тогда
// Склад=>Поставщик=>Товар
ТекстЗапроса=ТекстЗапроса+"
|Группировка Склад;
|Группировка Поставщик;
|Группировка Товар Упорядочить по Товар.Наименование;";
ИначеЕсли СпВар.ТекущаяСтрока()=6 Тогда
// Склад=>Поставщик=>Партия=>Товар
ТекстЗапроса=ТекстЗапроса+"
|Группировка Склад;
|Группировка Поставщик;
|Группировка Партия;
|Группировка Товар Упорядочить по Товар.Наименование;";
ИначеЕсли СпВар.ТекущаяСтрока()=7 Тогда
// Товар=>Склад
ТекстЗапроса=ТекстЗапроса+"
|Группировка Товар Упорядочить по Товар.Наименование;
|Группировка Склад;";
ИначеЕсли СпВар.ТекущаяСтрока()=8 Тогда
// Товар=>Поставщик
ТекстЗапроса=ТекстЗапроса+"
|Группировка Товар Упорядочить по Товар.Наименование;
|Группировка Поставщик;";
ИначеЕсли СпВар.ТекущаяСтрока()=9 Тогда
// Товар=>Поставщик=>Партия
ТекстЗапроса=ТекстЗапроса+"
|Группировка Товар Упорядочить по Товар.Наименование;
|Группировка Поставщик;
|Группировка Партия;";
КонецЕсли;
ТекстЗапроса=ТекстЗапроса+"
|Функция КонКол=КонОст(Кол);
|Функция КонСтоим=КонОст(Стоимость);
|";
Если Запрос.Выполнить(ТекстЗапроса)=0 Тогда
Предупреждение("Запрос не выполнился!");
Возврат;
КонецЕсли;       

Если флВыгрузитьВФайл = 1 Тогда
тхтФайл = СоздатьОбъект("Текст");
Если тхтФайл.КоличествоСтрок() <> 0 Тогда
тхтФайл.Очистить();
КонецЕсли;

тзРезультат = СоздатьОбъект("ТаблицаЗначений");   
Запрос.Выгрузить(тзРезультат, 0, 0);
тзРезультат.ВыбратьСтроки();
Пока тзРезультат.ПолучитьСтроку() = 1 Цикл
Если тзРезультат.Товар.Вид() <> "Номенклатура" Тогда
Продолжить;
КонецЕсли;

Если тзРезультат.Товар.ЭтоГруппа() = 1 Тогда
Продолжить;
КонецЕсли;       

Если тзРезультат.КонКол <> 0 Тогда
тхтФайл.ДобавитьСтроку(тзРезультат.Товар.Наименование + ";" + СокрЛП(Формат(тзРезультат.Товар.РозничнаяЦена, "Ч15.2,")) + ";1;" + тзРезультат.Товар.Код);
//             тхтФайл.ДобавитьСтроку(тзРезультат.Товар.Наименование + ";" + СокрЛП(Формат(тзРезультат.Товар.РозничнаяЦена, "Ч15.2")) + ";1;" + тзРезультат.Товар.Код + ";0;True;" + тзРезультат.КонКол);

КонецЕсли;
КонецЦикла;
тхтФайл.Записать(ввФайл);
КонецЕсли;


Заг=Заг+"Отчет получен "+ТекущаяДата()+" в "+ТекущееВремя();
Таб=СоздатьОбъект("Таблица");
Таб.ИсходнаяТаблица("Таблица");
Таб.ПовторятьПриПечатиСтроки(4,4);
Таб.ВывестиСекцию("Шапка");
Выведено=0;
СпСто=СоздатьОбъект("СписокЗначений");
СпСтоСкл=СоздатьОбъект("СписокЗначений");
СпСтоПост=СоздатьОбъект("СписокЗначений");
СпСтоПарт=СоздатьОбъект("СписокЗначений");
Если СпВар.ТекущаяСтрока()=1 Тогда
// Товар
Пока Запрос.Группировка("Товар")=1 Цикл
Если Запрос.Товар.Выбран()=0 Тогда
Продолжить;
КонецЕсли;
Если ФлажокПечататьТовар=1 Тогда
  Выведено=Выведено+1;
КонецЕсли;
Если Прав(Строка(Выведено),2)="00" Тогда
Состояние("Выведено строк "+Строка(Выведено));
КонецЕсли;
Наим=СокрП(Запрос.Товар.Наименование);
Если Запрос.Товар.ЭтоГруппа()=1 Тогда
ПечКол=Строка(Запрос.КонКол);
Наим= Запрос.Товар;
Если Наим.Уровень()=1 Тогда
    Таб.ВывестиСекцию("Группа1");
Иначе
Таб.ВывестиСекцию("Группа");
КонецЕсли;
Продолжить;
КонецЕсли;
Тов=Запрос.Товар;
Если СпВал.ТекущаяСтрока()=1 Тогда
  Вал=Тов.ВалютаУчета;
        КонецЕсли;
        Если СпВал.ТекущаяСтрока()=0 Тогда
Вал=Тов.ВалютаУчета;
КонецЕсли;
ПродажнаяЦена=Окр(Пересчет(Тов.РозничнаяЦена,Тов.ВалютаПродажи,Вал,ДатаКонца),3,1);
ОстатокКоличество=Запрос.КонКол;
КонКол=ОстатокКоличество;
ПечКол=Строка(КонКол);
ПродажнаяСтоимость=ПродажнаяЦена*ОстатокКоличество;
Если НазваниеИзмерения="ВалютнаяСтоимость" Тогда
  ОстатокСтоимость=Пересчет(Запрос.КонСтоим,Тов.ВалютаУчета,Вал,ДатаКонца);
Иначе
  ОстатокСтоимость=Запрос.КонСтоим;
КонецЕсли;
Поз=СпСто.НайтиЗначение(Вал);
Если Поз=0 Тогда
  СпСто.ДобавитьЗначение(Вал,Строка(ОстатокСтоимость)+"/"+Строка(ПродажнаяСтоимость));
Иначе
  Вал=СпСто.ПолучитьЗначение(Поз,глСтр);
П=Найти(глСтр,"/");
СпСто.УстановитьЗначение(Поз,Вал,Строка(Число(Лев(глСтр,П-1))+ОстатокСтоимость)
+"/"+Строка(Число(Прав(глСтр,СтрДлина(глСтр)-П))+ПродажнаяСтоимость));
КонецЕсли;
Если ФлажокПечататьТовар=1 Тогда
  Таб.ВывестиСекцию("Товар");
КонецЕсли;
КонецЦикла;
ИначеЕсли СпВар.ТекущаяСтрока()=2 Тогда
// Поставщик=>Товар
Пока Запрос.Группировка("Поставщик")=1 Цикл
СпСтоПост.УдалитьВсе();
Пока Запрос.Группировка("Товар")=1 Цикл
Если Запрос.Товар.Выбран()=0 Тогда
Продолжить;
КонецЕсли;
Если ФлажокПечататьТовар=1 Тогда
  Выведено=Выведено+1;
КонецЕсли;
Если Прав(Строка(Выведено),2)="00" Тогда
Состояние("Выведено строк "+Строка(Выведено));
КонецЕсли;
Наим=СокрП(Запрос.Товар.Наименование)+" / "+Запрос.Товар.Код;
Если Запрос.Товар.ЭтоГруппа()=1 Тогда
ПечКол=Строка(Запрос.КонКол);
Наим= Запрос.Товар;
Если Наим.Уровень()=1 Тогда
Таб.ВывестиСекцию("Группа1");
Иначе
Таб.ВывестиСекцию("Группа");
КонецЕсли;
Продолжить;
КонецЕсли;
Тов=Запрос.Товар;
Если СпВал.ТекущаяСтрока()=1 Тогда
Вал=Тов.ВалютаУчета;
КонецЕсли;
ПродажнаяЦена=Окр(Пересчет(Тов.РозничнаяЦена,Тов.ВалютаПродажи,Вал,ДатаКонца),3,1);
ОстатокКоличество=Запрос.КонКол;
КонКол=ОстатокКоличество;
ПечКол=Строка(КонКол);
ПродажнаяСтоимость=ПродажнаяЦена*ОстатокКоличество;
Если НазваниеИзмерения="ВалютнаяСтоимость" Тогда
ОстатокСтоимость=Пересчет(Запрос.КонСтоим,Тов.ВалютаУчета,Вал,ДатаКонца);
Иначе
ОстатокСтоимость=Запрос.КонСтоим;
КонецЕсли;
Поз=СпСто.НайтиЗначение(Вал);
Если Поз=0 Тогда
СпСто.ДобавитьЗначение(Вал,Строка(ОстатокСтоимость)+"/"+Строка(ПродажнаяСтоимость));
Иначе
Вал=СпСто.ПолучитьЗначение(Поз,глСтр);
П=Найти(глСтр,"/");
СпСто.УстановитьЗначение(Поз,Вал,Строка(Число(Лев(глСтр,П-1))+ОстатокСтоимость)
+"/"+Строка(Число(Прав(глСтр,СтрДлина(глСтр)-П))+ПродажнаяСтоимость));
КонецЕсли;
Поз=СпСтоПост.НайтиЗначение(Вал);
Если Поз=0 Тогда
СпСтоПост.ДобавитьЗначение(Вал,Строка(ОстатокСтоимость)+"/"+Строка(ПродажнаяСтоимость));
Иначе
Вал=СпСтоПост.ПолучитьЗначение(Поз,глСтр);
П=Найти(глСтр,"/");
СпСтоПост.УстановитьЗначение(Поз,Вал,Строка(Число(Лев(глСтр,П-1))+ОстатокСтоимость)
+"/"+Строка(Число(Прав(глСтр,СтрДлина(глСтр)-П))+ПродажнаяСтоимость));
КонецЕсли;
Если ФлажокПечататьТовар=1 Тогда
  Таб.ВывестиСекцию("Товар");
КонецЕсли;
КонецЦикла;
Для Н=1 По СпСтоПост.РазмерСписка() Цикл
Вал=СпСтоПост.ПолучитьЗначение(Н,глСтр);
П=Найти(глСтр,"/");
ОстатокСтоимость=Число(Лев(глСтр,П-1));
ПродажнаяСтоимость=Число(Прав(глСтр,СтрДлина(глСтр)-П));
Таб.ВывестиСекцию("ИтогоПост");
КонецЦикла;
КонецЦикла;
ИначеЕсли СпВар.ТекущаяСтрока()=3 Тогда
// Поставщик=>Партия=>Товар
Пока Запрос.Группировка("Поставщик")=1 Цикл
СпСтоПост.УдалитьВсе();
Пока Запрос.Группировка("Партия")=1 Цикл
СпСтоПарт.УдалитьВсе();
Пока Запрос.Группировка("Товар")=1 Цикл
Если Запрос.Товар.Выбран()=0 Тогда
Продолжить;
КонецЕсли;
Если ФлажокПечататьТовар=1 Тогда
  Выведено=Выведено+1;
КонецЕсли;
Если Прав(Строка(Выведено),2)="00" Тогда
Состояние("Выведено строк "+Строка(Выведено));
КонецЕсли;
Наим=СокрП(Запрос.Товар.Наименование)+" / "+Запрос.Товар.Код;
Если Запрос.Товар.ЭтоГруппа()=1 Тогда
ПечКол=Строка(Запрос.КонКол);
Наим= Запрос.Товар;
Если Наим.Уровень()=1 Тогда
Таб.ВывестиСекцию("Группа1");
Иначе
Таб.ВывестиСекцию("Группа");
КонецЕсли;
Продолжить;
КонецЕсли;
Тов=Запрос.Товар;
Если СпВал.ТекущаяСтрока()=1 Тогда
Вал=Тов.ВалютаУчета;
КонецЕсли;
ПродажнаяЦена=Окр(Пересчет(Тов.РозничнаяЦена,Тов.ВалютаПродажи,Вал,ДатаКонца),3,1);
ОстатокКоличество=Запрос.КонКол;
КонКол=ОстатокКоличество;
ПечКол=Строка(КонКол);
ПродажнаяСтоимость=ПродажнаяЦена*ОстатокКоличество;
Если НазваниеИзмерения="ВалютнаяСтоимость" Тогда
ОстатокСтоимость=Пересчет(Запрос.КонСтоим,Тов.ВалютаУчета,Вал,ДатаКонца);
Иначе
ОстатокСтоимость=Запрос.КонСтоим;
КонецЕсли;
Поз=СпСто.НайтиЗначение(Вал);
Если Поз=0 Тогда
СпСто.ДобавитьЗначение(Вал,Строка(ОстатокСтоимость)+"/"+Строка(ПродажнаяСтоимость));
Иначе
Вал=СпСто.ПолучитьЗначение(Поз,глСтр);
П=Найти(глСтр,"/");
СпСто.УстановитьЗначение(Поз,Вал,Строка(Число(Лев(глСтр,П-1))+ОстатокСтоимость)
+"/"+Строка(Число(Прав(глСтр,СтрДлина(глСтр)-П))+ПродажнаяСтоимость));
КонецЕсли;
Поз=СпСтоПост.НайтиЗначение(Вал);
Если Поз=0 Тогда
СпСтоПост.ДобавитьЗначение(Вал,Строка(ОстатокСтоимость)+"/"+Строка(ПродажнаяСтоимость));
Иначе
Вал=СпСтоПост.ПолучитьЗначение(Поз,глСтр);
П=Найти(глСтр,"/");
СпСтоПост.УстановитьЗначение(Поз,Вал,Строка(Число(Лев(глСтр,П-1))+ОстатокСтоимость)
+"/"+Строка(Число(Прав(глСтр,СтрДлина(глСтр)-П))+ПродажнаяСтоимость));
КонецЕсли;
Поз=СпСтоПарт.НайтиЗначение(Вал);
Если Поз=0 Тогда
СпСтоПарт.ДобавитьЗначение(Вал,Строка(ОстатокСтоимость)+"/"+Строка(ПродажнаяСтоимость));
Иначе
Вал=СпСтоПарт.ПолучитьЗначение(Поз,глСтр);
П=Найти(глСтр,"/");
СпСтоПарт.УстановитьЗначение(Поз,Вал,Строка(Число(Лев(глСтр,П-1))+ОстатокСтоимость)
+"/"+Строка(Число(Прав(глСтр,СтрДлина(глСтр)-П))+ПродажнаяСтоимость));
КонецЕсли;
Если ФлажокПечататьТовар=1 Тогда
  Таб.ВывестиСекцию("Товар");
КонецЕсли;
КонецЦикла;
Для Н=1 По СпСтоПарт.РазмерСписка() Цикл
Вал=СпСтоПарт.ПолучитьЗначение(Н,глСтр);
П=Найти(глСтр,"/");
ОстатокСтоимость=Число(Лев(глСтр,П-1));
ПродажнаяСтоимость=Число(Прав(глСтр,СтрДлина(глСтр)-П));
Таб.ВывестиСекцию("ИтогоПарт");
КонецЦикла;
КонецЦикла;
Для Н=1 По СпСтоПост.РазмерСписка() Цикл
Вал=СпСтоПост.ПолучитьЗначение(Н,глСтр);
П=Найти(глСтр,"/");
ОстатокСтоимость=Число(Лев(глСтр,П-1));
ПродажнаяСтоимость=Число(Прав(глСтр,СтрДлина(глСтр)-П));
Таб.ВывестиСекцию("ИтогоПост");
КонецЦикла;
КонецЦикла;
ИначеЕсли СпВар.ТекущаяСтрока()=4 Тогда
// Склад=>Товар
Пока Запрос.Группировка("Склад")=1 Цикл
СпСтоСкл.УдалитьВсе();
Пока Запрос.Группировка("Товар")=1 Цикл
Если Запрос.Товар.Выбран()=0 Тогда
Продолжить;
КонецЕсли;
Если ФлажокПечататьТовар=1 Тогда
  Выведено=Выведено+1;
КонецЕсли;
Если Прав(Строка(Выведено),2)="00" Тогда
Состояние("Выведено строк "+Строка(Выведено));
КонецЕсли;
Наим=СокрП(Запрос.Товар.Наименование)+" / "+Запрос.Товар.Код;
Тов=Запрос.Товар;
Если СпВал.ТекущаяСтрока()=1 Тогда
Вал=Тов.ВалютаУчета;
КонецЕсли;
Если СпВал.ТекущаяСтрока()=0 Тогда
Вал=Тов.ВалютаУчета;
КонецЕсли;
ПродажнаяЦена=Окр(Пересчет(Тов.РозничнаяЦена,Тов.ВалютаПродажи,Вал,ДатаКонца),3,1);
ОстатокКоличество=Запрос.КонКол;
КонКол=ОстатокКоличество;
ПечКол=Строка(КонКол);
ПродажнаяСтоимость=ПродажнаяЦена*ОстатокКоличество;
Если НазваниеИзмерения="ВалютнаяСтоимость" Тогда
ОстатокСтоимость=Пересчет(Запрос.КонСтоим,Тов.ВалютаУчета,Вал,ДатаКонца);
Иначе
ОстатокСтоимость=Запрос.КонСтоим;
КонецЕсли;
Поз=СпСто.НайтиЗначение(Вал);
Если Поз=0 Тогда
СпСто.ДобавитьЗначение(Вал,Строка(ОстатокСтоимость)+"/"+Строка(ПродажнаяСтоимость));
Иначе
Вал=СпСто.ПолучитьЗначение(Поз,глСтр);
П=Найти(глСтр,"/");
СпСто.УстановитьЗначение(Поз,Вал,Строка(Число(Лев(глСтр,П-1))+ОстатокСтоимость)
+"/"+Строка(Число(Прав(глСтр,СтрДлина(глСтр)-П))+ПродажнаяСтоимость));
КонецЕсли;
Поз=СпСтоСкл.НайтиЗначение(Вал);
Если Поз=0 Тогда
СпСтоСкл.ДобавитьЗначение(Вал,Строка(ОстатокСтоимость)+"/"+Строка(ПродажнаяСтоимость));
Иначе
Вал=СпСтоСкл.ПолучитьЗначение(Поз,глСтр);
П=Найти(глСтр,"/");
СпСтоСкл.УстановитьЗначение(Поз,Вал,Строка(Число(Лев(глСтр,П-1))+ОстатокСтоимость)
+"/"+Строка(Число(Прав(глСтр,СтрДлина(глСтр)-П))+ПродажнаяСтоимость));
КонецЕсли;
Если ФлажокПечататьТовар=1 Тогда
  Таб.ВывестиСекцию("Товар");
КонецЕсли;
КонецЦикла;
Для Н=1 По СпСтоСкл.РазмерСписка() Цикл
Вал=СпСтоСкл.ПолучитьЗначение(Н,глСтр);
П=Найти(глСтр,"/");
ОстатокСтоимость=Число(Лев(глСтр,П-1));
ПродажнаяСтоимость=Число(Прав(глСтр,СтрДлина(глСтр)-П));
Таб.ВывестиСекцию("ИтогоСкл");
КонецЦикла;
КонецЦикла;
ИначеЕсли СпВар.ТекущаяСтрока()=5 Тогда
// Склад=>Поставщик=>Товар
Пока Запрос.Группировка("Склад")=1 Цикл
СпСтоСкл.УдалитьВсе();
Пока Запрос.Группировка("Поставщик")=1 Цикл
СпСтоПост.УдалитьВсе();
Пока Запрос.Группировка("Товар")=1 Цикл
Если Запрос.Товар.Выбран()=0 Тогда
Продолжить;
КонецЕсли;
Если ФлажокПечататьТовар=1 Тогда
  Выведено=Выведено+1;
КонецЕсли;
Если Прав(Строка(Выведено),2)="00" Тогда
Состояние("Выведено строк "+Строка(Выведено));
КонецЕсли;
Наим=СокрП(Запрос.Товар.Наименование)+" / "+Запрос.Товар.Код;
Тов=Запрос.Товар;
Если СпВал.ТекущаяСтрока()=1 Тогда
Вал=Тов.ВалютаУчета;
КонецЕсли;
ПродажнаяЦена=Окр(Пересчет(Тов.РозничнаяЦена,Тов.ВалютаПродажи,Вал,ДатаКонца),3,1);
ОстатокКоличество=Запрос.КонКол;
КонКол=ОстатокКоличество;
ПечКол=Строка(КонКол);
ПродажнаяСтоимость=ПродажнаяЦена*ОстатокКоличество;
Если НазваниеИзмерения="ВалютнаяСтоимость" Тогда
ОстатокСтоимость=Пересчет(Запрос.КонСтоим,Тов.ВалютаУчета,Вал,ДатаКонца);
Иначе
ОстатокСтоимость=Запрос.КонСтоим;
КонецЕсли;
Поз=СпСто.НайтиЗначение(Вал);
Если Поз=0 Тогда
СпСто.ДобавитьЗначение(Вал,Строка(ОстатокСтоимость)+"/"+Строка(ПродажнаяСтоимость));
Иначе
Вал=СпСто.ПолучитьЗначение(Поз,глСтр);
П=Найти(глСтр,"/");
СпСто.УстановитьЗначение(Поз,Вал,Строка(Число(Лев(глСтр,П-1))+ОстатокСтоимость)
+"/"+Строка(Число(Прав(глСтр,СтрДлина(глСтр)-П))+ПродажнаяСтоимость));
КонецЕсли;
Поз=СпСтоСкл.НайтиЗначение(Вал);
Если Поз=0 Тогда
СпСтоСкл.ДобавитьЗначение(Вал,Строка(ОстатокСтоимость)+"/"+Строка(ПродажнаяСтоимость));
Иначе
Вал=СпСтоСкл.ПолучитьЗначение(Поз,глСтр);
П=Найти(глСтр,"/");
СпСтоСкл.УстановитьЗначение(Поз,Вал,Строка(Число(Лев(глСтр,П-1))+ОстатокСтоимость)
+"/"+Строка(Число(Прав(глСтр,СтрДлина(глСтр)-П))+ПродажнаяСтоимость));
КонецЕсли;
Поз=СпСтоПост.НайтиЗначение(Вал);
Если Поз=0 Тогда
СпСтоПост.ДобавитьЗначение(Вал,Строка(ОстатокСтоимость)+"/"+Строка(ПродажнаяСтоимость));
Иначе
Вал=СпСтоПост.ПолучитьЗначение(Поз,глСтр);
П=Найти(глСтр,"/");
СпСтоПост.УстановитьЗначение(Поз,Вал,Строка(Число(Лев(глСтр,П-1))+ОстатокСтоимость)
+"/"+Строка(Число(Прав(глСтр,СтрДлина(глСтр)-П))+ПродажнаяСтоимость));
КонецЕсли;
Если ФлажокПечататьТовар=1 Тогда
  Таб.ВывестиСекцию("Товар");
КонецЕсли;
КонецЦикла;
Для Н=1 По СпСтоПост.РазмерСписка() Цикл
Вал=СпСтоПост.ПолучитьЗначение(Н,глСтр);
П=Найти(глСтр,"/");
ОстатокСтоимость=Число(Лев(глСтр,П-1));
ПродажнаяСтоимость=Число(Прав(глСтр,СтрДлина(глСтр)-П));
Таб.ВывестиСекцию("ИтогоПост");
КонецЦикла;
КонецЦикла;
Для Н=1 По СпСтоСкл.РазмерСписка() Цикл
Вал=СпСтоСкл.ПолучитьЗначение(Н,глСтр);
П=Найти(глСтр,"/");
ОстатокСтоимость=Число(Лев(глСтр,П-1));
ПродажнаяСтоимость=Число(Прав(глСтр,СтрДлина(глСтр)-П));
Таб.ВывестиСекцию("ИтогоСкл");
КонецЦикла;
КонецЦикла;
ИначеЕсли СпВар.ТекущаяСтрока()=6 Тогда
// Склад=>Поставщик=>Партия=>Товар
Пока Запрос.Группировка("Склад")=1 Цикл
СпСтоСкл.УдалитьВсе();
Пока Запрос.Группировка("Поставщик")=1 Цикл
СпСтоПост.УдалитьВсе();
Пока Запрос.Группировка("Партия")=1 Цикл
СпСтоПарт.УдалитьВсе();
Пока Запрос.Группировка("Товар")=1 Цикл
Если Запрос.Товар.Выбран()=0 Тогда
Продолжить;
КонецЕсли;
Если ФлажокПечататьТовар=1 Тогда
  Выведено=Выведено+1;
КонецЕсли;
Если Прав(Строка(Выведено),2)="00" Тогда
Состояние("Выведено строк "+Строка(Выведено));
КонецЕсли;
Наим=СокрП(Запрос.Товар.Наименование)+" / "+Запрос.Товар.Код;
Тов=Запрос.Товар;
Если СпВал.ТекущаяСтрока()=1 Тогда
Вал=Тов.ВалютаУчета;
КонецЕсли;
ПродажнаяЦена=Окр(Пересчет(Тов.РозничнаяЦена,Тов.ВалютаПродажи,Вал,ДатаКонца),3,1);
ОстатокКоличество=Запрос.КонКол;
КонКол=ОстатокКоличество;
ПечКол=Строка(КонКол);
ПродажнаяСтоимость=ПродажнаяЦена*ОстатокКоличество;
Если НазваниеИзмерения="ВалютнаяСтоимость" Тогда
ОстатокСтоимость=Пересчет(Запрос.КонСтоим,Тов.ВалютаУчета,Вал,ДатаКонца);
Иначе
ОстатокСтоимость=Запрос.КонСтоим;
КонецЕсли;
Поз=СпСто.НайтиЗначение(Вал);
Если Поз=0 Тогда
СпСто.ДобавитьЗначение(Вал,Строка(ОстатокСтоимость)+"/"+Строка(ПродажнаяСтоимость));
Иначе
Вал=СпСто.ПолучитьЗначение(Поз,глСтр);
П=Найти(глСтр,"/");
СпСто.УстановитьЗначение(Поз,Вал,Строка(Число(Лев(глСтр,П-1))+ОстатокСтоимость)
+"/"+Строка(Число(Прав(глСтр,СтрДлина(глСтр)-П))+ПродажнаяСтоимость));
КонецЕсли;
Поз=СпСтоСкл.НайтиЗначение(Вал);
Если Поз=0 Тогда
СпСтоСкл.ДобавитьЗначение(Вал,Строка(ОстатокСтоимость)+"/"+Строка(ПродажнаяСтоимость));
Иначе
Вал=СпСтоСкл.ПолучитьЗначение(Поз,глСтр);
П=Найти(глСтр,"/");
СпСтоСкл.УстановитьЗначение(Поз,Вал,Строка(Число(Лев(глСтр,П-1))+ОстатокСтоимость)
+"/"+Строка(Число(Прав(глСтр,СтрДлина(глСтр)-П))+ПродажнаяСтоимость));
КонецЕсли;
Поз=СпСтоПост.НайтиЗначение(Вал);
Если Поз=0 Тогда
СпСтоПост.ДобавитьЗначение(Вал,Строка(ОстатокСтоимость)+"/"+Строка(ПродажнаяСтоимость));
Иначе
Вал=СпСтоПост.ПолучитьЗначение(Поз,глСтр);
П=Найти(глСтр,"/");
СпСтоПост.УстановитьЗначение(Поз,Вал,Строка(Число(Лев(глСтр,П-1))+ОстатокСтоимость)
+"/"+Строка(Число(Прав(глСтр,СтрДлина(глСтр)-П))+ПродажнаяСтоимость));
КонецЕсли;
Поз=СпСтоПарт.НайтиЗначение(Вал);
Если Поз=0 Тогда
СпСтоПарт.ДобавитьЗначение(Вал,Строка(ОстатокСтоимость)+"/"+Строка(ПродажнаяСтоимость));
Иначе
Вал=СпСтоПарт.ПолучитьЗначение(Поз,глСтр);
П=Найти(глСтр,"/");
СпСтоПарт.УстановитьЗначение(Поз,Вал,Строка(Число(Лев(глСтр,П-1))+ОстатокСтоимость)
+"/"+Строка(Число(Прав(глСтр,СтрДлина(глСтр)-П))+ПродажнаяСтоимость));
КонецЕсли;
Если ФлажокПечататьТовар=1 Тогда
  Таб.ВывестиСекцию("Товар");
КонецЕсли;
КонецЦикла;
Для Н=1 По СпСтоПарт.РазмерСписка() Цикл
Вал=СпСтоПарт.ПолучитьЗначение(Н,глСтр);
П=Найти(глСтр,"/");
ОстатокСтоимость=Число(Лев(глСтр,П-1));
ПродажнаяСтоимость=Число(Прав(глСтр,СтрДлина(глСтр)-П));
Таб.ВывестиСекцию("ИтогоПарт");
КонецЦикла;
КонецЦикла;
Для Н=1 По СпСтоПост.РазмерСписка() Цикл
Вал=СпСтоПост.ПолучитьЗначение(Н,глСтр);
П=Найти(глСтр,"/");
ОстатокСтоимость=Число(Лев(глСтр,П-1));
ПродажнаяСтоимость=Число(Прав(глСтр,СтрДлина(глСтр)-П));
Таб.ВывестиСекцию("ИтогоПост");
КонецЦикла;
КонецЦикла;
Для Н=1 По СпСтоСкл.РазмерСписка() Цикл
Вал=СпСтоСкл.ПолучитьЗначение(Н,глСтр);
П=Найти(глСтр,"/");
ОстатокСтоимость=Число(Лев(глСтр,П-1));
ПродажнаяСтоимость=Число(Прав(глСтр,СтрДлина(глСтр)-П));
Таб.ВывестиСекцию("ИтогоСкл");
КонецЦикла;
КонецЦикла;
ИначеЕсли СпВар.ТекущаяСтрока()=7 Тогда
// Товар=>Склад
Пока Запрос.Группировка("Товар")=1 Цикл
Если Запрос.Товар.Выбран()=0 Тогда
Продолжить;
КонецЕсли;
Выведено=Выведено+1;
Если Прав(Строка(Выведено),2)="00" Тогда
Состояние("Выведено строк "+Строка(Выведено));
КонецЕсли;
Наим=СокрП(Запрос.Товар.Наименование)+" / "+Запрос.Товар.Код;
Тов=Запрос.Товар;
Если СпВал.ТекущаяСтрока()=1 Тогда
Вал=Тов.ВалютаУчета;
КонецЕсли;
ПродажнаяЦена=Окр(Пересчет(Тов.РозничнаяЦена,Тов.ВалютаПродажи,Вал,ДатаКонца),3,1);
ОстатокКоличество=Запрос.КонКол;
КонКол=ОстатокКоличество;
ПечКол=Строка(КонКол);
ПродажнаяСтоимость=ПродажнаяЦена*ОстатокКоличество;
Если НазваниеИзмерения="ВалютнаяСтоимость" Тогда
  ОстатокСтоимость=Пересчет(Запрос.КонСтоим,Тов.ВалютаУчета,Вал,ДатаКонца);
Иначе
  ОстатокСтоимость=Запрос.КонСтоим;
КонецЕсли;
Поз=СпСто.НайтиЗначение(Вал);
Если Поз=0 Тогда
СпСто.ДобавитьЗначение(Вал,Строка(ОстатокСтоимость)+"/"+Строка(ПродажнаяСтоимость));
Иначе
Вал=СпСто.ПолучитьЗначение(Поз,глСтр);
П=Найти(глСтр,"/");
СпСто.УстановитьЗначение(Поз,Вал,Строка(Число(Лев(глСтр,П-1))+ОстатокСтоимость)
+"/"+Строка(Число(Прав(глСтр,СтрДлина(глСтр)-П))+ПродажнаяСтоимость));
КонецЕсли;
Таб.ВывестиСекцию("Товар");
Пока Запрос.Группировка("Склад")=1 Цикл
Выведено=Выведено+1;
Если Прав(Строка(Выведено),2)="00" Тогда
Состояние("Выведено строк "+Строка(Выведено));
КонецЕсли;
ОстатокКоличество=Запрос.КонКол;
КонКол=ОстатокКоличество;
ПечКол=Строка(КонКол);
ПродажнаяСтоимость=ПродажнаяЦена*ОстатокКоличество;
Если НазваниеИзмерения="ВалютнаяСтоимость" Тогда
ОстатокСтоимость=Пересчет(Запрос.КонСтоим,Тов.ВалютаУчета,Вал,ДатаКонца);
Иначе
ОстатокСтоимость=Запрос.КонСтоим;
КонецЕсли;
Таб.ВывестиСекцию("Склад");
КонецЦикла;
КонецЦикла;
ИначеЕсли СпВар.ТекущаяСтрока()=8 Тогда
// Товар=>Поставщик
Пока Запрос.Группировка("Товар")=1 Цикл
Если Запрос.Товар.Выбран()=0 Тогда
Продолжить;
КонецЕсли;
Выведено=Выведено+1;
Если Прав(Строка(Выведено),2)="00" Тогда
Состояние("Выведено строк "+Строка(Выведено));
КонецЕсли;
Наим=СокрП(Запрос.Товар.Наименование)+" / "+Запрос.Товар.Код;
Тов=Запрос.Товар;
Если СпВал.ТекущаяСтрока()=1 Тогда
Вал=Тов.ВалютаУчета;
КонецЕсли;
ПродажнаяЦена=Окр(Пересчет(Тов.РозничнаяЦена,Тов.ВалютаПродажи,Вал,ДатаКонца),3,1);
ОстатокКоличество=Запрос.КонКол;
КонКол=ОстатокКоличество;
ПечКол=Строка(КонКол);
ПродажнаяСтоимость=ПродажнаяЦена*ОстатокКоличество;
Если НазваниеИзмерения="ВалютнаяСтоимость" Тогда
  ОстатокСтоимость=Пересчет(Запрос.КонСтоим,Тов.ВалютаУчета,Вал,ДатаКонца);
Иначе
  ОстатокСтоимость=Запрос.КонСтоим;
КонецЕсли;
Поз=СпСто.НайтиЗначение(Вал);
Если Поз=0 Тогда
СпСто.ДобавитьЗначение(Вал,Строка(ОстатокСтоимость)+"/"+Строка(ПродажнаяСтоимость));
Иначе
Вал=СпСто.ПолучитьЗначение(Поз,глСтр);
П=Найти(глСтр,"/");
СпСто.УстановитьЗначение(Поз,Вал,Строка(Число(Лев(глСтр,П-1))+ОстатокСтоимость)
+"/"+Строка(Число(Прав(глСтр,СтрДлина(глСтр)-П))+ПродажнаяСтоимость));
КонецЕсли;
Таб.ВывестиСекцию("Товар");
Пока Запрос.Группировка("Поставщик")=1 Цикл
Выведено=Выведено+1;
Если Прав(Строка(Выведено),2)="00" Тогда
Состояние("Выведено строк "+Строка(Выведено));
КонецЕсли;
ОстатокКоличество=Запрос.КонКол;
КонКол=ОстатокКоличество;
ПечКол=Строка(КонКол);
ПродажнаяСтоимость=ПродажнаяЦена*ОстатокКоличество;
Если НазваниеИзмерения="ВалютнаяСтоимость" Тогда
ОстатокСтоимость=Пересчет(Запрос.КонСтоим,Тов.ВалютаУчета,Вал,ДатаКонца);
Иначе
ОстатокСтоимость=Запрос.КонСтоим;
КонецЕсли;
Таб.ВывестиСекцию("Поставщик");
КонецЦикла;
КонецЦикла;
ИначеЕсли СпВар.ТекущаяСтрока()=9 Тогда
// Товар=>Поставщик=>Партия
Пока Запрос.Группировка("Товар")=1 Цикл
Если Запрос.Товар.Выбран()=0 Тогда
Продолжить;
КонецЕсли;
Выведено=Выведено+1;
Если Прав(Строка(Выведено),2)="00" Тогда
Состояние("Выведено строк "+Строка(Выведено));
КонецЕсли;
Наим=СокрП(Запрос.Товар.Наименование)+" / "+Запрос.Товар.Код;
Тов=Запрос.Товар;
Если СпВал.ТекущаяСтрока()=1 Тогда
Вал=Тов.ВалютаУчета;
КонецЕсли;
ПродажнаяЦена=Окр(Пересчет(Тов.РозничнаяЦена,Тов.ВалютаПродажи,Вал,ДатаКонца),3,1);
ОстатокКоличество=Запрос.КонКол;
КонКол=ОстатокКоличество;
ПечКол=Строка(КонКол);
ПродажнаяСтоимость=ПродажнаяЦена*ОстатокКоличество;
Если НазваниеИзмерения="ВалютнаяСтоимость" Тогда
  ОстатокСтоимость=Пересчет(Запрос.КонСтоим,Тов.ВалютаУчета,Вал,ДатаКонца);
Иначе
  ОстатокСтоимость=Запрос.КонСтоим;
КонецЕсли;
Поз=СпСто.НайтиЗначение(Вал);
Если Поз=0 Тогда
СпСто.ДобавитьЗначение(Вал,Строка(ОстатокСтоимость)+"/"+Строка(ПродажнаяСтоимость));
Иначе
Вал=СпСто.ПолучитьЗначение(Поз,глСтр);
П=Найти(глСтр,"/");
СпСто.УстановитьЗначение(Поз,Вал,Строка(Число(Лев(глСтр,П-1))+ОстатокСтоимость)
+"/"+Строка(Число(Прав(глСтр,СтрДлина(глСтр)-П))+ПродажнаяСтоимость));
КонецЕсли;
Таб.ВывестиСекцию("Товар");
Пока Запрос.Группировка("Поставщик")=1 Цикл
Выведено=Выведено+1;
Если Прав(Строка(Выведено),2)="00" Тогда
Состояние("Выведено строк "+Строка(Выведено));
КонецЕсли;
ОстатокКоличество=Запрос.КонКол;
КонКол=ОстатокКоличество;
ПечКол=Строка(КонКол);
ПродажнаяСтоимость=ПродажнаяЦена*ОстатокКоличество;
Если НазваниеИзмерения="ВалютнаяСтоимость" Тогда
ОстатокСтоимость=Пересчет(Запрос.КонСтоим,Тов.ВалютаУчета,Вал,ДатаКонца);
Иначе
ОстатокСтоимость=Запрос.КонСтоим;
КонецЕсли;
Таб.ВывестиСекцию("Поставщик");
Пока Запрос.Группировка("Партия")=1 Цикл
Выведено=Выведено+1;
Если Прав(Строка(Выведено),2)="00" Тогда
Состояние("Выведено строк "+Строка(Выведено));
КонецЕсли;
ОстатокКоличество=Запрос.КонКол;
КонКол=ОстатокКоличество;
ПечКол=Строка(КонКол);
ПродажнаяСтоимость=ПродажнаяЦена*ОстатокКоличество;
Если НазваниеИзмерения="ВалютнаяСтоимость" Тогда
ОстатокСтоимость=Пересчет(Запрос.КонСтоим,Тов.ВалютаУчета,Вал,ДатаКонца);
Иначе
ОстатокСтоимость=Запрос.КонСтоим;
КонецЕсли;
Таб.ВывестиСекцию("Партия");
КонецЦикла;
КонецЦикла;
КонецЦикла;
КонецЕсли;
Для Н=1 По СпСто.РазмерСписка() Цикл
Вал=СпСто.ПолучитьЗначение(Н,глСтр);
П=Найти(глСтр,"/");
ОстатокСтоимость=Число(Лев(глСтр,П-1));
ПродажнаяСтоимость=Число(Прав(глСтр,СтрДлина(глСтр)-П));
Если Н=1 Тогда
  Таб.ВывестиСекцию("Итоги1");
Иначе
  Таб.ВывестиСекцию("Итоги");
КонецЕсли;
КонецЦикла;
Таб.ВывестиСекцию("Черта");
Таб.ТолькоПросмотр(1);
Таб.Опции(0,0,4,0,Портрет);
Таб.ПараметрыСтраницы(1,,,Константа.ПолеСлева,Константа.ПолеСправа,Константа.ПолеСверху
,Константа.ПолеСнизу,,,1);
Таб.Показать("Остатки товаров","");
КонецПроцедуры
//--------------------------------------
Процедура ПриВыбореМОЛ()
Если ВыбМОЛ.Выбран()=1 Тогда
ВыбСклад=0;
Форма.ВыбСклад.Доступность(0);
Иначе
Форма.ВыбСклад.Доступность(1);
КонецЕсли;
КонецПроцедуры
//--------------------------------------
Процедура ПриВыбореЗакладки(Ном,Значен)
Если Значен="Общие" Тогда
  Форма.ИспользоватьСлой("Основной, Общий",2);
Иначе
  Форма.ИспользоватьСлой("Основной, Шины",2);
КонецЕсли;
КонецПроцедуры
//--------------------------------------
ДатаКонца=ПолучитьДатуТА();
СпВар.ДобавитьЗначение("Товар");
СпВар.ДобавитьЗначение("Поставщик=>Товар");
СпВар.ДобавитьЗначение("Поставщик=>Партия=>Товар");
СпВар.ДобавитьЗначение("Склад=>Товар");
СпВар.ДобавитьЗначение("Склад=>Поставщик=>Товар");
СпВар.ДобавитьЗначение("Склад=>Поставщик=>Партия=>Товар");
СпВар.ДобавитьЗначение("Товар=>Склад");
СпВар.ДобавитьЗначение("Товар=>Поставщик");
СпВар.ДобавитьЗначение("Товар=>Поставщик=>Партия");
СпВар.ТекущаяСтрока(1);
СпВал.ДобавитьЗначение("В валюте учета товара");
СпВал.ДобавитьЗначение("В рублях (пересчет)");
СпВал.ДобавитьЗначение("В долларах");
СпВал.ДобавитьЗначение("В рублях (по базовой стоимости)");
СпВал.ТекущаяСтрока(1);
ФлажокПечататьТовар=1;
Форма.ИспользоватьЗакладки(1);
Форма.Закладки.ДобавитьЗначение("Общие","Общие");
Форма.Закладки.ДобавитьЗначение("Шины","Шины");
Форма.ИспользоватьСлой("Основной, Общий",2);
Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #1 : 14-04-2011 11:48 » 

shmyga5, ну а в чем ты видишь помощь? Написать за тебя - это не сюда...
Объясняй: что ты понимаешь в этом коде, что не понимаешь, что пробовал и что не получилось.
Записан
Страниц: [1]   Вверх
  Печать  
 

Powered by SMF 1.1.21 | SMF © 2015, Simple Machines