Форум программистов «Весельчак У»
  *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

  • Рекомендуем проверить настройки временной зоны в вашем профиле (страница "Внешний вид форума", пункт "Часовой пояс:").
  • У нас больше нет рассылок. Если вам приходят письма от наших бывших рассылок mail.ru и subscribe.ru, то знайте, что это не мы рассылаем.
   Начало  
Наши сайты
Помощь Поиск Календарь Почта Войти Регистрация  
 
Страниц: [1]   Вниз
  Печать  
Автор Тема: Как из модуля формы обратиться к процедуре модуля объекта  (Прочитано 11875 раз)
0 Пользователей и 1 Гость смотрят эту тему.
MARY 1c
Интересующийся

ua
Offline Offline

« : 31-05-2012 14:07 » 

Добрый день, форумчане. Надеюсь на вашу «скорую» помощь в решении данного вопроса))).  В модуле объекта есть  процедура 
Код: (1C v8)
Процедура СформироватьОтчет(ДокументРезультат, ВидОтчета) Экспорт
……..
КонецПроцедуры
В модуле формы присутствует процедура :

Код: (1C v8)
&НаКлиенте
Процедура Сформировать(Команда)
        ЗаписатьНачальныйНомерЛиста();
        СформироватьНаСервере();
КонецПроцедуры

&НаСервере
Процедура СформироватьНаСервере()
        ОбъектОтчет = ДанныеФормыВЗначение(Отчет, Тип("ОтчетОбъект.КассоваяКнига"));
        ОбъектОтчет =  СформироватьОтчет(ДокументРезультат, Отчет.ВидОтчета);
        ЗначениеВДанныеФормы(ОбъектОтчет,Отчет);
КонецПроцедуры

При проверке модуля ругается на
{Отчет.КассоваяКнига.Форма.ФормаОтчетаУправляемая.Форма(13,17)}: Процедура или функция с указанным именем не определена (СформироватьОтчет)
   ОбъектОтчет =  <<?>>СформироватьОтчет(ДокументРезультат, Отчет.ВидОтчета); (Проверка: Толстый клиент (обычное приложение))

Заранее спасибо
Записан
Dest
Опытный

ru
Offline Offline

« Ответ #1 : 31-05-2012 22:14 » 

У вас в модуле  объекта "СформироватьОтчет"  это процедура, а вы обращаетесь к ней как к функции.
Записан
MARY 1c
Интересующийся

ua
Offline Offline

« Ответ #2 : 06-06-2012 08:47 » 

Простите новичка, пожалуйста, но в чем разница? А черт его знает...        Заранее спасибо
Записан
Dest
Опытный

ru
Offline Offline

« Ответ #3 : 07-06-2012 01:31 » 

Функции отличаются от процедур только тем, что возвращают ВозвращаемоеЗначение (Возврат <Возвращаемое значение>Ага.
А вообще в синтаксис помощник есть.
Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #4 : 13-06-2012 07:05 » 

Вместо
Код: (1C v8)
ОбъектОтчет =  СформироватьОтчет(ДокументРезультат, Отчет.ВидОтчета);
должно быть
Код: (1C v8)
ОбъектОтчет.СформироватьОтчет(ДокументРезультат, Отчет.ВидОтчета);
Записан
Страниц: [1]   Вверх
  Печать  
 

Powered by SMF 1.1.21 | SMF © 2015, Simple Machines