Форум программистов «Весельчак У»
  *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

  • Рекомендуем проверить настройки временной зоны в вашем профиле (страница "Внешний вид форума", пункт "Часовой пояс:").
  • У нас больше нет рассылок. Если вам приходят письма от наших бывших рассылок mail.ru и subscribe.ru, то знайте, что это не мы рассылаем.
   Начало  
Наши сайты
Помощь Поиск Календарь Почта Войти Регистрация  
 
Страниц: [1]   Вниз
  Печать  
Автор Тема: 1с82, самописная, внешняя обработка  (Прочитано 3507 раз)
0 Пользователей и 1 Гость смотрят эту тему.
asdfr1
Участник

ru
Offline Offline

« : 10-08-2012 06:36 » 

внешняя обработка.Необходимо заменить одно значение на другое.Проводок нет.Выбираю запросом
Код: (1C v8)
Что = ЭтаФорма.ЭлементыФормы.Что.Значение;
КонтрольнаяДата = ТекущаяДата();
НаКого =  ЭтаФорма.ЭлементыФормы.НаКого.Значение;


    Запрос = Новый Запрос;
    Запрос.Текст =
"ВЫБРАТЬ
|               Задача.Ссылка КАК Ссылка,
|               Задача.Представление,
|               Задача.ТочкаМаршрута,
|               ПРЕДСТАВЛЕНИЕ(Задача.ТочкаМаршрута),
|               Задача.Наименование,
|               Задача.Пользователь КАК Пользователь1,
|               ПРЕДСТАВЛЕНИЕ(Задача.Пользователь),
|               Задача.Создатель,
|               ПРЕДСТАВЛЕНИЕ(Задача.Создатель),
|               Задача.БизнесПроцесс.Номер
|       ИЗ
|               Задача.Задача КАК Задача
|       ГДЕ

|               Задача.Выполнена = ЛОЖЬ
|               И Задача.КонтрольныйСрок < &КонтрольнаяДата
|           И Задача.Пользователь = &Что
|
|ДЛЯ ИЗМЕНЕНИЯ"
;

а дальше непонятки :
  Для каждого Строка Из ТЗ Цикл
 Объект = Строка.Ссылка.ПолучитьОбъект();
Для каждого Строка Из ТЗ Цикл
         
Заменяемые.Вставить(Что, НаКого);
Объект.Записать();
КонецЦикла;  КонецЦикла;

и не записывает Жаль



Добавлено через 39 минут и 43 секунды:
или как-то так :  
      
Код: (1C v8)
Для каждого Строка Из ТЗ Цикл
Объект = Строка.Ссылка.ПолучитьОбъект();
Объект.Пользователь = НаКого;

Сообщить(Объект.Исполнитель);

Объект.Записать();
КонецЦикла;  КонецЦикла;
ткните кто-нибудь носом
« Последнее редактирование: 31-08-2012 07:23 от Kivals » Записан
asdfr1
Участник

ru
Offline Offline

« Ответ #1 : 11-08-2012 05:36 » 

обычная невнимательность, подсказали на другом форуме :

Код: (1C v8)
ТЗ = Запрос.Выполнить().Выгрузить();

Для каждого Строка Из ТЗ Цикл
Объект = Строка.Ссылка.ПолучитьОбъект();
Объект.Пользователь = НаКого;
Сообщить(Объект.Исполнитель);
Объект.Записать();
КонецЦикла; КонецЦикла;

тема закрыта Улыбаюсь
« Последнее редактирование: 31-08-2012 07:24 от Kivals » Записан
Страниц: [1]   Вверх
  Печать  
 

Powered by SMF 1.1.21 | SMF © 2015, Simple Machines