Форум программистов «Весельчак У»
  *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

  • Рекомендуем проверить настройки временной зоны в вашем профиле (страница "Внешний вид форума", пункт "Часовой пояс:").
  • У нас больше нет рассылок. Если вам приходят письма от наших бывших рассылок mail.ru и subscribe.ru, то знайте, что это не мы рассылаем.
   Начало  
Наши сайты
Помощь Поиск Календарь Почта Войти Регистрация  
 
Страниц: [1]   Вниз
  Печать  
Автор Тема: Возможно ли отслеживать активность пользователя 1С?  (Прочитано 2961 раз)
0 Пользователей и 1 Гость смотрят эту тему.
AndyG
Постоялец

by
Offline Offline

« : 30-10-2012 06:41 » 

Юзеры совершенно безответственны. Запустят сеанс 1с - и гулять.
Может кто решал уже эту проблему?

Вот что у меня получилось с использованием 1С++

Глобальный модуль: вставляем чуток кода в процедуры...

Код:
Перем СрочноВыйти;
Перем  ВремяПростоя,
Перем ПределБездействияСеанса //можно выветси в константы или определить в глобале


Процедура ВремяПростоя()
Если ВремяПростоя>ПределБездействияСеанса Тогда
СрочноВыйти=1;
ЗавершитьРаботуСистемы(0);
КонецЕсли;
ВремяПростоя=ВремяПростоя+30;
//Сообщить(ВремяПростоя);
КонецПроцедуры //ВремяПростоя
//--------------------------GAV---------------------------
Процедура ПриДвиженииМыши(Конт,Сост,КоордХ,КоордY,ФСО)
ВремяПростоя=0;
КонецПроцедуры
//--------------------------GAV---------------------------
Процедура ПриНажатииКнопкиКлавиатуры(Код,Альт,Шифт,Контрл,Символ,Флаг)
ВремяПростоя=0;
КонецПроцедуры
//--------------------------GAV---------------------------
Процедура ПриНачалеРаботыСистемы()
       // не забываем подключить 1С++

       Если ТекущаяИБЦентральная()=1 Тогда
ВремяПростоя=0;
ОбработкаОжидания("ВремяПростоя",30);
КонецЕсли;
КонецПроцедуры

//--------------------------GAV---------------------------
Процедура ПриЗавершенииРаботыСистемы()
      Если СрочноВыйти=0 Тогда
Если Вопрос("Вы действительно хотите завершить работу?","Да+Нет")="Нет" Тогда      
СтатусВозврата(0);
Возврат
КонецЕсли;
КонецЕсли;
КонецПроцедуры


ПределБездействияСеанса =3600;

« Последнее редактирование: 30-10-2012 07:37 от AndyG » Записан
Страниц: [1]   Вверх
  Печать  
 

Powered by SMF 1.1.21 | SMF © 2015, Simple Machines