Форум программистов «Весельчак У»
  *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

  • Рекомендуем проверить настройки временной зоны в вашем профиле (страница "Внешний вид форума", пункт "Часовой пояс:").
  • У нас больше нет рассылок. Если вам приходят письма от наших бывших рассылок mail.ru и subscribe.ru, то знайте, что это не мы рассылаем.
   Начало  
Наши сайты
Помощь Поиск Календарь Почта Войти Регистрация  
 
Страниц: [1]   Вниз
  Печать  
Автор Тема: Проблема с TWebBrowser  (Прочитано 4201 раз)
0 Пользователей и 3 Гостей смотрят эту тему.
Devil
Гость
« : 15-12-2004 07:10 » 

Вот возникла тут небольшая проблемка. Есть некий сайт назовем его www.bonus.com. При заходе на него с уникального IP адреса на внутренний счет зачисляется 0,1 уе. Если заходить IE или оперой то все ок начисляется, а если заходить при помощи броузера на основе TWebBrowser то зачисление не производиться, хотя загружается все ок. Может кто подскажет где тут подводные камни. Заранее благодарен. Дмитрий.
Записан
baldr
Команда клуба

ru
Offline Offline
Пол: Мужской
Дорогие россияне


WWW
« Ответ #1 : 04-01-2005 08:58 » new

Я не помню какие у этого компонента есть настройки. Но проблема, видимо, вот в чем.
В HTTP протоколе есть строка User-Agent, которая идентифицирует браузер посетителя. У IE, Opera, Netscape - есть свои идентификаторы. У твоей программы, видимо, свой собственный. Нужно сделать так, чтобы этот параметр у тебя подменялся идентификатором, например, IE.
А вообще - может там еще cookies используется?
Записан

Приличный компьютер всегда будет стоить дороже 1000 долларов, потому что 500 долларов - это не вполне прилично
Страниц: [1]   Вверх
  Печать  
 

Powered by SMF 1.1.21 | SMF © 2015, Simple Machines