Форум программистов «Весельчак У»
  *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

  • Рекомендуем проверить настройки временной зоны в вашем профиле (страница "Внешний вид форума", пункт "Часовой пояс:").
  • У нас больше нет рассылок. Если вам приходят письма от наших бывших рассылок mail.ru и subscribe.ru, то знайте, что это не мы рассылаем.
   Начало  
Наши сайты
Помощь Поиск Календарь Почта Войти Регистрация  
 
Страниц: [1]   Вниз
  Печать  
Автор Тема: Табличный отчет  (Прочитано 10614 раз)
0 Пользователей и 1 Гость смотрят эту тему.
schnibbl
Гость
« : 02-03-2005 17:11 » 

Помогите пожалуйста, сил моих больше нету.
Есть внешний отчет, у формы есть закладка таблица, задаю в ней имя "Табличка1" в этой табличке есть 3 секции (Шапка, Основная, Подвал). в модуле формы делаю так:
Табличка.СоздатьОбъект("Таблица");
Табличка.ИсходнаяТаблица("Табличка1");
программа вываливается на этой строке с сообщением не найден файл с именем Табличка.
делаю так:
Табличка.СоздатьОбъект("Таблица");
Табличка.ВывестиСекцию("Шапка");
Табличка.ВывестиСекцию("Основная");
Табличка.ВывестиСекцию("Подвал");программа вываливается на этой строке с сообщением не найдена секция подвал (И почему же это тогда она секцию Шапка нашла ?)
делаю так:
смотри выше заисключением закомментировал выводсекции Подвал, тогда вываливается при Табличка.Просмотр(); пишет Открытие окна в данном режиме недоступно!
всё что написал выше описано в учебниках Усикова и Бартеньева у них там мля типа работает, у меня не работает.
в двухтомнике 1С нашел упоминание что вроде как если мы используем таблицу, то нужно в Действия/Свойства формы/ использовать таблицу выбрать, но она вылазиет при открытии обработки и никаких проблем не решает - использовать пустую да появляется но в том виде как я её нарисовал с секциями тоже не хочет вылезать с теми же ошибками.
вот скажите пожалуйста, что надо для полного счастья ? чтобы пообщались с юзером, получили от него некоторые данные а потом показали ему таблицу (нарисованную не в глобальном модуле, и не в отдельном файле а в этом же), и всем было хорошо ? как эту самую таблицу инициализировать чтобы 1С поняла что реч идет о таблице которая в табличной части этой же внешней обработки находится ?

Записан
schnibbl
Гость
« Ответ #1 : 03-03-2005 07:05 » 

Чуш какая, то: захожу в конфигуратор, создаю новую обработку в ней такой текст:
Процедура Выполнить()
   перем Табличка;
   Табличка=СоздатьОбъект("Таблица");
   Табличка.ИсходнаяТаблица("Таблоид");
   Табличка.ВывестиСекцию("Шапочка");
   Табличка.ВывестиСекцию("Вывод");
   Табличка.ТолькоПросмотр(1);
   Табличка.Показать("Проба");
КонецПроцедуры
Обзываю встроенную таблицу именем Таблоид и помещаю туда секции Шапочка и Вывод - ВСЕ РАБОТАЕТ.
сохраняю отчет как внешнюю обработка - ВСЕ РАБОТАЕТ.
Копирую данный код в старую обработку один в один, переименовывают таблицу, переименовываю секции - выдает невозможно найти файл с именем Таблоид Не понял? ну как так может быть Не понял в этой обработке я с закладками работаю, может здесь где с видимостью проблема Не понял

ЗЫ. Вот похоже проблема в области действия переменных, создал отдельную процедуру и она с кнопки на форме вызывается - выводит таблицу, если к этой процедуре вывода табличной части обращаться из другой процедуры, то пишет ненаходит файл.
« Последнее редактирование: 03-03-2005 09:01 от schnibbl » Записан
schnibbl
Гость
« Ответ #2 : 03-03-2005 13:03 » 

Код:
Процедура СформироватьОтчет() //ПОДВЯЗАНА НА КНОПКУ (ВКЛАДКА ДОПОЛНИТЕЛЬНО)
Табличка=СоздатьОбъект("Таблица");
Табличка.ИсходнаяТаблица("Таблица1");
Табличка.ВывестиСекцию("Шапочка");
Табличка.Опции(0,0,0,0);
Табличка.ПараметрыСтраницы(2,100);
Табличка.ТолькоПросмотр(1);
Табличка.Показать("Пример");     
//при нажатии на кнопку эта процедура работает и таблица  находится
КонецПроцедуры

//Процедура СформироватьОтчет1();
// СформироватьОтчет();
//конецПроцедуры

Процедура ВводТекста() //ПОДВЯЗАНА на реквизит формы "РЕКВИЗИТ ДИАЛОГА" для ввода текста
Сообщить(Текстик); //идентификатор для реквизита формы "РЕКВИЗИТ ДИАЛОГА"
//Любое из нижеследующего в этой процедуры включить - работать не будет

//СформироватьОтчет1();

       //СформироватьОтчет();

       //Табличка=СоздатьОбъект("Таблица");
//Табличка.ИсходнаяТаблица("Таблица1");
//Табличка.ВывестиСекцию("Шапочка");
//Табличка.Опции(0,0,0,0);
//Табличка.ПараметрыСтраницы(2,100);
//Табличка.ТолькоПросмотр(1);
//Табличка.Показать("Пример");
конецПроцедуры

Процедура ПриОткрытии()
//Если раскомментировать далее то работает - таблицу выводит
//Табличка=СоздатьОбъект("Таблица");
//Табличка.ИсходнаяТаблица("Таблица1");
//Табличка.ВывестиСекцию("Шапочка");
//Табличка.Опции(0,0,0,0);
//Табличка.ПараметрыСтраницы(2,100);
//Табличка.ТолькоПросмотр(1);
//Табличка.Показать("Пример");
Форма.ИспользоватьСлой("Основной,Слой1");
//Если раскомментировать далее то работает - таблицу выводит
//Табличка=СоздатьОбъект("Таблица");
//Табличка.ИсходнаяТаблица("Таблица1");
//Табличка.ВывестиСекцию("Шапочка");
//Табличка.Опции(0,0,0,0);
//Табличка.ПараметрыСтраницы(2,100);
//Табличка.ТолькоПросмотр(1);
//Табличка.Показать("Пример");
КонецПроцедуры                                         

  // если раскомментировать далее, то "Файл таблица1 не найден"
    //Табл=СоздатьОбъект("Таблица");
//Табл.ИсходнаяТаблица("Таблица1");
//Табл.ВывестиСекцию("Шапочка");
//Табл.Опции(0,0,0,0);
//Табл.ПараметрыСтраницы(2,100);
//Табл.ТолькоПросмотр(1);
//Табл.Показать("Пример");

в общем если знает кто, как вызвать табличный отчет из процедуры связанной с полем ввода текста "реквизит диалога" расскажите пожалуйста Жаль
« Последнее редактирование: 03-03-2005 13:07 от schnibbl » Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #3 : 12-03-2005 10:24 » 

Лень переписавать все наново. Если вышлешь обработку по мылу - думаю смогу помочь
Записан
schnibbl
Гость
« Ответ #4 : 14-03-2005 11:08 » 

в общем как мне сказали таблицей что в самой обработке нарисована можно пользоваться только находясь в процедуре, которая на кнопку подвязана, любой другой элемент по непонятным причинам таблицу невидит.
Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #5 : 14-03-2005 16:40 » 

Бред какой-то (обидеть никого не хотел) Улыбаюсь
У меня формируется таблица и печатается даже не показывая документ (в процедуре ПриОткрытии)
При чем тут кнопки?
Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #6 : 14-03-2005 16:44 » 

Возникло предположение - не перепутал ли ты где-то в названиях русские и англиские буквы?
Ведь русская "Т" и англиская "T" выглядят одинаково, а названия естественно разные.
И таких букв в слове Таблица - 3 штуки Улыбаюсь (Т, а, а)
Записан
schnibbl
Гость
« Ответ #7 : 15-03-2005 06:42 » 

По поводу процедуры при открытии, я выше код написал и там вроде закомментированно что в ней у меня тоже работает, и того имеем что таблица видется из процедуры при открытии и процедуре подвязанной на кнопке, если использовать таблицу применяется в коде программе или в любой другой процедуре, то не нахидт такое имя..., даже более того если имеем рабоччаю процедуру, которая выводит таблицу, то вызвав эту процедуру в другой, связанной с каким нить элементом формы, получим что она опять теряет местонахождение таблицы...
не, щас прост овремени нету копать обработку и с нуля писать тоже (хотя 20 минут нарно), щас разгребусь вышлю тебе эту шнягу, но по моему я вроде бы Harry  её высылал уже..
« Последнее редактирование: 15-03-2005 06:46 от schnibbl » Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #8 : 15-03-2005 08:50 » 

Ок, жду...
Записан
Страниц: [1]   Вверх
  Печать  
 

Powered by SMF 1.1.21 | SMF © 2015, Simple Machines