Форум программистов «Весельчак У»
  *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

  • Рекомендуем проверить настройки временной зоны в вашем профиле (страница "Внешний вид форума", пункт "Часовой пояс:").
  • У нас больше нет рассылок. Если вам приходят письма от наших бывших рассылок mail.ru и subscribe.ru, то знайте, что это не мы рассылаем.
   Начало  
Наши сайты
Помощь Поиск Календарь Почта Войти Регистрация  
 
Страниц: [1]   Вниз
  Печать  
Автор Тема: An invalid argument was encountered  (Прочитано 8651 раз)
0 Пользователей и 1 Гость смотрят эту тему.
AndyG
Постоялец

by
Offline Offline

« : 09-07-2010 09:49 » 

Вот и на мою улицу пришел праздник:)
Познакомился я с данной ошибкой.

Подчиненный справочник, попытка сохранить изменения в форме элемента.
Опа!
"An invalid argument was encountered"
*опа:(
Программа виснет намертво - задачу приходится снимать.

Причем у элементов-соседей все в порядке!!!

Индексировал. Безрезультатно.
Возможно Тестирование/Исправление поможет, но не уверен, делал неделю назад, ставил все птички:)))
Открыл архив 30тидневной давности - то же элемент, тот же эффект.


Поискал в Инете собратьев по несчастью, есть такие.
http://www.buh.ru/forum/thread.jsp?id=478981


Релизы у нас разные, базы тем более:) терминал/не терминал - все одно. Да , ку меня тоже 2003, хотя, в этом ли дело?
Действительно, отладчик обозначил команду списка значений СортироватьПоПредставлению() местом глюка
но мне, замена ее на Сортировать() или/и указание направления сортировки не исправили положения.

Короче пока проблему не решил, выношу на обсуждение.



« Последнее редактирование: 09-07-2010 19:16 от AndyG » Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #1 : 09-07-2010 13:13 » 

СортироватьПоПредставлению - это вроде метод Списка значений.
Какой его размер?
Опубликуй код, который выполяется при сохранении элемента
Записан
AndyG
Постоялец

by
Offline Offline

« Ответ #2 : 09-07-2010 19:12 » 

Kivals,
Справочник рассчетные счета, подчинен Контрагентам

Процедура ПриЗакрытии()
    Если ТипЗначенияСтр(ВнКонтекст)="ГрупповойКонтекст" Тогда
      Если Записали = 1 Тогда
         Если ВводНового=1 Тогда
            ВнКонтекст.СписокСчетов.ДобавитьЗначение(ТекущийЭлемент(), Наименование+": р/с № "+СокрЛП(РасчетныйСчет)+" в "+СокрЛП(Банк));
            ВнКонтекст.СписокСчетов.СортироватьПоПредставлению();
            ВнКонтекст.СписокСчетов.ТекущаяСтрока(ВнКонтекст.СписокСчетов.НайтиЗначение(ТекущийЭлемент()));
            ВнКонтекст.Форма.КнИзменить.Доступность(1);
            ВнКонтекст.Форма.КнУдалить.Доступность(1);
         Иначе
            Поз=ВнКонтекст.СписокСчетов.НайтиЗначение(ТекущийЭлемент());
            ВнКонтекст.СписокСчетов.УдалитьЗначение(Поз);
            ВнКонтекст.СписокСчетов.ВставитьЗначение(Поз,ТекущийЭлемент(), Наименование+": р/с № "+СокрЛП(РасчетныйСчет)+" в "+СокрЛП(Банк));
            ВнКонтекст.СписокСчетов.СортироватьПоПредставлению();
            ВнКонтекст.СписокСчетов.ТекущаяСтрока(ВнКонтекст.СписокСчетов.НайтиЗначение(ТекущийЭлемент()));
         КонецЕсли;
         Если ВнКонтекст.ОсновнойРасчСчет.Выбран()=0 Тогда
            ВнКонтекст.ОсновнойРасчСчет=ТекущийЭлемент();
         КонецЕсли;
         ВнКонтекст.Форма.Обновить();
      КонецЕсли;
   КонецЕсли;
КонецПроцедуры

« Последнее редактирование: 10-07-2010 08:04 от AndyG » Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #3 : 10-07-2010 11:57 » 

Насколько я понял - ВнКонтекст ссылается на открытую форму элемента Контрагента - владельца счета.
Попробуй работать со списком на форме (ВнКонтекст.СписокСчетов) не напрямую, а через Выгрузить:
Код:
Сп=СоздатьОбъект("СписокЗначений");
ВнКонтекст.СписокСчетов.Выгрузить(Сп);
Сп.ДобавитьЗначение(...);
Сп.СортироватьПоПредставлению();
Сп.Выгрузить(ВнКонтекст.СписокСчетов);
Кстати: а что будет, если закрыть форму контрагента-владельца перед закрытием формы счета?
« Последнее редактирование: 10-07-2010 12:00 от Kivals » Записан
AndyG
Постоялец

by
Offline Offline

« Ответ #4 : 14-07-2010 08:35 » 

Ошибка исчезла так же как и появилась.
Это наводит на размышления...
Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #5 : 14-07-2010 21:33 » 

Я так понял ято ошибка наблюдалась только на одном компьютере...
Насколько чиста система (была ли поражена вирусными атаками, как часто ставится/удаляется софт, были ли ручные вмешательства в системные файлы, проходят ли регулярные обновления)? Нет ли проблем с памятью?
Записан
AndyG
Постоялец

by
Offline Offline

« Ответ #6 : 16-07-2010 04:45 » 

ошибка была на 1 компе - НА СЕРВАКЕ:)
антивирь стоит, глюков вроде не замечалось.
софт не ставлю, стоит необходимое, в систему не лезу
Обновление? Нет обновлений...
ошибка исчезла. Почему? не знаю...
Но кто-то из операторов потрогал этот элемент - Наименование немного изменено
Хотя, можно и архив поднять, проверить.
Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #7 : 18-07-2010 05:22 » 

Похоже на то, что какой-то "неправильный" (непечатный) символ попал в название. Тестирование/исправление помагает в этом случае
Записан
Страниц: [1]   Вверх
  Печать  
 

Powered by SMF 1.1.21 | SMF © 2015, Simple Machines