Форум программистов «Весельчак У»
  *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

  • Рекомендуем проверить настройки временной зоны в вашем профиле (страница "Внешний вид форума", пункт "Часовой пояс:").
  • У нас больше нет рассылок. Если вам приходят письма от наших бывших рассылок mail.ru и subscribe.ru, то знайте, что это не мы рассылаем.
   Начало  
Наши сайты
Помощь Поиск Календарь Почта Войти Регистрация  
 
Страниц: [1]   Вниз
  Печать  
Автор Тема: Ручные операции  (Прочитано 4237 раз)
0 Пользователей и 1 Гость смотрят эту тему.
kiser
Участник

by
Offline Offline

« : 14-09-2010 12:45 » 

Подскажите, пожалуйста, как из документа "Операция" из журнала "Операции введенные вручную или через регламентированный отчет" получить данные по каждой введенной операции, чтобы заполнить их в ТЗ. Проблема в том, что там нет табличной части, и как из него вытащить данные, не представляю.
« Последнее редактирование: 16-09-2010 07:41 от Sel » Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #1 : 14-09-2010 13:53 » 

см. в синтакс-помощнике ВыбратьПроводки() / ПолучитьПроводку()
Записан
kiser
Участник

by
Offline Offline

« Ответ #2 : 14-09-2010 14:03 » 

Код:
    ДокОп = СоздатьОбъект("Документ.Операция");
    ДокОп.ВыбратьДокументы(ВыбНачПериода,ВыбКонПериода);
    Пока ДокОп.ПолучитьДокумент()=1 цикл
        Если (ДокОп.ПометкаУдаления()=1) тогда
            Продолжить;
        КонецЕсли;
        ТекДок = ДокОп.ТекущийДокумент();
        ТекДок.ВыбратьПроводки();
        Пока ТекДок.ПолучитьПроводку() = 1 цикл
                  //...
        КонецЦикла;
    КонецЦикла;

ошибка
Код:
ТекДок.ВыбратьПроводки();
{Отчет.ю01_ОтчетПоНДС.Форма.Модуль(184)}: Поле агрегатного объекта не обнаружено (ВыбратьПроводки)
Записан
kiser
Участник

by
Offline Offline

« Ответ #3 : 14-09-2010 14:14 » 

Спс, Kivals. разобрался. Нужно так:
Код:
ДокОп = СоздатьОбъект("Документ.Операция");
ДокОп.ВыбратьДокументы(ВыбНачПериода,ВыбКонПериода);
Пока ДокОп.ПолучитьДокумент()=1 цикл
Если (ДокОп.ПометкаУдаления()=1) тогда
Продолжить;
КонецЕсли;
ПроводкиДокумента = СоздатьОбъект("Операция");
ПроводкиДокумента.НайтиОперацию(ДокОп.ТекущийДокумент());
ПроводкиДокумента.ВыбратьПроводки();
Пока ПроводкиДокумента.ПолучитьПроводку()=1 Цикл
СчДб = ПроводкиДокумента.Дебет.Счет;
        //...
КонецЦикла;
КонецЦикла;
Записан
Страниц: [1]   Вверх
  Печать  
 

Powered by SMF 1.1.21 | SMF © 2015, Simple Machines