Форум программистов «Весельчак У»
  *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

  • Рекомендуем проверить настройки временной зоны в вашем профиле (страница "Внешний вид форума", пункт "Часовой пояс:").
  • У нас больше нет рассылок. Если вам приходят письма от наших бывших рассылок mail.ru и subscribe.ru, то знайте, что это не мы рассылаем.
   Начало  
Наши сайты
Помощь Поиск Календарь Почта Войти Регистрация  
 
Страниц: [1]   Вниз
  Печать  
Автор Тема: Перечисление.ВидКонтрагентов  (Прочитано 4268 раз)
0 Пользователей и 1 Гость смотрят эту тему.
Nodir2525
Участник

Offline Offline

« : 14-10-2010 10:47 » 

Документ-Форма
-ПолноеНаименование(строка-50)(слой-"Наим")
-Адрес (строка-50)(слой-"Адр")
-ВидКонтрагента(Перечисление.ВидКонтрагентов)
   ВидКонтрагентов
   -Физические
   -Юридические
-----------------------------------------------------------------------
Форма-Документ-Модуль
Процедура ПриОткрытии()
   Форма.ИспользоватьЗакладки(1);
   Форма.Закладки.ДобавитьЗначение (1,"Контрагент");
   Форма.ИспользоватьСлой("Наим");
   Если ВидКонтрагента = Перечисление.ВидКонтрагентов.Физические Тогда
           Форма.ИспользоватьСлой("Наим");
   КонецЕсли;
    ПриЗаписиПерепроводить(1);
КонецПроцедуры
------------------------------------------------------------------------------

Справочник – Контрагенте тоже ест ВидКонтрагента.
тоже ВидКонтрагента(Перечисление.ВидКонтрагентов)

Как изменяется ВидКонтрагента в Справочник-Контрагенте через Документ.
Но в Справочик – Контрагент ВидКонтрагента связано с Слоями.(Форма)
Записан
Nodir2525
Участник

Offline Offline

« Ответ #1 : 21-10-2010 12:56 » 

Через Документ вводится данный.

Конфигурация
-Перечисления
--ВидКонтрагент
---Юр
---Физ

Данные водится через Документ
ВидКонтрагент Я выбрал «Юр»
ВидКонтрагент связано с формой (слойями).
Если Я выбрал Физ (рис-1)
Если Я выбрал Юр (рис-2)


У меня в Справочник-Контрагенте тоже ест ВидКонтрагент там тоже ВидКонтрагент связано с формой (слоями)

Что Я хочу,
Когда обработка документа чтобы в справочник-контрагенте тоже ВидКонтрагент тоже авто поменялся как в документе.
Если Документ – ВидКонтрагент – Юр
То в Справочник – Контрагенте тоже должно ВидКонтрагент – Юр


* рис-1.png (13.12 Кб - загружено 216 раз.)
* рис-2.png (129.4 Кб - загружено 236 раз.)
Записан
Kivals
Модератор

us
Offline Offline
Пол: Мужской

WWW
« Ответ #2 : 24-10-2010 08:34 » 

Слои - это элементы формы (визуальной), реквизит - это элемент сущности (в твоем случае - справочника, объекта БД).
Соответственно реквизит со слоями должен быть связан событями. Тебе нужно обработать 2 события: при изменении реквизита и при открытии формы уже записанного элемента. Причем желательно из этих событий вызвать одну и ту же функцию работы со слоями.
Так в чем собственно твой вопрос?
Записан
Nodir2525
Участник

Offline Offline

« Ответ #3 : 25-10-2010 12:46 » 

Форма-Документ-Модуль
Процедура ПриОткрытии()
   Форма.ИспользоватьЗакладки(1);
   Форма.Закладки.ДобавитьЗначение (1,"Контрагент");
   Форма.ИспользоватьСлой("Наим");
   Если ВидКонтрагента = Перечисление.ВидКонтрагентов.Физические Тогда
           Форма.ИспользоватьСлой("Наим");
   КонецЕсли;
    ПриЗаписиПерепроводить(1);
КонецПроцедуры

Модуль-Документа
Процедура ОбработкаПроведения()
СпрК=СоздатьОбъект("Справочник.Контрагент");
СпрК.Новый();
СпрК.Наименование=СокрЛП(Фамилия)+" "+СокрЛП(Имя)+" "+СокрЛП(Отчество);
СпрК.Записать(); 
УстановитьРеквизитСправочника(СпрК,"Фамилия",Фамилия,ДатаДок);
УстановитьРеквизитСправочника(СпрК,"Имя",Имя,ДатаДок);
УстановитьРеквизитСправочника(СпрК,"Отчество",Отчество,ДатаДок);
..........
..........
КонецПроцедуры

Когда Я документ обрабатвиется в Справочник.Контрагенте ВидКонтраген не меняется?
Записан
Страниц: [1]   Вверх
  Печать  
 

Powered by SMF 1.1.21 | SMF © 2015, Simple Machines